LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-03-2003, 07:31 AM   #1
computerguy121
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Rep: Reputation: 0
named default configuration file


Hi,

I am having problems with named, i find if i start it in the configuration directory (/etc/) it works fine however if i chose any other directory it claims it's started when it has'nt.

The command for stopping works, only if started from /etc/ directory, suggesting the '/etc/rc.d/init.d/named start' only claims to start the process
Quote:
[root@linux etc]# /etc/rc.d/init.d/named stop
Stopping named: [ OK ]

This command claims its started when it has'nt
Quote:
[root@linux etc]# /etc/rc.d/init.d/named start
Starting named: [ OK ]
However if its started using the following it works fine every-time

Quote:
[root@linux etc]# pwd
/etc
[root@linux etc]# named

Is there any way i can get this command to work , so it starts on boot-up

/etc/rc.d/init.d/named start

Any ideas appreciated. --
 
Old 01-03-2003, 07:56 AM   #2
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
when you've cd to /etc you're actually running the named in /usr/sbin

try editing the /etc/rc.d/init.d/named file and getting rid of any junk on the line that starts "named", sometimes they put in arguments after "named" that don't work or they prefix it with "daemon".


Last edited by niknah; 01-03-2003 at 07:57 AM.
 
Old 01-03-2003, 08:09 AM   #3
computerguy121
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks that was so helpful did not relise /etc/rc.d/init.d/named was a file

Quote:

start() {
# Start daemons.
gprintf "Starting %s: " $prog
if [ -n "${ROOTDIR}" -a "x${ROOTDIR}" != "x/" ]; then
OPTIONS="${OPTIONS} -t ${ROOTDIR}"
fi

daemon named -c /etc/named.conf

# Line changed 03/01/02 - no longer lies about starting
#daemon named -u named ${OPTIONS}


RETVAL=$?
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/named
echo
return $RETVAL
}
I have changed the startup as listed above and it works perfect thanks!!!!!!!!!

Last edited by computerguy121; 01-03-2003 at 08:18 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with the named.conf-file configuration dmarkic Linux - Networking 3 07-07-2005 10:07 AM
Modify named.conf file pkrishna10 Linux - Networking 3 10-22-2004 01:03 PM
How do i create named.conf file pkrishna10 Linux - Wireless Networking 2 10-22-2004 12:54 PM
Missing /etc/named.conf file deepika Linux - Networking 10 09-12-2003 04:58 PM
DNS and named.local file Breezwell Linux - Networking 0 04-23-2001 07:05 PM


All times are GMT -5. The time now is 04:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration