LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   mysqld running and reading for connections on port 3306, no port 3306 found from scan (http://www.linuxquestions.org/questions/linux-networking-3/mysqld-running-and-reading-for-connections-on-port-3306-no-port-3306-found-from-scan-364970/)

darkenigmaa 09-19-2005 02:38 PM

mysqld running and reading for connections on port 3306, no port 3306 found from scan
 
I'm trien to connect to mysql server remotely. my.cnf file has #skip networking commented out. but when I have mysqld server running. it says its ready for connections through socket..., port =3306. but when i try a port scan for this nothing comes up. why is this? i know i cant remote connect to it if the port doesnt show up with a port scan. what do i have to change for settings to allow this to happen.

Darkenigma

Snowbat 09-20-2005 07:56 AM

From a shell on the server can you telnet to port 3306? Did you pinhole port 3306 in the server's firewall? If you're behind a NAT router, have you port forwarded 3306 to this box?

# telnet localhost 3306
Trying 127.0.0.1...
Connected to localhost (127.0.0.1).
Escape character is '^]'.
.
4.0.11a-gamma▒|p<wet8Y
(The connection times out after a few seconds of no input)

darkenigmaa 09-20-2005 09:34 AM

When i telnet localhost 3306 i get this:

#telnet localhost 3306
trying 127.0.0.1....
telnet: connect to address 127.0.0.1: connection refused

I have the servers firewall disabled, because the server itself is behind a firewall with port 3306 open.

Snowbat 09-20-2005 10:11 AM

mysqld is running?:
ps -A | grep mysqld

You've set a root password and you can use the mysql command to create a database?
http://www.yolinux.com/TUTORIALS/Lin...rialMySQL.html

darkenigmaa 09-20-2005 11:49 AM

yes mysqld is running and i can log on to it locally and create databases. But only locally. I need to be able to connect to it remotely

darkenigmaa 09-20-2005 05:01 PM

I finally got it. Thanks snowbat for your help =D

Snowbat 09-20-2005 09:35 PM

No worries. What was it (as a matter of interest and for the next person who has a similar problem)?

darkenigmaa 09-21-2005 10:10 AM

My internal fire was disabled, but not bypassed. Had to take it completely out i think it was /etc/SuSEfirewall112. it was also causeing ping problems aswell. so once i found that out it lead me in the right direction.


All times are GMT -5. The time now is 02:42 AM.