LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-14-2004, 04:04 PM   #1
Max P0wer
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
My laptop receives an IP via DHCP, but can't ping router or outside IP's!


Hi all. New here, and new to Linux in general. Nice looking place though, looks like there is a ton of helpful folks around.

So a while back I made the move to Linux from Win, on my home comp, and I'm very happy. Linux is pretty damn cool. Gaim for instance, and many more examples of course. The whole open-source and GNU thing is very cool to my mind. Anyhow, Fedora Core 2 installed really slick, no problems. My machine sits behind a Linksys router, and has a fixed IP. No connection problems at all.

Now. I wanted to take a stab at getting my laptop cooking with Linux as well. IT's a Toshiba Satellite Pro 4600. Old laptop, not really enough room for the dual boot thing, although that is what I'm doing now. I'm just not really a dual boot sort of guy. If Linux is going to be my os, then it's going to be my os. All or nothing right?

So under Fedora Core 2 everything is pretty good, except for a few things. The winmodem of course. Almost got it going with Smartlink's AMR modules, but whatever. Thing is a little unstable. Don't really need the modem anyhow. Audio is not working, I'll tackle it later though. The big thing is my NIC is not really working right. Well I think it is, but my network settings must be wrong or something.

The thing is, the card (Intel 100/Pro VE) is recognized and the e100 module loaded, it receives an ip via DHCP, but i can't ping out anything. Not the router, not my other Linux box, not an external ip either(aka the internet!)

So I think the driver(module?) works, the hardware works, because I don't believe it would get an ip if it didn't. Tried it with a static ip, like my other Linux machine, and my winblows box which sits on the same network. No dice.

Got frustrated, tried SuSE 9.1. This distro hangs at boot, right around the 'starting pcmcia' message, but tried passing the no pcmcia commands, no acpi, etc.. at boot with no success. It will however boot in 'failsafe' mode, and surprise of surprises, the same card was detected, same module loaded, and bang, it works. In failsafe i guess maybe the video card is handled a little differently, perhaps with a generic driver, cause the max resolution was 780 or whatever. Not so good anyhow.

I figure FC2 is the way to go, as I will probably need the pcmcia at some point, if i ever want to get a modem running(on the road a lot w. work), and I'd like to get a wireless nic going one day as well.

I've tried installing the latest driver from Intel's site, no success, but again I think that card and driver are working cause of the successful DHCP request.

Thought maybe it was a firewall/iptables problem, although there was no such trouble with my home comp, so I disabled the firewall in config-network or whatever the FC2/Gnome GUI tool is called. Maybe it was the Preferences/Security menu. Dunno. Anyway, still no success.

Googled my brains out for weeks now, literally, and no deal. The closest I've gotten was to read that maybe it was "the old IPV6 fedora problem"(?). So I read on, disabled it with "alias net-pf-10 off" (without quotes) in modprobe.conf. Again, nadda.

Any ideas folks? I'm desperate over here. Without the internet connection I can't troubleshoot and learn how to fix my audio problems, etc... any the comp is basically a boat anchor without the internet, as we all know...hehehe.
Oh, I get the same problems trying to connect from hotels I stay at with work, where I also successfully get an assigned ip, etc... I can connect with winblows from the hotels no prob. Same deal there i suppose, a router, dhcp, and so on.

I will of course be very happy to post any logs or iptables -L outputs or whatever is required!

Anyhow, TIA for any help people. Jeez, thats a novel up there! My memoirs would be shorter...

-Max
 
Old 08-14-2004, 05:49 PM   #2
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Could you post the following output of

lspci

dmesg | grep eth0

ifconfig

route -n
 
Old 08-14-2004, 06:31 PM   #3
Max P0wer
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
# lspci
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 11)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 11)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 03)
00:1f.0 ISA bridge: Intel Corp. 82801BAM ISA Bridge (LPC) (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801BAM IDE U100 (rev 03)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 03)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 03)
00:1f.6 Modem: Intel Corp. Intel 537 [82801BA/BAM AC'97 Modem] (rev 03)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/XP (rev 63)
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
02:0d.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 31)
02:0d.1 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 31)


# dmesg | grep eth0
divert: allocating divert_blk for eth0
e100: eth0: e100_probe: addr 0xf7dff000, irq 11, MAC addr 00:00:39:71:32:2C
divert: freeing divert_blk for eth0
divert: allocating divert_blk for eth0
e100: eth0: e100_probe: addr 0xf7dff000, irq 11, MAC addr 00:00:39:71:32:2C
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex


# ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:39:71:32:2C
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:342 (342.0 b) TX bytes:342 (342.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2224 errors:0 dropped:0 overruns:0 frame:0
TX packets:2224 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2295379 (2.1 Mb) TX bytes:2295379 (2.1 Mb)


# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0


Thanks for the quick response man!

Again, TIA.


-Max
 
Old 08-14-2004, 06:51 PM   #4
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Everything looks fine.
You should be able to ping you network.
The default gatetway (internet router) is 192.168.1.1
and you cannot ping 192.168.1.1 ?
 
Old 08-16-2004, 03:40 PM   #5
Max P0wer
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
Yeah affirmative. I cannot ping 192.168.1.1

I can ping 192.168.1.101 naturally (I suppose), but the router and anything else generate this:

"Destination Host Unreachable"

I dunno.

If I'm getting an IP assigned by DHCP then the card works right? Not a hardware issue right? Dunno....
 
Old 08-16-2004, 06:13 PM   #6
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
I read something about problem with auto negotiation

add this to /etc/modules.conf
options e100 Duplex=full Speed=100 FlowControl=3
 
Old 08-16-2004, 11:45 PM   #7
daqueej
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 2

Rep: Reputation: 0
Same Problem with Toshiba Satellite

I have the same problem and have tried many of the same things. I am not that knowledgeable about hardware and networking, but it does appear to be a problem with FC2. FC1 was on the laptop before I did a fresh install, and it worked fine with the same setup.

A possibly related issue: what is the mysterious 169.254.0.0 entry in the route listing? I noticed you have that as well.

Any help anyone can provide would be appreciated by me as well.

Thank you.
 
Old 08-17-2004, 12:08 AM   #8
daqueej
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 2

Rep: Reputation: 0
Bugzilla Item

This looks relevant: https://bugzilla.redhat.com/bugzilla....cgi?id=107389
 
Old 08-17-2004, 03:45 PM   #9
Max P0wer
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by arno
I read something about problem with auto negotiation

add this to /etc/modules.conf
options e100 Duplex=full Speed=100 FlowControl=3

Hey arno, I don't have modules.conf... would modprobe.conf be the same thing?

Threw it in there anyhow, rebooting....

Thanks, I'll let ya know how it goes.
 
Old 08-17-2004, 04:55 PM   #10
Max P0wer
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
oops

Okay putting the "options" thing in modprobe caused the e100 module not to be loaded at boot.

So no dice!

Thanks anyhow arno! I'll keep messing around with it.
 
Old 08-17-2004, 05:05 PM   #11
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Max P0wer,

Are you sure that there is no modules.conf in the /etc map
Then create one and put in
alias eth0 e100
options e100 Duplex=full Speed=100 FlowControl=3
 
Old 08-17-2004, 06:43 PM   #12
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Disregard my last entry you probably have a 2.6 kernel and they don't use modules.

I had a closer look at the output off route and 169.254.0.0 has not a valid function

remove it

route del -net 169.254.0.0 netmask 255.255.0.0 dev eth0
 
Old 08-17-2004, 06:45 PM   #13
bastard23
Member
 
Registered: Mar 2003
Distribution: Debian
Posts: 275

Rep: Reputation: 30
modprobe.conf essentially replaces modules.conf. Syntax is similar enough. I missed it the first time too (Mandrake 10 had both, or maybe I just made it. ;) Plus, this suse 9 has modprobe (uses modprobe.conf) and modprobe.old (uses modules.conf, conf.modules). YMMV.

the 169.154.0.0 in the route table may come from a failed DHCP client (Sets it to a private address until it can get a real address.).

There doesn't seem to be any errors from your ethernet driver (dmesg|grep eth0 or dmesg|grep e100). I don't know if it is a hardware issue.

Is 192.168.0.101 the same IP address you get under windows? Is 192.168.0.1 the router (default gateway)?

Make sure you don't have dhcpd installed (this is the DHCP server), dhclient or dhcpcd (DHCP client daemon) is OK.

Lets try to bring up the interface manually (# are comments):

# bring down the interface
ifdown eth0

# Make sure no dhcp agents are running (I thing fedora uses isc dhcp)
# Please post if you get anything here (execpt matching the grep itself)
ps -ef|grep dhc

# Check the interface, Only should have lo, no eth0
ifconfig

# Reload the module
modprobe -r e100
# Here you could add the module params at the end. The first time
# don't (cause we want to see what mii-tool comes up with "naturally")
# Not everybody has a 100mib switch.
modprobe e100

# "activate" the device, no configuration.
ifconfig eth0 up

# see what ethernet settings we negotiated (post the results)
mii-tool

# Now run packet sniffing to see what is happening
# capture on eth0, the whole packet, write to /home/root/file1.tcp
# run in background. Remember to kill this off later.
tcpdump -i eth0 -s0 -w ~/file1.tcp &

# Now setup the interface
ifconfig eth0 192.168.0.101 netmask 255.255.255.0

# We won't worry about routing yet.
# see if we can talk to our gateway
ping 192.168.0.1
# Ctrl-C to exit
# Did it work?

# Let's try dhcp "manually"
# I don't know what fedora uses, so this may fail
dhclient eth0

# check config
ifconfig eth0

# test again
ping 192.168.1.1
# Kill off tcpdump
jobs
# see which job it was
# The only thing you can't copy and paste
kill %num

# Take a look at our packet capture
# This should be around 10-20 lines
tcpdump -vn -r ~/file1.tcp | less
# Post the results if either ping fails.



Not sure why I'm being so verbose today. But hopefully one of these commands will show us why it isn't working.

Good Luck,
chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't ping my internal IP's jaanus Linux - Networking 14 08-25-2005 08:15 PM
Home network: connecting to a Linksys router for DHCP IP address - no ping gunther Linux - Networking 28 05-20-2005 11:14 PM
howto relay ISPs dhcp ip's though linux router to LAN deice Linux - Networking 0 09-20-2004 12:40 PM
Can ping IP's, but not names. Why??? JeffreyKunkle Linux - Newbie 3 08-30-2004 12:22 PM
Wireless laptop sees router but can't ping anything darin3200 Linux - Laptop and Netbook 5 07-30-2004 10:11 AM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration