LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   My DNS Server doesnt work, what's wrong? (http://www.linuxquestions.org/questions/linux-networking-3/my-dns-server-doesnt-work-whats-wrong-494151/)

saudoi 10-20-2006 12:26 PM

My DNS Server doesnt work, what's wrong?
 
My /etc/named.conf

Code:


//
// named.conf for Red Hat caching-nameserver
//

options {
        directory "/var/named";
        dump-file "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        /*
        * If there is a firewall between you and nameservers you want
        * to talk to, you might need to uncomment the query-source
        * directive below.  Previous versions of BIND always asked
        * questions using port 53, but BIND 8.1 uses an unprivileged
        * port by default.
        */
        // query-source address * port 53;
        forwarders {
                192.168.1.254;
                };
};

//
// a caching only nameserver config
//
controls {
        inet 192.168.1.2 port 53 allow { 192.168.1.0; } keys { rndckey; };
};


include "/etc/rndc.key";



zone "0.1.168.192.in-addr.arpa" {
        type master;
        file "/var/named/192.168.1.0.rev";
        };
zone "ipcoms.com" {
        type master;
        file "/var/named/ipcoms.com.hosts";
        };

When I try "nslookup" at this linux box, it seems okay, can resolve name to ip. However, when i try to point DNS server on Windows box to that server, use "nslookup" to test, it responds that not found server.

What's wrong???

twantrd 10-20-2006 01:43 PM

Can the windows box hit port 53 on your linux dns server?

-twantrd

alienux 10-20-2006 01:55 PM

Yes, typical linux firewalls do not open port 53 by default. Make sure you open that port on the DNS server if you have a firewall enabled.

saudoi 10-21-2006 12:40 AM

I have opened port TCP/53 and UDP/53 however clients still can not send a query to it!!!

alienux 10-21-2006 06:32 AM

Two questions:

1. Is the Windows box on the same subnet as the DNS server?

2. Is there any other firewall between the two machines?

twantrd 10-22-2006 03:26 AM

From the windows box, telnet to port 53 on your dns server. That will let you know right away.

-twantrd

linuxjamil 10-22-2006 05:09 AM

DNS Entry
 
zone "0.1.168.192.in-addr.arpa" {
type master;
file "/var/named/192.168.1.0.rev";
};



first of all errors------in the zine entry zone "0. will not be . That means last octet will not be in the zone entry


it will be
zone "1.168.192.in-addr.arpa"

saudoi 10-22-2006 10:14 PM

1. My Windows box stays on the same subnet with Linux box.
2. There's a firewall on Linux box but port 53 is opened. I capture packet by Ethereal and see request and reply packet on port 53.
3. Maybe my reverse lookup zone was wrong as linuxamil comment. I will try to modify it.

Anyways, after i have rebooted Linux box, my BIND seems not running now. I can not nslookup though I am on the Linux. I have stared named deamon:
Code:

[root@spider ~]# ps -ef | grep named
named    3272    1  0 Oct21 ?        00:00:00 /usr/sbin/named -u named -t /var/named/chroot
root    11282 11249  0 21:22 pts/1    00:00:00 grep named
[root@spider ~]#

Any idea?

saudoi 10-23-2006 12:02 AM

hey, my DNS is working now after i've modified the reverse lookup zone. Thank all you guys for ur great help.


All times are GMT -5. The time now is 07:36 PM.