LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   My datacard goes online but doesn't gives internet access (Fedora 14) (http://www.linuxquestions.org/questions/linux-networking-3/my-datacard-goes-online-but-doesnt-gives-internet-access-fedora-14-a-852351/)

one_harsh 12-25-2010 01:03 PM

My datacard goes online but doesn't gives internet access (Fedora 14)
 
I am using MTS datacard. I have usb_modeswitch installed and have configured the wvdial.conf file. When I do sudo wvdial cdma, the IPs and DNS addresses are also allocated but I still cant access internet. The reply to
Code:

dmesg | grep -e 'tty' -e 'modem'
is:

Code:

[ 0.000000] console [tty0] enabled
[ 11.098238] USB Serial support registered for GSM modem (1-port)
[ 11.098352] option 6-1:1.0: GSM modem (1-port) converter detected
[ 11.102170] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 11.102207] option 6-1:1.1: GSM modem (1-port) converter detected
[ 11.102334] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 11.102364] option 6-1:1.2: GSM modem (1-port) converter detected
[ 11.102488] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB2
[ 11.102522] option 6-1:1.3: GSM modem (1-port) converter detected
[ 11.102643] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB3
[ 11.102672] option 6-1:1.4: GSM modem (1-port) converter detected
[ 11.102793] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB4
[ 11.103074] option: v0.7.2:USB Driver for GSM modems

Can anyone tell me what shall I do?

one_harsh 12-31-2010 06:37 AM

well, after a lot of googling, I found that the DNS entry that should have been made be the network-manager wasn't made. so, I had to manually do that by editing the /etc/resolv.conf file and restarted the network.

Code:

# Generated by NetworkManager


# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
nameserver 8.8.8.8
nameserver 8.8.4.4
# DOMAIN=lab.foo.com bar.foo.com

This solved the problem.


All times are GMT -5. The time now is 07:19 PM.