LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   multipath not active/active (http://www.linuxquestions.org/questions/linux-networking-3/multipath-not-active-active-922955/)

td3201 01-09-2012 09:50 PM

multipath not active/active
 
All of my iscsi volumes are showing similar to the following on a multipath -ll:
Code:

mpathf (36090a018a01a76cfcae0b4427b02b075) dm-10 EQLOGIC,100E-00
size=6.0T features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=1 status=enabled
| `- 18:0:0:0 sdl 8:176  active ready running
|-+- policy='round-robin 0' prio=1 status=active
| `- 17:0:0:0 sdn 8:208  active ready running
`-+- policy='round-robin 0' prio=1 status=enabled
  `- 26:0:0:0 sdv 65:80  active ready running

Does the status=enabled mean that it's ready to take over but not being actively used?

I don't have path_grouping_policy set in multipath.conf which means that it should be set to multibus by default. That's the only thing I can think of here. Anyone have any other ideas?

td3201 01-09-2012 10:45 PM

Hmmm. The dm-multipath doc from redhat says that path_grouping_policy is set to failover by default but MULTIPATH.CONF(5) says that it's multibus. Fail.

How do I apply a change like path_grouping_policy on the fly w/out causing an interruption?

td3201 01-09-2012 10:57 PM

This is just stupid. The man page doesn't document the -r option as indicated in the -h help output:

Code:

[root@omadvnfs01c ~]# multipath -h
multipath-tools v0.4.9 (04/04, 2009)
Usage:
  multipath [-c] [-d] [-r] [-v lvl] [-p pol] [-b fil] [-q] [dev]
  multipath -l|-ll|-f [-v lvl] [-b fil] [dev]
  multipath -F [-v lvl]
  multipath -h

Where:
  -h      print this usage text
  -l      show multipath topology (sysfs and DM info)
  -ll    show multipath topology (maximum info)
  -f      flush a multipath device map
  -F      flush all multipath device maps
  -c      check if a device should be a path in a multipath device
  -q      allow queue_if_no_path when multipathd is not running
  -d      dry run, do not create or update devmaps
  -r      force devmap reload
  -p      policy failover|multibus|group_by_serial|group_by_prio
  -b fil  bindings file location
  -p pol  force all maps to specified path grouping policy :
          . failover            one path per priority group
          . multibus            all paths in one priority group
          . group_by_serial    one priority group per serial
          . group_by_prio      one priority group per priority lvl
          . group_by_node_name  one priority group per target node
  -v lvl  verbosity level
          . 0 no output
          . 1 print created devmap names only
          . 2 default verbosity
          . 3 print debug information
  dev    action limited to:
          . multipath named 'dev' (ex: mpath0) or
          . multipath whose wwid is 'dev' (ex: 60051..)
          . multipath including the path named 'dev' (ex: /dev/sda)
          . multipath including the path with maj:min 'dev' (ex: 8:0)

Either way, here's what I did to fix my situation:

Code:

multipath -p multibus
multipath -r

You might be able to combine these into
Code:

multipath -r -p multibus
, who knows.


All times are GMT -5. The time now is 08:16 AM.