LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-13-2005, 08:36 PM   #1
cmd0a0
LQ Newbie
 
Registered: Oct 2004
Posts: 13

Rep: Reputation: 0
Mounting windows xp file system, creates mnt point, however, cant read files in share


Attempting to mount windows xp file system share on seperate machine.

When I use:
mount -t smbfs //servername/share /mountpoint

Receive warning 'Ignoring badly formed line in conjunction file: read only -yes'

When I df, the mount point has been created to the windows file system with an accurate block %. However, when I cd to mount point, there is no reference to my share directory or files within the directory.

Please advise on course of action.

Can ping to / from host remote using host name, ip, fully qualified names.

Also tried mount -t vfat //servername/share /mountpoint
Recv: special device does not exist.

I can ping servername being used.

Last edited by cmd0a0; 04-13-2005 at 09:29 PM.
 
Old 04-14-2005, 05:19 AM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
try grepping your conj. files (or all your files...) for `read only -yes', and fix any appropriate file that shows up.
 
Old 04-14-2005, 05:23 AM   #3
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Rep: Reputation: 30
due to permission.
check ur shared file is view by others.

give read mode.
 
Old 04-14-2005, 05:38 AM   #4
Rinish
Member
 
Registered: Apr 2005
Location: Bangalore
Distribution: Redhat, CentOS, AIX
Posts: 93

Rep: Reputation: 15
mount -t smbfs - o username=loginname //hostname/share /mnt/mountdir
 
Old 04-14-2005, 05:39 AM   #5
Rinish
Member
 
Registered: Apr 2005
Location: Bangalore
Distribution: Redhat, CentOS, AIX
Posts: 93

Rep: Reputation: 15
this should work ^


thanks,
Rinish.P
 
Old 04-14-2005, 09:54 AM   #6
cmd0a0
LQ Newbie
 
Registered: Oct 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Rinish, this worked well:
mount -t smbfs - o username=loginname //hostname/share /mnt/mountdir

I now configured fstab to mount upon boot.

my syntax in fstab:

servername/share /mountpoint vfat <args>

Question with <args>: all files s/b rw,exec for applmgr user or dba group mbrs. Also, as applmgr, should be able to chmod,chgrp,chown as applmgr.
Currently, even as root, unable to change permisions.

I did read that the following args will work:
rw,exec,nosuid,nodev,user.

What do you think. Thanks.

Last edited by cmd0a0; 04-14-2005 at 12:45 PM.
 
Old 04-14-2005, 02:59 PM   #7
cmd0a0
LQ Newbie
 
Registered: Oct 2004
Posts: 13

Original Poster
Rep: Reputation: 0
After doing more reading, I did find out that you cannot change the permissions when using vfat. Ultimately, you can set options to allow users / group the appropriate permissions to the dir / files.

That said, I will attempt to use the umask, uid and gid options and ensure that I can read/write files on the file system as applmgr & dba group.

Thanks.
 
Old 04-14-2005, 08:48 PM   #8
cmd0a0
LQ Newbie
 
Registered: Oct 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Still cant get the proper config using fstab. Upon boot, it states that it cannot identify my device. So i go back to the mount at the command line. I am able to mount, however, cannot write a file out to share on file system as user applmgr, even though i have specified the user explicitly.

I can however, edit any doc in the dir !

Any advise would be greatly appreciated.

Last edited by cmd0a0; 04-14-2005 at 08:53 PM.
 
Old 04-15-2005, 02:49 AM   #9
Rinish
Member
 
Registered: Apr 2005
Location: Bangalore
Distribution: Redhat, CentOS, AIX
Posts: 93

Rep: Reputation: 15
in ur fstab try with this
//host/share /mnt/mountdir smbfs uid=username,gid=groupname,username=username/domainname 0 0


Thanks,
Rinish.P
 
Old 04-15-2005, 10:15 AM   #10
cmd0a0
LQ Newbie
 
Registered: Oct 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for everyones assistance. Was able to resolve in fstab with :

//hostname/share /mnt/rman smbfs username=xxxx,password=xxxx,uid=500,gid=500,rw
 
Old 04-16-2005, 01:28 AM   #11
Rinish
Member
 
Registered: Apr 2005
Location: Bangalore
Distribution: Redhat, CentOS, AIX
Posts: 93

Rep: Reputation: 15
that was great cmd0a0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can see but cant read files on windows share, help a newb out! eonicrush Linux - Networking 2 04-11-2005 04:03 PM
/mnt ...Read Only File System rblampain Linux - Distributions 4 12-30-2004 12:16 AM
cannot create directory `/mnt/win_d/MP3': Read-only file system PapaJac Mandriva 11 03-04-2004 06:25 AM
cannot create directory `/mnt/win_d/MP3': Read-only file system PapaJac Mandriva 0 03-02-2004 05:09 PM
mounting linux share point on windows jolu2000 Linux - Software 1 04-18-2003 10:36 AM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration