LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-21-2010, 08:06 AM   #1
chrislski
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Rep: Reputation: 0
Mounting Windows share using fstab but the mount folder doesn't populate automaticall


I have a RHEL 5.5 box which I am using the fstab to mount a Windows share automatically. I am using the below line to set up the mount.

//servername.local.domain/sharename /mnt/sharename cifs user,uid=500,rw,suid,username=adusername,password=password 0 0

This appears to work somewhat as the share shows up in the Computer location in Gnome. When you go to the /mnt/sharename directory there is nothing in it. If you open the share from the Computer location /mnt/sharename all of a sudden shows everything in the share and works like normal.

What am I missing in order to get the mount folder to show everything in the share automatically?
 
Old 04-21-2010, 06:41 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
I believe the problem is that fstab happens before the network is up, so it can't mount the share properly.

_netdev option is the key, but there are other things you need to take care of, like not putting your username and password where everybody can see them.

See this post :
http://www.linuxquestions.org/questi...-fstab-667392/
 
Old 04-22-2010, 06:49 AM   #3
chrislski
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Original Poster
Rep: Reputation: 0
I was planning on following the steps here to hide the password but I wanted to get it working first.

I am off to try the _netdev option and see how it works.
 
Old 04-22-2010, 08:53 AM   #4
chrislski
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Even after adding -netdev I can't get it to automatically mount at the /mnt/sharename directory.
 
Old 04-22-2010, 09:17 AM   #5
chrislski
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Apparently netfs is required because once I enabled the service it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Correct syntax for mounting a windows share in the /etc/fstab file kaplan71 Linux - Software 3 08-17-2009 04:48 PM
Mounting windows share via cifs (fstab entry) - error 13 opening credentials file O(V)eGA_l2el) Linux - Networking 2 12-05-2006 11:22 AM
samba mount to windows share folder lewkh Red Hat 1 03-01-2005 03:31 PM
mounting an smbfs share using mount vs /etc/fstab sichen Linux - Networking 4 08-13-2004 06:40 PM
can't mount to windows share folder using samba yawhum80 Linux - Software 4 10-24-2003 11:52 PM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration