LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-25-2006, 11:55 AM   #16
TheOracle
Member
 
Registered: Nov 2004
Posts: 87

Rep: Reputation: 15
Fedora Core 5 (FC5) SMB / CIFS Solution


Hello all

Here is what you should do to get a list of available SMB mounts...

#> smbclient -L the_server_name -U your_domain_name/your_username

This will list all available servers even if only one is specified, I'll have to read up more on the man pages.

Now to mount...

#> mount -t cifs //the_server_name/desired_directory /mnt/this_dir --verbose -o user=your_username,domain=your_domain_name

The system will the prompt for your domain login and then mount.
If you like write this to /root/bin/mnt.whatever.
Then...

#> chmod 700 /root/bin/mnt.whatever


This will enable you to mount as root whenever you choose. Also incl a uid option if you want users other than root to access...

#> mount -t cifs //the_server_name/desired_directory /mnt/this_dir --verbose -o user=your_username,domain=your_domain_name,uid=fc5_username

Something else, it did take a few tries but by using the "--verbose" option it showed exactly how "mount" parses the directory slashes "\" and "/"...

Hope this helps
Graeme
 
Old 09-25-2006, 12:02 PM   #17
jviola
Member
 
Registered: May 2004
Posts: 47

Rep: Reputation: 15
Can you mount to the shared folder from another windows pc?

I thought you should check and make sure you can share the folder from another pc. To make sure windows isn't blocking you.
 
Old 10-16-2006, 12:52 PM   #18
jancev
LQ Newbie
 
Registered: Oct 2006
Posts: 1

Rep: Reputation: 0
I think the issue is that "//192.168.1.77/E/Tunes" isn't a windows share. Youre probably connecting to the shared folder "//192.168.1.77/E" and wants to mount the ordinary folder "Tunes" on that shared folder (hope all the folder referencing made any sence).

I haven't found any way to do this with samba, "mount.smbfs" or "mount.cifs", but there are two options anyway.

1. If you are administrating the windows machine, try making the Tunes folder a share, and name it something like E_Tunes, using some magic rightclick manoeuver on your Windows machine. Then mount the new share "//192.168.1.77/E_Tunes" on your Linux box.

2. Not boss of the shares, you can use Nautilus file browser to mount folders in "shared folders". In Nautilus select File->Connect to Server. Service Type=Windows share, server=192.168.1.77, share=E, folder=Tunes. -> Connect. You can now access the folder using Nautilus.

Good luck

/Robert Jancev
 
Old 11-21-2006, 03:52 PM   #19
cmot501
LQ Newbie
 
Registered: Jun 2006
Posts: 2

Rep: Reputation: 0
mounting smb folder

Is might be me but this mount //192.168.1.77/E/Tunes isnt vaalid.

The drive your mount is on is not used.

It should be //server/MountName

I.e. //192.168.1.77/Tunes

onit the E

Hope this helps
 
Old 11-21-2006, 03:54 PM   #20
cmot501
LQ Newbie
 
Registered: Jun 2006
Posts: 2

Rep: Reputation: 0
mounting smb

This mount //192.168.1.77/E/Tunes isnt vaalid.

The drive your mount is on is not used is smb/cifs file system.

It should be //server/MountName

I.e. //192.168.1.77/Tunes

omit the E

Hope this helps
 
Old 03-04-2007, 03:39 AM   #21
bluelightning
Member
 
Registered: Mar 2006
Location: Redmond, WA
Distribution: FC4, WinXP Pro
Posts: 37

Rep: Reputation: 15
I hit a similar issue. The answer is that you can only mount the share directly. You cannot mount a subfolder of a share.

So instead of doing:
mount -t cifs //skybyte/E/Tunes /mp3/flx

Do this instead:
mount -t cifs //skybyte/E /mp3/flx
 
Old 05-01-2007, 09:10 AM   #22
ejan
Member
 
Registered: Mar 2007
Location: Rochester Hills, MI, USA
Distribution: Mandriva 2007, CentOS 5, Debian 4.0
Posts: 38

Rep: Reputation: 15
I've found that the following syntax works perfect for mounting samba shares:

Quote:
mount -t cifs -o user=<user-name> //<server-name>/<root-share-name> <mount-point>
Here are some very important points about how the mount utility works (or not works) when it comes to mounting samba shares:

1. For the -t parameter smbfs *won't* work. That value for the -t parameter has retired and no longer supported.

2. If you specify a user whose password is *blank*, you'll need to just press enter when prompted for password. In this case, mount will fail with a permission denied error. So always specify a user who does have a password.

3. <share-name> *must* be the root of a share not a subdirectory of it. For example, if you have a server named myserver with the following shared directory structure,

RootShare
|
---SubDirOne
---SubDirTwo
|
---SubSubDirOne

then you can mount nothig but the directory RootShare. Trying to mount any of the sub-directories will result in the following error:

Quote:
retrying with upper case share name
mount error 6 = No such device or address
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
4. The <mount-point> should be an already existing directory.

I hope this makes up for a crystal clear solution to a *very* common problem. Try googling for it and you'll see it seems like everyone on this planet has gone through this problem

Note: I've also posted this same solution on my blog Sooper Tux.

Last edited by ejan; 05-05-2007 at 04:29 AM.
 
Old 10-19-2007, 05:00 AM   #23
cybafelo
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
hey i think i figured it out you got to use \ instead of / for windows shares so:

mount -t cifs \\\\server\\share /mnt/net -o domain=WHATEVER -o username=thisandthat
 
Old 07-03-2009, 07:09 PM   #24
antonismark
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
Caution!!

the network path MUST BE in LOWERcase, even if the original share name (shared with windows) includes capital letters.

the command should look like this (tested Fedora 11, Windows Xp shared folder) (1 line)

/sbin/mount.cifs '//192.168.1.99/shared folder name/some path here/folder to mount' '/home/yourusername/Desktop/folderlocal' -o user=windowsusername,pass=windowspassword

Sorry to bring this up its high on google results and it doesnt help much as it was
 
  


Reply

Tags
fedora, mounting, name, network, smb, tcp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMB Nautilus integration - sometimes behaves oddly (Fedora Core 2) paulecoyote Linux - Newbie 6 10-20-2006 11:08 AM
Fedora Core 4 - how to get file browser to open by double click on home folder nickleus Linux - General 2 01-24-2006 03:36 AM
fedora core 3 ntfs mounting rusty_slacker Linux - General 5 07-06-2005 06:23 PM
Fedora Core 1 SMB Printing Auth Problem rdjurovich Linux - Software 4 12-01-2004 08:57 AM
VSFTPD - Seting up virtual folder and users on Fedora Core 2 tosheeba Linux - Networking 2 10-18-2004 05:04 PM


All times are GMT -5. The time now is 05:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration