LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 07-25-2008, 12:58 AM   #1
everyday
LQ Newbie
 
Registered: May 2006
Posts: 8

Rep: Reputation: 0
mount working on one machine but not another??


Hi all, I have a problem with mounting, where I have two servers (A and B), each with one shared folder each, and two client machines.

Both of my client machine can mount server A's drive, but only 1 client can mount server B's shared folder saying 'only root can do that'?

I know it must be something really simple but i'm baffled.

I have tried copying the same entrys from the working fstab to the other and so I know its not a syntax error at least.

It must be permissions as far as I can see are the same, and I am using the same username and password for both clients.

I'm stumped!

TIA everyone,

everyday
 
Old 07-25-2008, 07:26 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
As far as my information goes if drive maybe yet better the drive and file type is not mentioned in fstab it standard that only root can mount it
 
Old 07-25-2008, 07:42 AM   #3
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
can you post not working fstab here? I'd also like to see you're shared folder permissions if possible... use ls -l to see that info...

Skuzye
 
Old 07-25-2008, 03:55 PM   #4
everyday
LQ Newbie
 
Registered: May 2006
Posts: 8

Original Poster
Rep: Reputation: 0
thanks guys,

Here is the fstab entry:

//192.168.1.2/currentprojects /mnt/a cifs auto,username=pass,password=pass,uid=0,gid=500 0 0
//192.168.1.3/rfarm /mnt/b cifs auto,username=pass,password=pass,uid=0,gid=500 0 0

ls -l gives:

drwxrwxrwx 1 root 500 0 2008-07-25 16:51 a
drwxrwxrwx 2 root root 4096 2008-07-10 16:02 b

On the computer that is working:

//192.168.1.2/currentprojects /mnt/a cifs auto,username=pass,password=pass,uid=0,gid=500 0 0
//192.168.1.3/rfarm /mnt/b cifs auto,username=pass,password=pass,uid=0,gid=500 0 0
drwxrwxrwx 1 root pass 0 2008-07-25 16:51 a
drwxrwxrwx 1 root pass 0 2008-07-23 08:18 b

thanks
 
Old 07-25-2008, 06:03 PM   #5
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
I noticed that you're using group id to set permission in fstab. Maybe you have forgotten to add the client which is not working to that group.

If that's right, you just have to add the client to the group. I'm not very concerned about this so if that's the case I cannot help you further.

Skuzye
 
Old 07-25-2008, 07:47 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
It would be better to use the "credentials" option to reference a credentials file. Remember that /etc/passwd is world readable. Also consider the _netdev option to delay mounting the share until the network is ready.

It might be better if you used the users uid instead of root. Your current configuration is exposing the root's password. Plus a root client may be mapped to guest by the server. Make sure that each username & password is entered using "smbpasswd" on the server.
 
Old 07-28-2008, 05:23 PM   #7
everyday
LQ Newbie
 
Registered: May 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks everyone for your reply's, it was much appreciated. I just figured out what it was. I had to enter in the domain.

so my fstab entry went from:

//192.168.1.3/rfarm /mnt/b cifs auto,username=pass,password=pass,uid=0,gid=500 0 0

to

//192.168.1.3/rfarm /mnt/b cifs auto,username=domain/pass,password=pass,uid=0,gid=500 0 0

and then it worked straight away.

Thanks again everyone.

PS I figured it out by trying to log on with a windows machine and it promted for the domain, that tipped me off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
linux mount.from one to another machine.!!!!! hegdeshashi Linux - General 1 11-27-2006 07:44 AM
SSH forward from a Windows machine to a Linux machine isn't working nickj6282 Linux - Networking 3 08-13-2006 03:47 PM
How to mount a drive from another machine? quintan Linux - Software 2 11-21-2005 07:23 AM
Can't mount remote machine juno Linux - General 5 09-04-2003 01:06 AM
mount another machine on the network ndovi Linux - Networking 1 01-04-2002 03:56 AM


All times are GMT -5. The time now is 01:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration