LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   mount -t smbfs -o problem (http://www.linuxquestions.org/questions/linux-networking-3/mount-t-smbfs-o-problem-465479/)

baikonur 07-19-2006 04:50 AM

mount -t smbfs -o problem
 
hi.

i'm trying to access some stuff on my linux-samba-PDC from a linux-notebook. i tried

Code:

mount -t smbfs -o username=myname,password=mypword //myserver/myshare /mnt/mountpoint
and the share is there. so far so good.

but i can't access the directories.
the owner/group is all displayed with numbers only, like 1005:1015, and even though i mounted the share as the samba user who is the owner of the files, it doesn't work.

maybe the problem has something to do with the linux laptop not being part of the samba domain. (could it be a member of such a domain at any rate?)

i'm running low on ideas - any help would be sweet.

baik

ps: now i can't even get rid of that share ... device busy ... *grumble*

Gethyn 07-19-2006 04:55 AM

Try adding uid=user,gid=group to the options.

baikonur 07-19-2006 05:08 AM

no, that didn't help.

at least I could umount it now ...

out for lunch :-)

baikonur 07-19-2006 07:02 AM

hmm ... the log.smbd file looks like all should be well:
192.168.1.229 (192.168.1.229) connect to service qm initially as user mfk (uid=1001, gid=100) (pid 11605)

and later:
192.168.1.229 (192.168.1.229) closed connection to service qm

that looks just like when I connect from a windows machine.
only then I can browse the folders that are open to the owner (me).
on the LinuxLaptop I can see them but not browse them.

so I'm really beginning to think that a machine needs to be in the domain,
even if it's a linux box.
can anybody tell me how I could achieve this?

regards,
baik


ah: there is a difference in the logs: the hostname of the linuxlaptop is not there.
all the other connects from win machines create a logfile entry like:
clmediapc1 (192.168.1.232) connect to service ell initially as user ell (uid=1010, gid=100) (pid 11581)


All times are GMT -5. The time now is 10:32 PM.