LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-19-2002, 09:48 PM   #1
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Rep: Reputation: 0
Mk9 cannot ping any comp in the network


I am trying to network my linux box as a client in my network. The nic has linked to the linksys switch and the lights are lit but if i ping any computer in the network I get Destination host unreachable. I have also ping from other computers (windows machines) to the linux box and the request timed out. What could be the problem. Thank you for any suggestions. Please help me I have been trying to set this client up for a couple of weeks now.
 
Old 12-19-2002, 10:04 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
run these commands and post the output..
Code:
 
ifconfig -a

route -n

lsmod

cat /proc/pci | grep Ethernet

iptables -L
 
Old 12-19-2002, 10:24 PM   #3
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
ifconfig -a

eth0
Link encap: Ethernet HW addr 00:05:5D:53E2:B4
inet addr:192.168.0.168 Bcast:192.168.0.255 Mask255.255.255.0
Broadcast Multicast MTU 1500 Metric:1
Rx packets:0errors:15dropped:0overruns:0frame:0
Tx packets: 471 errors:0dropped:0overruns:0carrier:0
collisions:0 txquelon:100
Rx bytes 0 (0.0b) tx bytes 28644 (27.9kb)
Interrupt:11

lo
Link encap: Local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UPLoopback running MTU 16436 Metric:1
Rx packets:254 errors:0dropped:0overruns:0frame:0
Tx packets:254 errors:0dropped:0overruns:0carrier:0
collisions:0 txquelon:0
Rx bytes:23368 (22.8kb) Txbytes:23368(22.8kb)


cat /proc/pci | grep Ethernet

Ethernet controller: D-Link System Inc. RTL8139 Ethernet (rev 16)


iptables -L

command not found


lsmod

what do you want to see there is to much to type
 
Old 12-20-2002, 12:27 AM   #4
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Quote:
what do you want to see there is to much to type

I hope you did not type all that stuff!

you can copy and paste



the output of lsmod would have been some help if the module had failed to load. However it looks like it should be working normally.
 
Old 12-21-2002, 03:25 PM   #5
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
please help

today i checked the hub when i pinged the windows machine form the linux box and noticed the lights were flickering which indicates that the info is passing threw the hub. I also checked the windows box and the activity light was blinking there so the ping is making it that far. Now either the windows box is not recognizing the signal or it is sending back a signal and the linux box is not accepting the windows info.
Any one have any suggestions
 
Old 12-21-2002, 03:31 PM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
We need to see the output of this

Code:
route -n
 
Old 12-21-2002, 03:40 PM   #7
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
Destination gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

Here is another site I have my question on that will show you some other info I have obtained

http://www.dslreports.com/forum/rema...xdsl~mode=flat
 
Old 12-21-2002, 03:47 PM   #8
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
sorry here is the full route -n

Destination Gateway genmask Flags Metric ref use iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.1 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
 
Old 12-21-2002, 09:19 PM   #9
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Everything looks ok

I looked at the other posts, I see you are using ICS

are you sure ICS is working?


have you had another machine work on the same cable your hooked up to?


I would say that you need to fire up the linux box and type this

Code:
dhcpcd
that should be all there is to it
 
Old 12-21-2002, 10:22 PM   #10
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
when i run that command then i do a ifconfig my eth0 is gone the only thing there is lo also i do a mii-tool it says it fail there is no eth0
 
Old 12-21-2002, 10:46 PM   #11
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
ths tells me that ics is not working,

ics is supposed to provide dhcp to clients

try opening up an xterm and run tcpdump -i eth0
and in another xterm run dhcpcd


root@slacker:~# tcpdump -i eth0
tcpdump: WARNING: eth0: no IPv4 address assigned
tcpdump: listening on eth0
22:43:59.636391 0.0.0.0.bootpc > 255.255.255.255.bootps: xid:0xxxxxxx24 secs:10 file ""[|bootp]



at this point lights should be flashing and you should see the windows box coming back with a response

22:43:59.646033 www.mydomain.com.bootps > 255.255.255.255.bootpc: xid:0xxxxxxx24 secs:10 Y:slacker.mydomain.com S:www.mydomain.com ether 0:x:xx:xx:xx:12 file ""[|bootp] (DF)

Last edited by DavidPhillips; 12-21-2002 at 10:49 PM.
 
Old 12-21-2002, 11:21 PM   #12
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
when i run tcpdump -i eth0 i get command not found
 
Old 12-21-2002, 11:48 PM   #13
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
are you root?

if so you should probably install it

you could check and see if you have trafshow or iptraf
 
Old 12-21-2002, 11:57 PM   #14
cavy
LQ Newbie
 
Registered: Dec 2002
Location: Artemas, PA
Distribution: Mandrake 9.0
Posts: 16

Original Poster
Rep: Reputation: 0
yes i am root

trafshow shows command not found

iptraf shows command not found

where do i find them to install them will they be in the packages somewhere and will those names be what i should look for.
 
Old 12-22-2002, 12:04 AM   #15
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
ok are you root in root's environment?
try this and see if it makes a difference

Code:
 
su -
as far as getting software, it's on the install cd

you can also try this

Code:
locate tcpdump
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can ping network computer, cannot ping google.com (help needed) ben_build#2.1.0 Linux - Wireless Networking 23 11-07-2010 12:55 PM
Two comp network with belkin wireless card and router windell Linux - Wireless Networking 1 07-24-2005 05:49 AM
how to do: using a linux comp to act as router for a windows comp grimhammer Linux - Networking 8 02-10-2005 09:56 PM
Can ping network but can't ping any internet ip when I hard set the ip Streme Linux - Wireless Networking 4 04-13-2004 09:18 AM
couldn't ping a WinXp comp from Fedora Comp tanbetien Fedora 5 12-04-2003 06:03 AM


All times are GMT -5. The time now is 03:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration