LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-15-2005, 03:17 AM   #1
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Rep: Reputation: 15
Media files download rather than stream


Hello all, I have a windows server running with all my media files stored on it, the media files are accessible with the samba client through my Linux box which is running Fedora Core 3 and KDE, when I go to open up an mp3, mpg, or avi the file starts to download to a temp dir, I then have to wait for it to download before I can play it, is there a way to have the file play as if it where on a local disc, ie stream it?

Thanks
 
Old 01-16-2005, 04:16 AM   #2
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
What are you "opening" the file with? If it's konqueror, then you need to set the file associations so that the appropriate application is called. Otherwise, you could try opening the file with the application that is going to use it eg xine for an mpg.
 
Old 01-16-2005, 07:53 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try using videolan.
 
Old 01-16-2005, 10:53 AM   #4
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for the responses, I use Konqueror to browse to the file, if I double click the file (eg mpg) it downloads it to the temp dir, then opens Xine, which is the program I have set in file associations to open such file, if I right click the file and open with and select Xine it still downloads.

I´ll try out Video Lan but would still like to be able to have the item stream across the network and use Xine.
 
Old 01-16-2005, 11:52 AM   #5
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Weird, and I do not know what is going on here. Wish I could replicate your problem, but I am still at the stage of struggling to get my linux<->linux network working! Sorry I cannot help more.
 
Old 01-16-2005, 12:21 PM   #6
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
I think Xine can open files from a location such as the web, another PC, etc. I think if you run Xine, select "open url" and enter the address of the file, it will play the file as a stream from wherever it's located.
 
Old 01-16-2005, 07:03 PM   #7
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Original Poster
Rep: Reputation: 15
On the way to work this morning I was thinking about the problem and I thought, I haven't mounted the shares in /mnt I just created a link on my desktop to the folders on the server, so if I create a share in /mnt/share with
Code:
mount -t smbfs //server/folder /mnt/share
it should work, cross fingers
 
Old 01-17-2005, 01:18 AM   #8
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Original Poster
Rep: Reputation: 15
Well it didn´t work, apparently windows has changed the SMB protocol to be more secure and older ¨clients¨ can´t logon this is the error
Code:
cli_negprot: SMB signing is mandatory and we have disabled it.
7039: protocol negotiation failed
SMB connection failed
Helpful of Microsoft really

Oh well thanks for all your help anyway
 
Old 01-17-2005, 02:42 AM   #9
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Original Poster
Rep: Reputation: 15
LOL maybe I reacted to soon:
Code:
mount -t cifs -o user=username%password //server/share /mnt/mount file
Seems to work just fine

Anyone know how to have it so it is mounted at reboot?
 
Old 01-17-2005, 06:05 AM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
put that line in /etc/rc.d/rc.local, that should work
 
Old 01-18-2005, 12:00 AM   #11
adrenaline_NZ
Member
 
Registered: Jun 2004
Location: Wellington, New Zealand
Distribution: Suse 9.3
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by keefaz
put that line in /etc/rc.d/rc.local, that should work
Thanks, it worked a treat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
media stream problems Ephracis Linux - Software 1 05-02-2005 12:36 PM
Windows Media Playlist for Icecast stream funkatron General 0 04-11-2005 05:46 PM
Video stream support for media players Ligius Linux - Software 2 11-02-2004 02:24 PM
can't stream media from network deadslota Linux - Newbie 2 05-30-2004 05:26 AM
how to download real media files? sk8guitar Linux - General 2 12-06-2003 12:31 AM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration