LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-18-2009, 02:33 PM   #1
Jophish
LQ Newbie
 
Registered: Jun 2008
Posts: 6

Rep: Reputation: 5
Exclamation Master mode on AR928X using ath9k driver.


Hi all

EDIT
Turns out I was running a really old version of ath9k. compiling the newest version worked great.
/EDIT

I am trying to get my wireless card working in master mode. I am running Jaunty server 2.6.28-11 x86_64.
I have compiled hostapd with nl80211 enabled. The interface is using ath9k.

I have tried to compile compat-wireless with this patch. However IEEE80211_IF_TYPE_AP was undefined along with IEEE80211_IF_TYPE_VLAN. In addition the latest version of compat-wireless needs to be patched for kernels < 2.6.31 with this. However when using this patch IRQ_WAKE_THREAD is still undefined.

I have got to this message:
Code:
$ sudo hostapd /home/jophish/.hostapd.conf 
Configuration file: /home/jophish/.hostapd.conf
Failed to set interface wlan0 to master mode.
nl80211 driver initialization failed.
ELOOP: remaining socket: sock=5 eloop_data=0xe05040 user_data=(nil) handler=0x433350
.hostapd.conf:
Code:
interface=wlan0
driver=nl80211
ssid=Testnet
channel=1
hw_mode=g
auth_algs=1
wpa=3
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP
rsn_pairwise=CCMP
Thanks

Joe

Some useful information:

$ sudo lshw -C Network
Code:
  *-network               
       description: Ethernet interface
       product: MCP79 Ethernet
       vendor: nVidia Corporation
       physical id: a
       bus info: pci@0000:00:0a.0
       logical name: eth0
       version: b1
       serial: 00:01:2e:27:58:15
       size: 100MB/s
       capacity: 1GB/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.61 duplex=full ip=192.168.0.3 latency=0 link=yes maxlatency=20 mingnt=1 module=forcedeth multicast=yes port=MII speed=100MB/s
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wmaster0
       version: 01
       serial: 00:25:d3:3d:9b:19
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath9k latency=0 module=ath9k multicast=yes wireless=IEEE 802.11bgn
$ dmesg | grep -e ath -e wlan
Code:
[   15.371737] ath9k: 0.1
[   15.373213] ath9k 0000:04:00.0: PCI INT A -> Link[LN3A] -> GSI 19 (level, low) -> IRQ 19
[   15.373232] ath9k 0000:04:00.0: setting latency timer to 64
[   15.800779] phy0: Selected rate control algorithm 'ath9k_rate_control'
[   15.842715] Registered led device: ath9k-phy0:radio
[   15.842758] Registered led device: ath9k-phy0:assoc
[   15.842796] Registered led device: ath9k-phy0:tx
[   15.842833] Registered led device: ath9k-phy0:rx
[ 3704.324281] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6377.225165] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[67178.380725] ath_hal: module license 'Proprietary' taints kernel.
[67178.383995] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[67178.415378] wlan: 0.9.4
[67178.434237] ath_pci: 0.9.4
[67189.736303] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[67617.963271] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[68301.016316] ath_pci: driver unloaded
[68306.091446] ath9k 0000:04:00.0: PCI INT A disabled
[68306.091527] ath9k: driver unloaded
[68316.125010] ath_hal: driver unloaded
[68355.378628] ath9k: 0.1
[68355.378715] ath9k 0000:04:00.0: PCI INT A -> Link[LN3A] -> GSI 19 (level, low) -> IRQ 19
[68355.378732] ath9k 0000:04:00.0: setting latency timer to 64
[68355.812298] phy1: Selected rate control algorithm 'ath9k_rate_control'
[68355.814239] Registered led device: ath9k-phy1:radio
[68355.814304] Registered led device: ath9k-phy1:assoc
[68355.814358] Registered led device: ath9k-phy1:tx
[68355.814420] Registered led device: ath9k-phy1:rx
[71192.024009] ath9k 0000:04:00.0: PCI INT A disabled
[71192.024096] ath9k: driver unloaded
[71208.671421] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[71208.687656] ath_pci: 0.9.4
[71232.363604] ath_pci: driver unloaded
[71236.845164] ath9k: 0.1
[71236.845261] ath9k 0000:04:00.0: PCI INT A -> Link[LN3A] -> GSI 19 (level, low) -> IRQ 19
[71236.845282] ath9k 0000:04:00.0: setting latency timer to 64
[71237.277830] phy2: Selected rate control algorithm 'ath9k_rate_control'
[71237.279894] Registered led device: ath9k-phy2:radio
[71237.279949] Registered led device: ath9k-phy2:assoc
[71237.280065] Registered led device: ath9k-phy2:tx
[71237.280131] Registered led device: ath9k-phy2:rx
[72341.584129] ADDRCONF(NETDEV_UP): wlan0: link is not ready
$ iwconfig
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=20 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
$ sudo iwconfig wlan0 mode master
Code:
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

Last edited by Jophish; 09-18-2009 at 02:55 PM.
 
Old 10-26-2010, 06:05 AM   #2
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Thanks for posting the solution. That's the LQ spirit.

A suggestion for the future: If you answer your own question, put the solution in a separate post; this does 2 good things:
  • It generates e-mail to anyone who subscribed to either the thread or the forum.
  • In avoids the creation of oxymoronic 0-reply solved threads.
 
  


Reply

Tags
ar928x, ath9k, hostapd, master


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hostapd not going into master mode gregnorc Linux - Wireless Networking 10 09-16-2009 01:31 PM
Wlan0 failing master mode Geneset Linux - Wireless Networking 5 09-18-2007 11:48 AM
Cannot use b/g channels in master mode. Swope Linux - Wireless Networking 0 04-25-2006 02:14 PM
Master mode on one NIC and Managed mode on the other ilan1 Linux - Networking 0 02-22-2006 08:02 PM
Master Mode Cards Trano Linux - Wireless Networking 1 04-26-2005 03:56 PM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration