LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-23-2004, 12:54 PM   #1
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Rep: Reputation: 0
Question mandrake 9.1 doesnt recognize nic


newbie here, and to linux, i have mandrake 9.1 loaded on my computer and it does not recognize my nic. the motherboard is a ASUS p4p800 with a built in 3com nic, i cant remember the number but could find it easily. the installation cd comes with linux drivers and instructions on how to install them using tar. ive tried it a couple different ways and cant figure out how to make it work. any help would be greatly appreciated.

matt
 
Old 03-23-2004, 01:11 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
hi theshue, welcome to lq. what files do you have, is there a readme, if you post what it says, i'll try to help you sort it.
 
Old 03-23-2004, 01:46 PM   #3
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
this is the read me file


3Com Gigabit NIC (3C2000) Driver Readme Version A02
Copyright (c) 2003 3Com Corporation

This file describes the 3Com Gigabit NIC (3C2000) driver for Linux.

Loading the driver
------------------

1) Make sure that the kernel source is installed in /usr/src/linux
or /usr/src/linux-2.4.

2) Copy the file /Linux/3c2000.tar.gz from the 3Com driver CD to
your hard drive.

3) Change to the directory containing 3c2000.tar.gz

4) Type 'tar zxvf 3c2000.tar.gz'

5) Type 'cd 3c2000'

Note: on SuSE systems since 7.1, you will have to execute the
following commands before running make:

cp /boot/vmlinuz.version.h /usr/src/linux/include/linux/version.h
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux/autoconf.h

For more details se http://sdb.suse.de/en/sdb/html/mwalter_kernel_24.html

6) Type 'make load' to load the driver.

Alternatively, you may type the following to load the driver:

insmod 3c2000.o

Something like the following will be added to /var/log/messages:

Jan 22 19:31:19 localhost kernel: 3C2000: 3Com Gigabit NIC Driver Version A08
Jan 22 19:31:19 localhost kernel: Copyright (C) 2003 3Com Corporation.
Jan 22 19:31:19 localhost kernel: Copyright (C) 2003 Marvell.
Jan 22 19:31:19 localhost kernel: eth0: 3Com Gigabit NIC (3C2000)

Depending on your configuration, the OS may then automatically bring the
interface up and request an address from a DHCP server. If it does not,
bring the interface up with the command:

ifconfig eth0 up

You may have to substitue 'eth0' for your actual interface if you have
more than one ethernet NIC installed.

If your system is not configured for DHCP, you can assign an IP address
with the command:

ifconfig eth0 a.b.c.d

Where a.b.c.d is the IP address that you wish to use. Again, eth0 may
be different depending on your system configuration.

Configuring the Driver
------------------------

The 3C2000 driver supports various options, which can be supplied
as command line arguments to the 'insmod' command or in the
/etc/modules.conf file. You may specify more than one option.
Unless otherwise stated, all settings take the form of:

<Option-Name>=value [,value...]

If you use the modules.conf file to load the driver at boot time,
include the word "options" when configuring the driver.

For example:
options 3c2000 DupCap_A=Full

If you use command line 'insmod', do not include the word "option"
when configuring the driver.

For example:
insmod 3c2000.o DupCap_A=Full


The following options are supported:

OPTION: Speed_A
Selects the speed of Port A of the NIC.

"Auto" - Automatic Resolution
"10" - 10MBPS
"100" - 100MBPS
"1000" - 1GIG

OPTION: DupCap_A
Selects the duplex capabilities of Port A of the NIC.

"Full" - Full Duplex
"Half" - Half Duplex
"Both" - Both Half Duplex & Full Duplex


To unload the driver
--------------------

1) Type 'ifconfig eth0 down' (Substitute you actual interface for 'eth0')

2) Type 'rmmod 3c2000'



ive tried the load driver steps and i get a something to the effect that this is a directory, and it wont let me go any further.
 
Old 03-23-2004, 01:49 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
so you've gotten past the tar and cd steps? what error do you get from the make load or insmod commands?

Last edited by Peacedog; 03-23-2004 at 01:51 PM.
 
Old 03-23-2004, 01:58 PM   #5
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
no its at step 3 were it goes haywire. im not exactly sure were im suppose to do the entering. not sure what to call it, but its a window similar to a dos prompt, and got into a root access of it. then tried to change to the location i saved the file, and it says its a directory and wont open it switch to it.
 
Old 03-23-2004, 02:08 PM   #6
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
your at the command line interface, or cli. you call it a terminal. to get root access

su <enter>
password <root password>

cd the/path/to/the/file <this should take you to the directory of the file>

from there do

ls <this will show you the files and directories, sometimes it's just good to take a look at what your doing>

you should see the file 3c2000.tar.gz

if not

cd / <this will take you to the root directory>

then

ls <to see all directories>

and

cd <one directory at a time if you have to just to get where your going>
 
Old 03-23-2004, 02:10 PM   #7
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
thanks i'll give it a try and get back to you on that.

matt
 
Old 03-24-2004, 01:35 AM   #8
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
well thanks to your help i was able to try and make it load, unfortunately i forgot about step 1. how do i make sure the kernal source is installed? the readme file doesnt say much about it.

matt
 
Old 03-24-2004, 07:25 AM   #9
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
the kernel source should be on your cd set. i'm working from memory here so bear w/me and look around, in mandrake control center you have a software manager, may be under system, as i said look around. from the software manager there should be some check boxes up on the left top corner to filter your software search(again if i remember correctly) you'll want to choose available or packages or packages not installed. the kernel source should be listed there. choose it, follow the prompts, they'll ask for a disk, i think you'll be able to find your way through the rest of it.
good luck.
 
Old 03-24-2004, 04:32 PM   #10
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
ok i went in and loaded all available packages, everything i could find, and went back in and tried to load it again. its at the "make load" portion that its not working. i get alot of errors i cant remember what they are, and am at work now, so i wont be able to look and find exactly were its says.

matt
 
Old 03-24-2004, 06:42 PM   #11
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
all you should need are the appropriate libs, the development packages and the kernel source. another note running mandrake i experienced problems when trying to install alot of packages at one time, in fact it usually errored out. i resolved myself to install just a few packages at a time, and had no problems. on to the other problem, as per the instructions, when make load failed, did you try the insmod? i know it's frustrating, but, don't give up.
good luck.
 
Old 03-24-2004, 08:05 PM   #12
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
yeah i tried the insmod, and it didnt work, i dont remember what it said, ill have to get back to you on that. but when i loaded the packages the load seemed to work fine, i didnt have any errors. is there a way to see if the kernels are already loaded? on a side note, when i loaded mandrake the first time, i loaded every package that it gave me the option to. are there more on the disk set that you have to access seperately after the load?

matt
 
Old 03-24-2004, 08:20 PM   #13
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
there are a ton on the disk that don't install, the first time i installed mandrake, i selected everything it allowed me to, only to find out later that there were a couple hundred or so apps still on the cd's. quite confusing for a newbie. when you get the chance post the errors, we'll try to sort them.
 
Old 03-24-2004, 10:30 PM   #14
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Let's check if you have the kernel source installed. What directories are in /usr/src

What does the command:
urpmq kernel-source
return.

From your description of the install instructions, The makefile is copying a pre-compiled kernel module somewhere in /usr/lib.

Enter the commands as root:
find /lib -iname 3c2000.o
and
find /usr/lib -iname 3c2000.o

Also, it may help if you cd'ed to the directory made during the untarring
and re-issue the make command from the instructions.

This time, cut and paste the output of the command and post it here.
That will give us a more accurate description.
 
Old 03-25-2004, 06:17 PM   #15
theshue
LQ Newbie
 
Registered: Mar 2004
Posts: 11

Original Poster
Rep: Reputation: 0
okay after loading alot of software updates off the disks (probably a bunch i didnt need ) i tried the make load again. and a majority of it worked. what didnt work was the first to commands it tried the erors i recieved were:

/usr/src/linux/include/linux/version.h:1:28: linux/rhconfig.h: no such file or directory

and

/usr/src/linux/autoconf/linux/version.h:1:28: linux/rhconfig.h: no such file or directory

so i went through the CLI and can find both files, but they are version.h not h:1:28:. i dont know if that makes a differance or not. so i went back to the sowtware loader and did a file search and could find nothing that matched either of those two files. only thing is now the OS actually recognizes the NIC, due to the fact that my router now shows a usage signal from this computer. but it only recognizes it as a LAN connection, and doesnt let me access the internet.

thanks for all the help so far, its helped immensely(sp?)

matt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 9 installer doesnt recognize keyboard snowinferno Linux - Laptop and Netbook 6 01-21-2009 10:08 AM
DigiKam doesnt recognize my camera stewill Linspire/Freespire 7 01-22-2005 03:02 PM
slackware 10 doesnt recognize my cdrom ddaas Slackware 4 12-10-2004 12:28 AM
Swaret doesnt recognize my slack version sigma957 Slackware 8 09-20-2004 09:28 PM
Fedora doesnt recognize correct cpu speed gomartin Fedora 5 08-17-2004 05:03 PM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration