LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-02-2004, 01:48 PM   #1
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Rep: Reputation: 15
Mandrake 10 & WinXP OPEN file sharing


Hey, I'm a Linux n00b and I just put Mandrake 10 on a P3-733 machine w/ 128MB RAM. Nothing too weak, nothing too special. Anyway, I have 6 WinXP boxes around and this one Linux box with a bigass hard drive, and I want to make it a file server. I have a folder /home/user/netshare that I want ANYBODY on the network to have access to with TOTAL read permission, no writing to it. If it's even an option for Linux, I'd like to have it not even HAVE a username or password prompt when they try to access it. I know Win2K and XP can do it, I want it an open share. Just "oh, there it is - click and you have files" from any computer. If that's possible, I think I may have figured TWO ways of doing it, but both lead to dead ends. I got Samba installed and up and running, and I can SEE the linux box on the network, but Windoze gives me "access not available, make sure you have permission" or something like that. I can edit the smb.conf file, that's how I got it to show up in WORKGROUP instead of MDKGROUP, OR I could go through the Samba Server Wizard in Mandrake Control Center, but I get stuck at the part where it asks you to put in users and groups and tells you groups must be preceeded by @ and gives you "fred@wheel" as an example. And I get no change when I click next and have no idea what I'm putting in those lines. Help! Thank you.
 
Old 08-02-2004, 03:25 PM   #2
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
check out Samba docs, modify the config file manually.

<hint>guest account, guest ok, security = share</hint>

Last edited by Demonbane; 08-02-2004 at 03:26 PM.
 
Old 08-02-2004, 06:46 PM   #3
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Nope.

No go. For the most part. I DRASTICALLY simplified the smb.conf file, and got it down to this:

[global]
path = /home/user/netshare
workgroup = WORKGROUP
security = share
guest ok = yes

And I get into it, it doesn't show a password prompt, takes me right to the folder. Yay! Only problem now is that the contents of /home/user/netshare aren't THERE. Just a "Printers and Faxes" icon. None of the files or folders that are present in the actual folder on the Linux box. Any ideas?

Last edited by CaptainRegular; 08-02-2004 at 08:52 PM.
 
Old 08-02-2004, 09:57 PM   #4
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
get rid of "path = /home/user/netshare" under global, and create a share down the bottom eg.
Code:
[myshare]
path = /home/user/netshare
writeable = yes
make sure the guest account is mapped to a local user account(guest account = bob), and that account has proper permission for /home/user/netshare.
 
Old 08-03-2004, 06:30 PM   #5
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
PROGRESS!
After making THIS:

[global]
workgroup = WORKGROUP
security = share
guest ok = yes
guest account = tim
guest = tim
[linux]
path = /home/tim/netshare
writeable = no

I was able to access it just like I wanted. From one computer. Only one that I can tell (laptop, wireless, XP) gives me no access. It also says in addition to \\Localhost not accessible, might not have permission to use the resource, blah blah. "You were not connected because a duplicate name exists on the network. Go to System in Control Panel to change the computer name and try again."
Does this mean on this one XP machine? I have NO idea why this would happen now? Thanks for all your help, and if you have any suggestions, I would appreciate them on this issue, although it sounds more like Windoze than anything else.

Last edited by CaptainRegular; 08-03-2004 at 06:51 PM.
 
Old 08-03-2004, 08:00 PM   #6
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
on mine i enabled the guest account, and allowed the "no password" function, then mapped guest = guest, and made the share directory = /home/guest/share and set 777 permissions, and writeable is set to yes (cause we swap files back and forth)

Demonbane big thanx for the security = share tip, that was the only thing keeping mine from working properly to let a winblows computer link up with mine, the old method of using my little 128M jump drive just wasn't cutting it!

Last edited by Ghost_runner; 08-03-2004 at 08:05 PM.
 
Old 08-03-2004, 09:11 PM   #7
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Screeching halt! After a reboot of the linux box, but of course NO changes to the working smb.conf file or any other network setting, it DOESN'T WORK AGAIN! WTF?!?!?! The file is this EXACTLY, like cut and paste exactly.
[global]
workgroup = WORKGROUP
security = share
guest ok = yes
guest account = tim
guest = tim
[linux]
path = /home/tim/netshare
writeable = no

And I get the SAME DAMN MESSAGE I was getting before about the not accessable and bull$h1t. Linux sure as hell is the opposite of Windows, usually Windows STOPS working UNTL you reboot it, here stuff works fine if I don't and stops working if I do. Apparently, I REALLY need to invest in a battery backup. Any thoughts? I SWEAR, it was working on at least 2 of the Windows XP boxes, and one was my girlfriends laptop that wasn't setup or rebooted or had anything special done to it.

EDIT: I figured out how to start and stop samba in the GUI, that made it a little easier. And I added all 3 "guest" lines to the share part at the bottom (duplicated, probably redundant) but it works like it did the first time it worked. I now believe the only problem is with my wifi laptop. (It has trouble running the network wizard, and I can't get it to do stuff it should manually, it has other problems, I smell a format one of these days.)

Last edited by CaptainRegular; 08-03-2004 at 09:21 PM.
 
Old 08-03-2004, 10:22 PM   #8
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Samba uses your hostname as the netbios name(Computer name in Windows) by default, make sure it's not the same as any other boxes. It has to be unique on your LAN, otherwise strange things can happen.
To set a different netbios name in Samba put this in smb.conf:
Code:
netbios name = mylinuxbox
then restart it
 
Old 08-05-2004, 08:09 AM   #9
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks! The whole "Samba 3.0.2a Localhost" was kinda bugging me. And the whole folder works perfectly now, even after rebooting. This site and the people on it are just...awesome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WinXP ICS with SuSE 9.2 File Sharing StaticSage Linux - Networking 4 04-22-2005 06:56 AM
FC3 WinXP file sharing bestbidder1 Linux - Newbie 1 01-20-2005 07:33 AM
WinXP open print sharing CaptainRegular Linux - Networking 3 08-23-2004 09:51 PM
how to get primary logon network, Access control,File sharing & printer sharing info dileepkk Linux - Networking 2 07-06-2004 06:54 AM
linux and winXP file sharing kefen Linux - Networking 3 10-09-2003 10:16 AM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration