LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 05:14 PM   #1
mgrenier
LQ Newbie
 
Registered: Nov 2004
Distribution: Mandrake, Debian, Redhat, Fedora
Posts: 2

Rep: Reputation: 0
Wink Mandrake 10.1 can't ping my gateway


Hello,

I've just replaced RedHat 8.0 with Mandrake 10.1. The install went ok but my network
doesn't work. I can't even ping my gateway. I have a 3Com card that is a few years old.

At boot the eth0 interface comes up with no errors.
ifconfig gives me valid info.

/etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
IPADDR=10.0.0.40
NETMASK=255.255.252.0
NETWORK=10.0.0.0
BROADCAST=10.0.3.255
ONBOOT=yes
MII_NOT_SUPPORTED=no
WIRELESS_ENC_KEY=""

/etc/sysconfig/network

HOSTNAME=mrburns
NETWORKING=yes
GATEWAY=10.0.0.1

/etc/resolv.conf

search qwest.net
domain qwest.net
nameserver 205.171.2.65
nameserver 205.171.3.65

I think the problem is in the drivers for my network card. But I know just enough to be dangerous.

Could someone point me in the right direction?
 
Old 05-16-2005, 07:38 PM   #2
mike33
Member
 
Registered: Jul 2004
Location: Houston Tx
Distribution: kubuntu, Debian, Suse 10.2
Posts: 31

Rep: Reputation: 15
everything seems ok. Make sure that no firewalls are running:
iptables -n -L
If you get any rules then flush them with
iptables -F
 
Old 05-17-2005, 10:22 AM   #3
mgrenier
LQ Newbie
 
Registered: Nov 2004
Distribution: Mandrake, Debian, Redhat, Fedora
Posts: 2

Original Poster
Rep: Reputation: 0
Wink

Thanks for looking at it but I figured out my problem. Mandrake thought my firewire card was my network interface and didn't recognize my 3Com card. So I configured the 3Com by hand through the Mandrake Control Center. So if anybody else runs into this same problem that is what worked for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPP establish can ping the gateway router but unable to ping the host deepalalla Linux - Networking 0 11-18-2004 09:10 AM
dhcp client can't ping gateway but can ping other local hosts dirty_forks Linux - Networking 7 10-08-2004 10:54 AM
Cannot ping my gateway trippeer Linux - Networking 5 05-17-2004 07:23 PM
can't ping gateway pierogie Linux - Networking 3 08-06-2003 05:38 PM
Can't ping or get resolution beyond gateway. Gladiator Linux - Networking 6 04-05-2002 09:45 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration