LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 09-25-2002, 01:17 AM   #1
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
lynksys router.... static ip?


Hi all. I have a lynksys router connecting my little network to a DSL line. I have been trying to set up static ip addresses within my network, but i can't get it to work. I set up my linux box w/ an ip of 192.168.1.101 , netmask of 255.255.255.0 and gateway of 192.168.1.1 . I don't understand why this is all not working... can somebody help?
 
Old 09-25-2002, 01:38 AM   #2
RijilV
Member
 
Registered: Sep 2002
Location: somewhere
Distribution: gentoo
Posts: 123

Rep: Reputation: 15
is there another computer at 192.168.1.101 ? check this first.

what exactly did you do that didn't work?

from the command line, as root:

ifconfig <network device> 192.168.1.101 netmask 255.255.255.0
route add default gw 192.168.1.1

that *should* do it

if you're using LFS you should know where the scripts are. it might be a problem of networking not being started at bootup, or an error in the ifcfg-eth0 or whatever interface it is.
 
Old 09-25-2002, 02:15 AM   #3
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Original Poster
Rep: Reputation: 30
Thanks for getting back to me. Yes, i am using lfs. The only machine with that ip is my other lfs system (which is on the same computer... uses dhcp). I'm sure it's something simple that i'm not doing. I was wondering if you had to specify the dns servers? if so, how would i do that? here's some of my files:

/etc/sysconfig/network:
HOSTNAME=lfs2
GATEWAY=192.168.1.1
GATEWAY_IF=eth0

/etc/sysconfig/network-devices/ifconfig.eth0:
ONBOOT=yes
IP=192.168.1.101
NETMASK=255.255.255.0
BROADCAST=192.168.1.255

and my bootup script is working fine. Any other suggestions?

ooh yeah... I can connect to the network i.e. ping the router and what not, but i can't get outside, "unknown host"- thats why i'm thinking dns?

Last edited by adam_boz; 09-25-2002 at 02:18 AM.
 
Old 09-25-2002, 02:22 AM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
You forgot to add your DNS entries to your /etc/resolv.conf file most likely.
 
Old 09-25-2002, 02:30 AM   #5
RijilV
Member
 
Registered: Sep 2002
Location: somewhere
Distribution: gentoo
Posts: 123

Rep: Reputation: 15
Quote:
Originally posted by adam_boz

ooh yeah... I can connect to the network i.e. ping the router and what not, but i can't get outside, "unknown host"- thats why i'm thinking dns?
ahah

one of two things that haven't been mentioned

either your default route isn't working, which it should. type
netstat -nr

or the linksys router isn't routing IPs it didn't had out, there should be some configuration option somewhere in that linksys regarding that. I could have sworn I saw that before..

I doubt the resolv.conf issue, it could be, if you have ever grabbed a dhcp lease it *should* update the resolv.conf and it will stay that way until you change it. Either way it is a good thing to check
 
Old 09-25-2002, 02:54 AM   #6
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Original Poster
Rep: Reputation: 30
thanks tricky kid. I copied /etc/resolv.conf from my working lfs system, and it works now! (i'm writing this from lynx on my new system). Thanks a lot.
 
Old 09-25-2002, 04:13 AM   #7
mikek147
Member
 
Registered: Mar 2002
Location: Elyria, Ohio
Distribution: Debian, Nothing else required
Posts: 141

Rep: Reputation: 15
SInce the Linksys cable router hands out 50 dhcp addresses starting at 192.168.1.100, it might be a good idea to use static addresses either below 192.168.1.100 or above 192.168.1.49. This way you insure that you won't get a duplicate address.

A note. On versions of the bios below 1.4.27. the Linksys had a bug that would cause it to duplicate a DHCP address. For anyone using a Linksys, upgrade its bios to 1.4.27 or later. -mk
 
Old 09-25-2002, 04:47 AM   #8
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Original Poster
Rep: Reputation: 30
Thanks Mike, good suggestion.

p.s.- I dig the motto
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems routing through a Lynksys firewall router Homer Glemkin Linux - Networking 24 11-19-2004 08:28 AM
static ip from router true_atlantis Slackware 4 09-22-2004 10:31 PM
Lynksys router, no DHCP. Have to use IP manualy, some one give me low down. RHLinuxGUY Linux - Networking 1 07-08-2004 03:16 AM
LAN over Lynksys router between RH9 and two Win2KPro machines GTBlackwell Linux - Networking 4 08-28-2003 01:12 AM
lynksys router.... secure? adam_boz Linux - Security 10 10-25-2002 11:16 PM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration