LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-03-2006, 08:12 PM   #1
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Rep: Reputation: 30
Question Lost All Win95 connections to Samba


Last night I shut down my network for the thunderstorms going through the area, and unplugged it all. When I booted up this morning, I had no Win95 connection to my samba server.

My setup: Ubuntu 6.06 server, running samba 3.0.22. 3 Ubuntu workstations, 1 WinXP Pro, 2 Win95 boxes. The Ubuntu boxes mount the same directories as the Win boxes, using cifs.

What I have tried: checking log files in /var/log/samba--nothing even seems to mention login attempts by either Win95 station. Same for syslog and /var/log/messages.

The server and the two win95 boxes can ping each other. One Win95 box can be accessed via vnc. Two of the Win boxes can ping google.com (the one that cannot rarely uses an internet connection, so I might not have changed things around on it when I got my router a while back). So the network connections are working.

Rebooted the server. Rebooted one of the Win95 boxes multiple times.

Tried mapping drive letters to the server. Got this: the network name is either incorrect or on a network to which you do not have full access.

I am able to login to the server directly and through other connections, one of which is an Ubuntu workstation, using the same login name. So the user and password is working.

The WinXP box has had no trouble accessing the samba files, opening, reading, editing, saving. All is normal.

The Win95 boxes allow me to login to the particular W95 computer, but then when the screen comes up about logging in to samba, it says a connection cannot be found.

I have made no changes in any box (Oh!--except I did do the updated files that came up on Update Manager on my Ubuntu workstation this morning--nothing on any other box) since last night. It is unlikely that I have done anything on the server since the last time I rebooted it--but it is not impossible.

So how would you go about trouble shooting this? The two Win95 boxes are at the moment essential to us, in our production environment.

Thanks!
 
Old 08-03-2006, 09:58 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
A) double check that all of the Samba services are working on the server. On Ubuntu, I think that the commands would be:
sudo /sbin/service smb status
sudo /sbin/service winbind status

or

sudo /sbin/service smbd status
sudo /sbin/service nmbd status
sudo /sbin/service windind status

Which security model are you using on the Samba servers? Do they have static addresses? If not it is possible that one of the Samba servers is running as a WINS server but it's IP address has changed so the other hosts have the wrong WINS address.

Can you map the drives using the server's IP address instead of by name?
You might want to post the global and the [<share>] sections of your /etc/samba/smb.conf files.
 
Old 08-03-2006, 11:03 PM   #3
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

jschiwal--

Thank you for getting back to me so quickly. I am beginning to learn that LQ is a place to turn to for help!

Code:
doug@earth:~$ sudo smbstatus
Password:

Samba version 3.0.22
PID     Username      Group         Machine
-------------------------------------------------------------------
 4864   doug          doug          192.168.0.106 (192.168.0.106)
 4863   doug          doug          192.168.0.107 (192.168.0.107)

Service      pid     machine       Connected at
-------------------------------------------------------
vol2         4863   192.168.0.107  Thu Aug  3 14:03:47 2006
doug2        4864   192.168.0.106  Thu Aug  3 14:08:33 2006
vol2         4864   192.168.0.106  Thu Aug  3 14:03:47 2006
doug2        4863   192.168.0.107  Thu Aug  3 15:05:25 2006
vol1         4863   192.168.0.107  Thu Aug  3 14:03:47 2006

No locked files
I do not know what winbind is, so I doubt I have it set up. service commands don't seem to work in a debian based system, like Ubuntu, in my experience. These did not, and there is no man page nor info page for winbind that I could find.

The machines all have static ipaddresses.

Yes, I thought of mapping to the ipaddress too, but that did not take, either.

Don't know what WINS is either, sorry.

Here are the parts of my smbd.conf file you mentioned:

Code:
#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
#   workgroup = MSHOME
   workgroup = EVERYONE
   netbios name = earth
##############added by ddg 20060726
smb ports = 445
#############


# server string is the equivalent of the NT Description field
   server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
;   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast


#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Put a capping on the size of the log files (in Kb).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
;   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 220

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/ServerType.html in the samba-doc
# package for details.
;   security = user
   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
   passdb backend = tdbsam guest

   obey pam restrictions = yes

;   guest account = nobody
   invalid users = root

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
;   unix password sync = no

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Augustin Luton <aluton@hybrigenics.fr> for
# sending the correct chat script for the passwd program in Debian Potato).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
;   pam password change = no


########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
;   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

# When using [print$], root is implicitly a 'printer admin', but you can
# also give this right to other users to add drivers and set printer
# properties
;   printer admin = @ntadmin


######## File sharing ########

# Name mangling options
;   preserve case = yes
;   short preserve case = yes


############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
;   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

#======================= Share Definitions =======================

wins support = no
[homes]
   comment = Home Directories
#   browseable = no
path = /home
browseable = yes
writable = yes

# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
   writable = no

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0700

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no

[printers]
   comment = All Printers
   browseable = no
   path = /tmp
   printable = yes
   public = no
   writable = no
   create mode = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
;   write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   writable = no
;   locking = no
;   path = /cdrom
;   public = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#       cdrom share is accesed. For this to work /etc/fstab must contain
#       an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#       is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom



[vol1]
path = /vol1
available = yes
#browseable = no
browseable = yes
# public = yes
public = no
writable = yes
        valid users = doug,sharon,lindag,suzyq,mike,root,@apps,@data

[vol2]
path = /vol2
available = yes
#browseable = no
# public = yes
browseable = yes
public = no
writable = yes

##################
# map system = Yes
#        dos filemode = Yes
#        map hidden = Yes
#        writeable = yes
#        preserve case = No
#        path = /vol2
#        strict locking = Yes
#        sync always = Yes
#        force user = data
        create mask = 0777
#        comment = Volume 22
#        directory mask = 0775
        valid users = doug,sharon,lindag,dean,suzyq,mike,root,@apps,@data
#browseable = yes
#force group = data
#public = no
#########added ddg 20060315
#        level2 oplocks = yes
#        veto oplock files = /*.o*/

##################

[label]
path = /vol1/apps/label
available = yes
#browseable = no
browseable = yes
#public = yes
public = no
writable = yes
        valid users = doug,sharon,lindag,suzyq,mike,root,@apps,@data

[doug2]
path = /doug2
available = yes
#browseable = no
browseable = yes
#public = yes
public = no
writable = yes
        valid users = doug,root
See some clues in there? I hope?

Thanks, jschiwal!
 
Old 08-04-2006, 05:43 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I think that the winbindd service would be more important for the 3 Ubuntu workstations.

From the winbindd manpage:
Code:
NAME
       winbindd - Name Service Switch daemon for resolving names from NT servers

SYNOPSIS
       winbindd [-F] [-S] [-i] [-Y] [-d <debug level>] [-s <smb config file>] [-n]

DESCRIPTION
       This program is part of the samba(7) suite.

       winbindd  is  a daemon that provides a number of services to the Name Service Switch capability found in most modern C
       libraries, to arbitary applications via PAM and ntlm_auth and to Samba itself.

       Even if winbind is not used for nsswitch, it still provides a service to smbd, ntlm_auth and  the  pam_winbind.so  PAM
       module,  by  managing  connections to domain controllers. In this configuraiton the idmap uid and idmap gid parameters
       are not required. (This is known as ‘netlogon proxy only mode’.)

       The Name Service Switch allows user and system information to be obtained from different databases  services  such  as
       NIS or DNS. The exact behaviour can be configured throught the /etc/nsswitch.conf file. Users and groups are allocated
       as they are resolved to a range of user and group ids specified by the administrator of the Samba system.

       The service provided by winbindd is called ‘winbind’ and can be used to resolve user and group information from a Win-
       dows NT server. The service can also provide authentication services via an associated PAM module.
A wins server is similar to a DNS server but it includes netbios information that a DNS server doesn't. This may help the windows 95 machines see the other machines and shares on the network.

You are using the "security = user" mode. That is what I use. Does the server have users with home partitions? If not, maybe you can delete the [homes] section.

By the way, there may be 3 samba books in /usr/share/doc/packages/samba/. One of them is "Samba 3 by Example" which includes a number of sample setups including what you need to do on the Windows machines.
 
Old 08-04-2006, 08:41 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I almost forgot. In the Samba 3 by Example documentation, there is an example where for Windows ME, a registry entry was edited to turn off password caching. I wonder if you need to do that for Windows 95 also.
 
Old 08-04-2006, 02:34 PM   #6
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

jschiwal--

Thanks!

I will check out what you have suggested over the weekend.

In the meantime, I wonder--

I posted about the samba issue last night on Gmane network.samba.general and today someone came back with "what do you think about a switch (or hub, of course) failure?"

So what do you think about that?

Here's the other side--for the past two weeks I have been trouble shooting a connection to pop.compuserve.com to collect my e-mail. I cannot from any machine get e-mail from there or even telnet there, except maybe once in 10 tries.

The switch is a Linksys EZXS16W. It is about 3 years old.

Is there a way to test? Note that when I tested a direct connection to the modem I skipped both the switch and the router. When I did that I could collect e-mail.

As I think about it, could I just take the cable that goes from switch to router and plug that directly to the modem?

And what about testing to eliminate the switch? I don't have any female to female ethernet adapters around here, but I have an old hub from 10 years ago.

Thanks, jschiwal!
 
Old 08-04-2006, 10:26 PM   #7
scott2004
Member
 
Registered: Nov 2004
Location: Toronto, Canada
Distribution: Debian, OpenBSD, SuSE, Ubuntu
Posts: 68

Rep: Reputation: 15
One thing that I noticed in your smb.conf is this line:

encrypt passwords = true

I know that Windows 2000 and XP require this to be turned on, but that older Windows do not. Could it be that Win95 doesn't know how to encrypt its passwords, and therefore cannot connect?

You could test this theory by setting up a purely public share. The share declaration "guest only = yes" will allow clients to connect without providing any account info.

Also I noticed that root is listed as an invalid user in the global section and as a valid user in a couple of shares. This probably is not the cause of your problem, but it is logically inconsistent.

Further, I think that mapping the shares by IP e.g.,
\\server-ip\share-name

should completely sidestep any netBIOS or Winbind issues. If you can't map drives in that way, I don't think that WINS/Winbind would help. Of course, anything's possible and I'm no expert.

You could lastly try form the command line in DOS:

net use S: \\server-ip\share-name /username:valid-user
 
Old 08-05-2006, 11:53 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
If you can ping from the Windows 95 computers to the servers, the switch is probably OK.
You samba services may be started from a "smb" script that starts both smbd and nmbd.
I don't have ubuntu but if you can determine the name of the script, you can run it with the "status" option to see if both are running.

On Fedora, this is the case, and running: "sudo /sbin/service smb" will give you the status of both services.
On SuSE, you would run them separately. You could try "locate smb" to find where the scripts are, and also "locate service".
sudo /usr/sbin/rcsmb
sudo /usr/sbin/rcnmb

If Ubuntu isn't debian or slackware based, then "chkconfig smb" might return information also.

On SuSE:
Code:
# chkconfig --list | egrep '(smb|nmb|winbind)'
nmb                       0:off  1:off  2:off  3:on   4:off  5:on   6:off
pamsmbd                   0:off  1:off  2:off  3:off  4:off  5:off  6:off
smb                       0:off  1:off  2:off  3:on   4:off  5:on   6:off
smbfs                     0:off  1:off  2:off  3:on   4:off  5:on   6:off
winbind                   0:off  1:off  2:off  3:off  4:off  5:off  6:off
 
Old 08-06-2006, 09:26 PM   #9
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

Scott2004--

Interesting things you turned up.

dos did not like the /username bit, but here is what happened:

Code:
C:\>net use S \\192.168.0.112\vol2 /home

Error 53: The computer name specified in the network path cannot be located.
Make sure you are specifying the computer name correctly, or try again later
when the remote computer is available.
I thought I had, but guess I didn't try mapping by ipaddress. Just did, and it worked!

Is that a clue?

Another thing to report: This weekend I replaced the failed data HDD in the old server. The HDD that held the OS is still working. When I booted it up, samba and all network connections worked as they were supposed to. So I copied all data over from the new server to the older server, and am up and running on the older one.

What I think that tells us is that I need to work on the samba configuration. My plan is to try to get swat up and running and use that to try to tweak things on the newer server. Sound like a good plan?

jschiwal--

Ubuntu is debian based.

Thank you for sticking with me on this.

I plan to report back after I have tried the swat thing.

Thanks, guys!
 
Old 08-06-2006, 10:56 PM   #10
scott2004
Member
 
Registered: Nov 2004
Location: Toronto, Canada
Distribution: Debian, OpenBSD, SuSE, Ubuntu
Posts: 68

Rep: Reputation: 15
Doug,

So, am I correct in understanding that mapping the share using the IP worked? If so good.

I just noticed this section in your smb.conf:

##############added by ddg 20060726
smb ports = 445
#############

I haven't come across this option before and suspect it might be a problem, too. Try commenting it out (or just deleting it - you don't need it) and restarting samba. If you don't know how to restart just the service, reboot the server.

NetBIOS (name to IP resolution for Windows clients) uses TCP and UDP ports in the 136-139 range, so telling samba to only use 445 might cause name resolution problems that would especially effect older machines like Windows 95.

Scott
 
Old 08-06-2006, 11:09 PM   #11
scott2004
Member
 
Registered: Nov 2004
Location: Toronto, Canada
Distribution: Debian, OpenBSD, SuSE, Ubuntu
Posts: 68

Rep: Reputation: 15
Oh, and the proper syntax for the "net use" command can be found here:

http://www.microsoft.com/resources/d....mspx?mfr=true

It's "/user:" not "/username:" , my mistake.

corrected:
net use S \\192.168.x.x\vol2 /user:doug

There is however a username= option when you map an smb share from Linux, and this must be where I got this from.
 
Old 08-07-2006, 09:15 PM   #12
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Smile

scott2004--

Thanks, Scott!

Quote:
So, am I correct in understanding that mapping the share using the IP worked? If so good.
Yes, you are correct. What is that telling us, if anything?

Quote:
I just noticed this section in your smb.conf:

##############added by ddg 20060726
smb ports = 445
#############

I haven't come across this option before and suspect it might be a problem, too. Try commenting it out (or just deleting it - you don't need it) and restarting samba. If you don't know how to restart just the service, reboot the server.
I had another thread somewhere about samba being slow on this new server. Someone suggested this line, so I tried it. I commented it out last night on a test, but not sure I rebooted. I thought samba changes took effect right away. But then I think I remember swat had a restart switch. So I will restart it and see.

OK, I did reboot and it seems to have worked. Strangely, but it logs in.

Oh, I had also changed the setting from master server to be = no. The older server was objecting, saying in the logs, We thought we were the master.

But when Win95 logs in, it reports that it is logging in to a mixture of the name of the server (earth) and its ipaddress (192.168.0.112). Win95 reports it is Vol1 on 'Earth68.0.112'. Well, that is something that I can live with.

So, problem pretty well solved.

Oh, and DOS didn't like user:doug any better:

Code:
H:\comm\tap\2006\dl>net use S \\192.168.0.112\vol2 /user:doug
The option "USER:DOUG" is unknown. Make sure you are specifying a valid
option, and then try again.
For help, type NET USE /? at the command prompt.

H:\comm\tap\2006\dl>net use S \\192.168.0.112\vol2 /user: doug
The option "USER:" is unknown. Make sure you are specifying a valid option,
and then try again.
For help, type NET USE /? at the command prompt.
Thanks for your help on this. I think you two have figured it out!
 
Old 08-07-2006, 10:55 PM   #13
scott2004
Member
 
Registered: Nov 2004
Location: Toronto, Canada
Distribution: Debian, OpenBSD, SuSE, Ubuntu
Posts: 68

Rep: Reputation: 15
The way Windows shows mapped samba drives is always a little weird. The same is true, however, for how it handles mapped Windows 2000 or 2003 server drives, though. It tries to use the netBIOS name, I guess. I like the way Linux just attached whatever media to the file system, seamlessly.

You might try commenting out this line:

server string = %h server (Samba, Ubuntu)

to see if that improves how the drives show up in the My Computer window. It may or may not make a difference. (I've often thought of trying it but never got around to it).

Samba does need to be manually restarted to re-read its configuration file. I seem to remember something like "samba reload" (like with squid, "squid -k reconfigure") but I don't think this is it. /etc/rc.d/smb restart works on SuSE systems and /etc/rc.d/init.d/smb restart works on Fedora and Mandriva. I'm not sure about Ubuntu/Debian systems.

I suspect the Win95 version of "net use" must not have a user option, as later ones do.

Anyway, glad to hear that aside from cosmetics, things are working again.

Scott
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
win95 connect Samba problem nelnel Linux - Networking 4 04-06-2006 03:44 AM
Redhat Samba with Win95 Hendon Linux - Networking 2 12-14-2004 11:39 AM
Samba 3.0.2 not mangling long names correctly for Win95/98 JLindenmuth Linux - Networking 0 03-25-2004 02:28 PM
Samba works with win95 but not ME blainehilton Linux - Networking 8 07-24-2003 06:48 AM
Win95 and Samba Half_Elf Linux - Networking 19 06-16-2002 11:31 PM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration