LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-17-2007, 05:09 PM   #1
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 69

Rep: Reputation: 16
localhost bind will not resolve from other clients


I'm running a closed network (not on the internet).
I'm running bind on a Fedora Core 5 box. Command line.
On other servers I'm also running bind.

From localhost I can resolve dns names such as
io.com, www.io.com, ftp.io.com, mail.io.com, and public.io.com.

In other words:
I can ping ftp.io.com from locally but not from another machine.

But from other clients the only dns name that gets resloved is the io.com. I have a dns server at 192.168.1.8 that everyone points to.

I have /etc/resolv.conf set as:
nameserver 127.0.0.1
nameserver 192.168.1.8


Any hints on what else could be wrong. The only files I've edited are:

named.conf, io.com.zone, and rev.168.192.zone

Thanks,
cwc
 
Old 01-17-2007, 05:16 PM   #2
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Please post your io.com.zone and rev.168.192.zone files and let's have a look.

All of these machines are running bind..are they setup as slaves
 
Old 01-17-2007, 06:39 PM   #3
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 69

Original Poster
Rep: Reputation: 16
It will be 10 hours before I'm back at the network location.

All computers are running bind. I don't think io.com is set as a slave.
How do you script a slave?

Last edited by cwc; 01-17-2007 at 10:01 PM.
 
Old 01-17-2007, 10:06 PM   #4
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 69

Original Poster
Rep: Reputation: 16
Thanks for the reply xjlittle!

// named.conf
// named.conf for Red Hat caching-nameserver
//
acl io-com {192.168.1.0/24; 127.0/8;};
options {
directory "/var/named";
allow-query {tma-com;};
//dump-file "/var/named/data/cache_dump.db";
//statistics-file "/var/named/data/named_stats.txt";
forwarders {192.168.1.8;};
forward only;
/* 192.168.1.8 is the main nameserver custom configured
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};

zone "." IN {
type hint;
file "named.ca";
};

zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
type master;
file "named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa" IN {
type master;
file "named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa" IN {
type master;
file "named.zero";
allow-update { none; };
};

#forward zone
zone "io.com" IN {
type master;
file "io.com.zone";
};

#reverse zone
zone "1.168.192.in-addr.arpa" IN {
type master;
file "192.168.1.zone";
};

include "/etc/rndc.key";
------------------------------------
//io.com.zone

$TTL 1D
io.com. IN SOA io.com. root.io.com. (
2007011701 ; serial
2H ; refresh slaves
5M ; retry
1W ; expire
1M ; Negative TTL
)

@ IN NS io.com.

io.com. IN A 192.168.1.13;

www IN CNAME io.com. ;
ftp IN CNAME io.com. ;

------------------------------------
//192.168.1.zone

$TTL 1D

@ IN SOA io.com. root.io.com. (
20070116701 ; serial
2H ; refresh slaves
5M ; retry
1W ; expire
1M ; Negative TTL
)

IN NS io.com.
13 IN PTR io.com.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to resolve any hostnames, including localhost calamari Linux - Networking 10 11-02-2005 01:17 PM
can't resolve localhost auji Linux - Networking 16 09-29-2005 02:39 PM
my bind 8.2.4 sometime can't resolve name chhansopheaktra Linux - Networking 2 08-11-2005 06:29 AM
Can bind 9 (DNS) resolve names based on who's asking?? (internal vs. external clients registering Linux - Networking 3 06-16-2004 07:25 AM
postfix can't resolve localhost yapp Linux - Networking 2 12-02-2003 01:48 PM


All times are GMT -5. The time now is 02:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration