LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-07-2003, 07:19 PM   #1
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Rep: Reputation: 0
Localhost 127.0.0.1 may be forged ??


Hi,

I am running RedHat 8.0 and have a problem with SendMail.
I am using DSL and a dynamic service for DNS. I can send and receive mail okay using mail/pine from the server console.

The problem is that when I send mail to others, it has the following in the headers

Received: from server.mydomain.net (localhost [127.0.0.1] (may be forged))

This is causing the messages to be rejected by a lot of mail servers. Is there any way I can stop Sendmail from doing this ?

Thanks
 
Old 03-08-2003, 12:19 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
You have not configured your Sendmail. Open sendmail.cf file in any editor and change your IP, server name and so on.
 
Old 03-12-2003, 11:20 AM   #3
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Actully I have configured send mail using the sendmail.mc file and ran the M4 command.

I can send messages when logged onto the server with ssh using pine or the mail command. I can also read my messages.

Just cannot send from a pop client.
 
Old 03-13-2003, 01:52 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Try to connect using telnet:
telnet yourmachine pop3
+OK (message with 'ready' or 'ok')
USER yourlogin
+Ok User name accepted (or similar)
PASS yourpassword
And you should be logged in. In your case, there should be an error. Note it down.
BTW You don't send via POP3. You send using SMTP.
 
Old 03-14-2003, 12:14 AM   #5
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the reply.

I tried that and here is what I got from:

telnet mymachine pop3

+OK pop3 machinename.domainname.com v2001.78.rh server ready
USER myusername
+OK Username accepted, password please
mypassword
-ERR Unknown AUTHORIZATION state command
 
Old 03-14-2003, 01:03 AM   #6
Z28kid
Member
 
Registered: Jan 2003
Location: Long Island
Posts: 72

Rep: Reputation: 15
Mzee, i have the same setup as you except i have a cable modem.

How did you set up your sendmail?

what changes did you make in the sendmail.cf or sendmail.mc

Are you able to reciever mail from the outside world?

I would really appericate the help....

Also this way are you able to set up a email like

Webmaster@mydomain.com
 
Old 03-14-2003, 04:23 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Quote:
Originally posted by Mzee

+OK Username accepted, password please
mypassword
-ERR Unknown AUTHORIZATION state command
Should be:
+OK Username accepted, password please
PASS mypassword
 
Old 03-14-2003, 07:55 PM   #8
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
ohh ohh

did that and I got

+OK Mailbox open, 0 messages




And just for kicks I tried the following in my sendmail.mc
FEATURE(`relay_local_from') and all messages flow from workstations like crazy ...... and from spammers as well.

I have taken it back to FEATURE(`relay_hosts_only') and put all my hosts in the access.db with RELAY (tried OK as well) and the problem still persists.......


help
 
Old 03-14-2003, 08:07 PM   #9
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
@Z28kid

Quote:
Originally posted by Z28kid
Mzee, i have the same setup as you except i have a cable modem.

How did you set up your sendmail?

what changes did you make in the sendmail.cf or sendmail.mc

Are you able to reciever mail from the outside world?

I would really appericate the help....

Also this way are you able to set up a email like

Webmaster@mydomain.com

I am able to receive mail from the outside world.
The only changes that I have made that seem to work are

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl : To enable sendmail to listen on my network interface

LOCAL_DOMAIN(`mydomain.net')dnl : To reflect my actual domain

MASQUERADE_AS(`mydomain.net')dnl : To masq emails to appear to be from mydomain.net

FEATURE(masquerade_entire_domain)dnl : enabled this ... cant remember why ....

Hope that make sense ....
 
Old 03-14-2003, 08:37 PM   #10
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Typically the "may be forged" message appears when the forward and reverse DNS entries do not match. Does server.mydomain.net point to 127.0.0.1 or the public IP of the system? Some distro like to put the server name in /etc/hosts on the same line with localhost.

Last edited by stickman; 03-14-2003 at 08:39 PM.
 
Old 03-15-2003, 04:11 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Re: @Z28kid

Quote:
Originally posted by Mzee

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl : To enable sendmail to listen on my network interface
I think there's the problem. Any non-local IP would be much better.
 
Old 03-16-2003, 01:48 AM   #12
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Do I need to have something else for that feature !!!!!


I thought that removing the feature completely defaults sendmail to listen to my network interface ???
 
Old 03-16-2003, 11:45 AM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Try to remove it. Sendmail should search for interface and use it. NOTE: Comment it out, don't remove. Just in case.
 
Old 03-18-2003, 09:30 PM   #14
Mzee
LQ Newbie
 
Registered: Mar 2003
Posts: 7

Original Poster
Rep: Reputation: 0
The line has always been commented out .....

results still unchanged
 
Old 03-20-2003, 02:51 PM   #15
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Could you post your sendmail.cf? But first try this:
yourdomain.net define(`confDOMAIN_NAME', `$w.$m')dnl
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE/CUPS printer slow to start up; fixed with "127.0.0.1 localhost" in /etc/hosts KWTm LinuxQuestions.org Member Success Stories 0 03-05-2005 12:11 PM
postfix ? (may be forged) emetib Linux - Software 2 01-08-2005 02:05 PM
DSN: Data format error & relay=[127.0.0.1] [127.0.0.1] calmbomb Linux - Software 0 11-07-2004 04:24 PM
127.0.0.1 v localhost.localdomain Bill Barrington Linux - Software 2 06-28-2003 08:47 PM
localhost vs computer name vs 127.0.0.1 modeler4547 Linux - General 0 02-26-2003 06:53 PM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration