LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-20-2004, 12:42 PM   #1
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Rep: Reputation: 15
local network configure failed


Here is a strange thing.

I have been trying to install a local network. I have a K6-2 desktop and a P4 laptop, both kernel V2.4.20 with red hat linux 9. The desktop is connected to internet vai an usb device, and its Ethernet card (a 3C900 COMBO) is for local network with my laptop and its broadcom bcm 4401 Ethernet controler.

I have double boot with windows. I was using windows on desktop.
I boot under linux with the laptop.
I have added IPADDR, NETMASK and BROADCAST to the ifcfg-eth0 file to parameter my eth0 (forbroadcom bcm4400) interface:
IPADDR= 192.168.1.2
BROADCAST=192.168.1.255
NETMASK=255.255.255.0
BOOTPROTO=none
ONBOOT=yes
PEERDNS=yes
TYPE=Ethernet
...

But mounting eth0 interface at laptop boot still always fails.

So I still do it manually:
# ifconfig eth0 192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.255 up

Then
#lsmod | grep bcm4400
bcm4400 35584 1

Here is what is strange. At this point, I can ping both computers (laptop with linux and desktop with windows)
Then I reboot my desktop, and I can still ping both computers.
Rebooting now the laptop, and after the manual setup of eth0, I get "NIC link is down"
Impossible to ping both computers now.!


What happened ? Can anybody tell me what is wrong ?
May be settings of my desktop ? Here are few informations below:


Cheers, xround.

PS: eth0 is for the usb device and eth1 is for the 3C900 COMBO

# more /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

# more /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
IPADDR=192.168.1.1
ONBOOT=yes

# more /etc/hosts
127.0.0.1 localhost.localdomain localhost
 
Old 08-20-2004, 02:37 PM   #2
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
Just tried booting with my desktop while my laptop was running, and get

C:\>ping 192.168.1.2

Envoi d'une requête 'ping' sur 192.168.1.2 avec 32 octets de données :

Réponse de 192.168.1.2 : octets=32 temps<10 ms TTL=64
Réponse de 192.168.1.2 : octets=32 temps<10 ms TTL=64
Réponse de 192.168.1.2 : octets=32 temps=10 ms TTL=64
Réponse de 192.168.1.2 : octets=32 temps<10 ms TTL=64


from windows.

Can I get help please ?
I am getting mad. Has my desktop under linux a wrong config ?

Please help.


Cheers, xround.
 
Old 08-22-2004, 10:12 AM   #3
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
can somebody help me ?

Please, help!
 
Old 08-22-2004, 12:21 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,897

Rep: Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746
Quote:
IPADDR= 192.168.1.2
BROADCAST=192.168.1.255
NETMASK=255.255.255.0
BOOTPROTO=none
ONBOOT=yes
PEERDNS=yes
TYPE=Ethernet
Change the BOOTPROTO=NONE to
BOOTPROTO=STATIC

This should fix the laptop eth0 configuration problem at boot.
 
Old 08-22-2004, 12:51 PM   #5
posto
LQ Newbie
 
Registered: Jul 2004
Location: RO, Bucharest
Distribution: Ubuntu
Posts: 12

Rep: Reputation: 0
if you set up your link manually, the configuration will be reset after next reboot. To make the changes permanent edit the config file
 
Old 08-23-2004, 04:24 AM   #6
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
After the modification, ifconfig still didn't display eth0 settings (noIPADDR, no NETMASK, ...)

On the laptop, I found an ifcfg-eth0 in directory /etc/sysconfig/networking/devices/ifcfg-eth0. I made a copy of /etc/sysconfig/network-scripts/ifcfg-eth0 in this file, and now eth0 settings are ok.

But I still have the message "NIC Link is down" on my laptop. And it is still impossible to ping both comptuters.
I don't understand why ping with windows on my desktop is ok when linux fails.

xround.
 
Old 08-23-2004, 08:47 AM   #7
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
Fianally, using the following command on my desktop
# /etc/init.d/network restart

the job succeeds!
But what can I do if I want that the laptop is recognized automatically ?
Posto, which "config" file do I have to use ?

Cheers, xround.
 
Old 08-23-2004, 01:18 PM   #8
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
trying dhcp

Does anybody know the differences between /etc/sysconfig/networking/devices
and
/etc/sysconfig/network-scripts/

I have installed a dhcp server on my desktop. The deamon start at boot (Iused ntsysv for that).
When I use /etc/init.d/network restart on the laptop, I loose the eth0 configuration I have set both files
/etc/sysconfig/networking/devices/ifcfg-eth0
and
/etc/sysconfig/network-scripts/ifcfg-eth0
like this:
Code:
USERCTL=no
PEERDNS=yes
TYPE=Ethernet
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
Now the 3 files :
/etc/sysconfig/networking/devices/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth0
and
/etc/sysconfig/networking/profiles/default//ifcfg-eth0
are the same.

But I still have to use
# /etc/init.d/network restart
on the server (desktop) to start the connection.

In fact, I must configure first the etherent card of the laptop with ifconfig.
Then using,
# /etc/init.d/network restart
on the desktop starts the connection (ping is ok at this point).

Finally, in order to verify that dhcp is active, I use
# /etc/init.d/network restart
on the laptop. The file /var/lib/dhcp/dhcpd.leases contains the new address that the desktop dhcp server attributes to my laptop dhclient:
192.168.1.60, ....

But I am still with the problem : and no automatic setting of the broadcom ethernet contrloler.

Any help,
xround.
 
Old 08-24-2004, 04:29 AM   #9
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
please help again!!

Today, I tried another thing.
Booting my laptop first, the eth0 device on laptop being well configured, then I can boot directly desktop, and the loacl network is ok for ping.

Has anybody an idea ? Plese help!
xround
 
Old 08-24-2004, 02:28 PM   #10
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
When I try to launch the redhat-config-network, I get an error message. Is it possible to solve that bug ? I must have modified some files in /etc/sysconfig/networking/devices, that I shouldn't have modify.

Xround.


I get the 2 following messages :

Message 1

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py:43:getDeviceClass:KeyError: Inconnu
Traceback (most recent call last):
File "/usr/sbin/redhat-config-network-gui", line 154, in ?
window = mainDialog()
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 154, in __init__
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 225, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 232, in loadDevices
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 210, in getDeviceList
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 114, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py", line 43, in getDeviceClass
KeyError: Inconnu

Local variables in innermost frame:
subtype: None
self: {'Wireless': {0: <class netconfpkg.plugins.NCDevWireless.DevWireless at 0x844aa3c>}, 'Token Ring': {0: <class netconfpkg.plugins.NCDevTokenRing.DevTokenRing at 0x846a7b4>}, 'CIPE': {0: <class netconfpkg.plugins.NCDevCipe.DevCipe at 0x840bcac>}, 'Ethernet': {0: <class netconfpkg.plugins.NCDevEthernet.DevEthernet at 0x83d5364>}, 'Modem': {0: <class netconfpkg.plugins.NCDevModem.DevModem at 0x83dd7e4>}, 'xDSL': {0: <class netconfpkg.plugins.NCDevADSL.DevADSL at 0x84ceafc>}, 'ISDN': {0: <class netconfpkg.plugins.NCDevIsdn.DevIsdn at 0x83db4cc>}}
type: Inconnu



Message 2

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/lib/python2.2/site-packages/rhpl/exception.py:280:handleException:TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
File "/usr/sbin/redhat-config-network-gui", line 169, in ?
handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in handleException
dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_type'

Local variables in innermost frame:
fs: <rhpl.exception.FileSelection instance at 0x82d4b04>
type: exceptions.KeyError
text: Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py:43:getDeviceClass:KeyError: Inconnu
Traceback (most recent call last):
File "/usr/sbin/redhat-config-network-gui", line 154, in ?
window = mainDialog()
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 154, in __init__
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 225, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 232, in loadDevices
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 210, in getDeviceList
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 114, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py", line 43, in getDeviceClass
KeyError: Inconnu

list: ['Traceback (most recent call last):\n', ' File "/usr/sbin/redhat-config-network-gui", line 154, in ?\n window = mainDialog()\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 154, in __init__\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 225, in load\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 232, in loadDevices\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 210, in getDeviceList\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 114, in load\n', ' File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py", line 43, in getDeviceClass\n', 'KeyError: Inconnu\n']
progname: redhat-config-network
value: Inconnu
tb: <traceback object at 0x865a3f4>
extxt: ['KeyError: Inconnu\n']
version: 1.2.0
t: getDeviceClass
file: /root/bug-reseau
rc: -5
.0: (<class exceptions.KeyError at 0x81192ec>, <exceptions.KeyError instance at
0x8628c6c>, <traceback object at 0x865a3f4>)
tblast: ('/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceFactory.py', 43, 'getDeviceClass')
out: <closed file '/root/bug-reseau', mode 'w' at 0x866d898>
 
Old 08-25-2004, 05:19 AM   #11
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Original Poster
Rep: Reputation: 15
Is anybody here ? Does anybody care ?

I may get mad soon, while "soliloquing". Nervermind, I will continue even if I am getting sick.

Does anybody know how I can make a deep checking concerning my 2 "ehternet" cards.
I would like to know more about this, because originally, My config was like this:
Either
Internet <-> Modem (Free) <- (via RJ45 CABLE) -> 3C900 COMBO Ethernet Card of my DESKTOP
Or
Internet <-> Modem (Free) <- (via RJ45 CABLE) -> BC4401 Broadcom Ethernet controler of my LAPTOP

And both cards where recognized as eth0

Now I have the following config:

Internet <-> Modem (Free) <- (via USB CABLE) -> USB HUB <- (via USB CABLE) -> USB Card on Desktop
eth0 interface is relied to this connection.

And I use a "crossed" cable and both "3C900 COMBO" and "BC4401 Broadcom" for my local netwok.
And the 3C900 Combo interface is now eth1

Code:
# lsmod | grep 3c59
3c59x                  29360   1
# lsmod | grep CDCEther
CDCEther               13500   1
usbcore                73088   1  [CDCEther acm hid ehci-hcd usb-ohci]

# modprobe -c | grep eth
alias eth0 off
alias eth1 3c59x
Can my problems raise from these changes ?
Is it normal that eth0, a name used for Ethernet Cards, relies to USB stuff ??


xround, and around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
failed to send 'clear' to local ypserv: RPC:Program not registered beginner16 Linux - Newbie 3 04-29-2014 12:25 PM
configure proftp for the local network only regisG Linux - Networking 1 09-04-2004 03:38 AM
boot.local failed (suse 9.1) Big Money Linux - Software 10 08-06-2004 09:59 PM
How to Configure POstfix for Local Network jay_gonzales Red Hat 0 02-20-2004 09:10 PM
Cannot resolve local addresses on local network danielgrenyer Linux - Networking 6 01-14-2004 11:03 AM


All times are GMT -5. The time now is 04:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration