LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-11-2006, 04:59 PM   #1
paatagog
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
local DNS has 2 second timeout


Hello everybody,

I am new in linux systems. I have problems with DNS on SUSE 9.2. Particularly - I get the timeout in local DNS when queuing the local domain name

I have connected my personal PC with the server (SUSE 9.2 with BIND) and no other computers are connected to this "network" (no internet, no intranet, only 2 computers).


PC (85.238.43.37) ---------- (85.238.43.38) SUSE


SUSE has the BIND with the domain name amigo.ge



1. when I type the nslookup on my PC(and choosing 85.238.43.38 as server), I get the correct answer for amigo.ge, but with the timeout of 2 seconds
though
2. when I type nslookup on my SUSE machine and query for amigo.ge it is ok and I get the IP address 85.238.43.38 without any timeout!

here is my named.conf

Code:
options {
    directory "/var/lib/named";
};

zone "." {
    type hint;
    file "/var/lib/named/root.hint";
};

zone "localhost" {
        type master;
        file "/var/lib/named/localhost.zone";
};

zone "amigo.ge" IN	{
    type master;
    file "/var/lib/named/amigo.ge.zone";
};

zone "43.238.85.in-addr.arpa" IN	{
    type master;
    file "/var/lib/named/85.238.43.zone";
};

zone "0.0.127.in-addr.arpa" IN	{
    type master;
    file "/var/lib/named/127.0.0.zone";
};
here is my zone files

amigo.ge.zone
Code:
@	IN	SOA	ns0.amigo.ge. admin.amigo.ge. (
  	1134834874
  	10800
  	3600
  	604800
  	38400 )
	IN	NS	ns0.amigo.ge.
	IN	NS	ns1.amigo.ge.
amigo.ge.	IN	A	85.238.43.38
ns0.amigo.ge.	IN	A	85.238.43.38
ns1.amigo.ge.	IN	A	85.238.43.38
localhost.zone:
Code:
@  IN SOA	@   root (
    42	; serial (d. adams)
    2D	; refresh
    4H	; retry
    6W	; expiry
    1W )	; minimum

  IN NS  @
  IN A  127.0.0.1
localhost  IN A  127.0.0.1
85.238.43.zone:
Code:
$TTL 86400
@     IN     SOA    ns0.amigo.ge.     ns0.amigo.ge. (
                    2001062501; serial
                    21600     ; refresh after 6 hours
                    3600      ; retry after 1 hour
                    604800    ; expire after 1 week
                    86400 )   ; minimum TTL of 1 day

      IN     NS     ns0.amigo.ge.
38    IN     PTR    ns0.amigo.ge.
127.0.0.zone
Code:
$TTL 1W
@  IN SOA  localhost.   root.localhost. (
    42	; serial (d. adams)
    2D	; refresh
    4H	; retry
    6W	; expiry
    1W )	; minimum

  IN NS  localhost.
1  IN PTR  localhost.

the results of queries from the PC (queries from SUSE is ok)

Code:
> server 85.238.43.38
DNS request timed out.
    timeout was 2 seconds.
Default Server:  [85.238.43.38]
Address:  85.238.43.38

> 127.0.0.1
Server:  [85.238.43.38]
Address:  85.238.43.38

Name:    localhost
Address:  127.0.0.1

> 85.238.43.38
Server:  [85.238.43.38]
Address:  85.238.43.38

Name:    ns0.amigo.ge
Address:  85.238.43.38

> amigo.ge
Server:  [85.238.43.38]
Address:  85.238.43.38

DNS request timed out.
    timeout was 2 seconds.
Name:    amigo.ge
Address:  85.238.43.38

> localhost
Server:  [85.238.43.38]
Address:  85.238.43.38

DNS request timed out.
    timeout was 2 seconds.
*** Request to [85.238.43.38] timed-out
>

the reverse lookup is ok, but I have timeout for amigo.ge lookup. ( I mentioend above that the resolving of name amigo.ge is immediate (no timeout) if i type the nslookup command on my suse machine. )

named-checkzone and named-cheeckconf commands writes that everything is ok.

Please help to resolve the problem.
 
Old 02-11-2006, 09:18 PM   #2
wilby
LQ Newbie
 
Registered: Feb 2006
Posts: 11

Rep: Reputation: 1
Try adding
IN A 85.238.43.38
in to your amingo.ge.zone file after your time out options.
 
Old 02-13-2006, 02:38 AM   #3
paatagog
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Unhappy

wilby
Thank you for reply. I added this line to my zone file. Now my zone file looks like
Code:
@	IN	SOA	ns0.amigo.ge. admin.amigo.ge. (
			1134834874
			10800
			3600
			604800
			38400 )
	IN	A	85.238.43.38
	IN	NS	ns0.amigo.ge.
	IN	NS	ns1.amigo.ge.
ns0.amigo.ge.	IN	A	85.238.43.38
ns1.amigo.ge.	IN	A	85.238.43.38
amigo.ge.	IN	A	85.238.43.38
but the problem is not fixed, the timeout remains 2 seconds again.
 
Old 02-13-2006, 05:48 PM   #4
wilby
LQ Newbie
 
Registered: Feb 2006
Posts: 11

Rep: Reputation: 1
Sorry friend that's all I really had for you. Everything else looks good. I would read the bind/named how to at ldp. Once again sorry I couldn't help better.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TEMP_FAILURE: DNS Error: Timeout while contacting DNS servers when receiving emails tonysutherland Linux - Networking 2 02-10-2006 09:04 AM
How to configure DNS for a local LAN (at least I think I want DNS) FlyingPenguin128 Linux - Networking 8 12-11-2005 04:15 PM
Sendmail: timeout waiting for input from local during Draining Input andrewstr Linux - Software 0 07-14-2004 01:43 PM
dns check outside dns before local reaky Linux - Networking 1 02-22-2004 09:27 AM
need some local DNS help rnorton Linux - Networking 4 02-10-2003 05:50 PM


All times are GMT -5. The time now is 05:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration