LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-04-2004, 11:43 AM   #1
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Rep: Reputation: 15
Linux Network Settings


Hello all,

I am trying to add a Linux machine to my network. I am very new at this, and my minimal experience was over a year ago.

I used the ifconfig eth0 to set the IP Address & the Mask, the Bcast was set automatically.

As I still can't ping the Linux machine from my LAN, I think it is my gateway addr. (Currently 0.0.0.0).

I JUST DON"T KNOW HOW TO CHANGE IT and cant see to find the correct command parameters.

Anyone?
 
Old 05-04-2004, 12:09 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
try this,

route add default gw xxx.xxx.xxx.xxx

more info would be helpfull, distro, etc.

have you tried running netconfig?
 
Old 05-04-2004, 12:26 PM   #3
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
Running SuSE 7.3

I added the gw as per your instructions, but when I ifconfig I see the following:

TX packets:0 errors:10 dropped:0 overruns:0 carrier:20
 
Old 05-04-2004, 12:29 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
could we see the output of ifconfig, and route -n, also try running netconf.
 
Old 05-04-2004, 12:30 PM   #5
bladrag
LQ Newbie
 
Registered: Feb 2004
Location: mtl
Posts: 12

Rep: Reputation: 0
what is the full output of ifconfig and route,
 
Old 05-04-2004, 12:36 PM   #6
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
eth0 Link encap:Ethernet HWaddr00:20:18:56:81:xx
inet addr:10.1.10.21 Bcast:10.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::220:18ff:fe56:817b/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:10 dropped:0 overruns:0 carrier:20
TX packets:0 errors:10 dropped:0 overruns:0 carrier:20
Collision:170 txqueuen:100
RX bytes:0 (0.0 b) TX bytes:724 (724.0 b
 
Old 05-04-2004, 12:36 PM   #7
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
OOPS, Not complete. 1 min. please
 
Old 05-04-2004, 12:43 PM   #8
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
eth0 Link encap:Ethernet HWaddr00:20:18:56:81:xx
inet addr:10.1.10.21 Bcast:10.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::220:18ff:fe56:817b/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 carrier:20
TX packets:0 errors:10 dropped:0 overruns:0 carrier:20
Collision:170 txqueuen:100
RX bytes:0 (0.0 b) TX bytes:724 (724.0 b)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.0 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
Collision:0 txqueuen:0
RX bytes:2184 (2.1 Kb) TX Bytes:2184 (2.1 Kb)

route -n

Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.10.1 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 10.1.10.1 0.0.0.0 UG 0 0 0 eth0
 
Old 05-04-2004, 07:04 PM   #9
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
have a look at this

http://portal.suse.com/sdb/en/1999/12/nic.html

good luck.
 
Old 05-05-2004, 08:35 AM   #10
ChangeOfPace
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
Followed the link you gave me. I used YAST to config the eth0, but I am still having a problem.

YAST - Set the IP, Mask & GW

When I exit YAST, ifconfig down, ifconfig up & route -n

I see the correct IP & Mask BUT THE WRONG GW. This makes no sense to me. I also tried to add default gw, but that does not change the gw of my interface (eth0), it displays an additional line when I route -n.

Any suggestions?

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
network settings... piyushiitk Linux - Newbie 16 11-06-2005 07:10 PM
Network Settings kunkumd Linux - Software 1 05-06-2005 12:53 PM
Network settings in Amigo Linux hornmeister2000 Amigo 24 10-15-2004 09:59 PM
Network settings jklaroe Slackware 5 06-19-2004 05:17 PM
Network Settings Redhat Linux 8 manojkreddy Linux - Networking 2 08-05-2003 01:07 PM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration