LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-01-2003, 05:22 AM   #1
Sabeer
Member
 
Registered: Mar 2003
Posts: 38

Rep: Reputation: 15
Angry Linux Internal DNS Problem Help!!!!


Hi

I am a newbie to linux environment
I was been working in windows for the past years
Now i moved to linux
Can anyone please guide me in this

I have installed Red Hat Linux 8.0 with all packages

Now first they asked me to set up and internal DNS Server in Linux Envirionment

So I started configuring DNS Server in linux I used the DNS Configuration Console and at last confired it

The linux machine is a Local IP machine i kept as 192.168.1.130

and the name server as ns.texsupport.com

So when i do nslookup in my linux server i get the result as

Server: 192.168.1.130
Address: 192.168.1.130#53

Name: ns.techsupport.com
Address: 192.168.1.130

So I think my DNS is correct

I also configured This DNS to use a forwarder

My Problem is......
Now I went to a Windows client machine and configured this DNS ie i put this IP 192.168.1.130 in the network settings

But it is not working

when i put nslookup in the windows client it is showing the Server could not be found

So what could be the reason
Where I went wrong how to make the Windows client use this Linux DNS Server

Please any one guide me as i I newbie i have to learn lot as my first step was to configure the DNS.

Please guide me

you can also contact me at sabeer_a@hotmail.com

Regards
Sabeer
 
Old 04-01-2003, 06:07 AM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
You will need to install BIND (Berkeley Internet Naming Daemon) in order to use this machine as a DNS Server. If you are familiar with Windows NT's DNS Server, the Zone files are, in fact, portable between the two systems. With a little tweaking, you can grab zone files from an NT system located in C:\Winnt\System32\DNS and throw them onto your Linux machine in /var/named.

Your /etc/named.conf will contain entries like the following:
zone "bentz.no-ip.com" IN {
type master;
file "bentz.no-ip.com.zone";
allow-update { none; };
};

And your zone files, referenced above, will look like this.
/var/named/bentz.no-ip.com.zone:
@ 1D IN SOA bentz.no-ip.com. root.localhost. (
1997022700 ; Serial
28800 ; Refresh
14400 ; Retry
3600000 ; Expire
86400 ) ; Minimum
@ 1D IN NS bentz.no-ip.com.
@ 1D MX 5 bentz.no-ip.com.
@ 1D A 192.0.0.1
www 1D CNAME bentz.no-ip.com.

I hope this helps!
 
Old 04-01-2003, 06:12 AM   #3
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Whoops, I forgot to mention that if you installed all RH8 packages, NAMED is probably on your system already. Give it a start with '/etc/rc.d/init.d/named start'. You can also set it to start at boot time with 'chkconfig --level 345 named on'.

Also the following pdf should be considered a resource for hosting your own DNS server. It includes more step-by-step instructions that I ever could in a forum:
http://www.netikus.net/documents/Lin...stallation.pdf
 
Old 04-01-2003, 07:10 AM   #4
Sabeer
Member
 
Registered: Mar 2003
Posts: 38

Original Poster
Rep: Reputation: 15
Hi bentz

Thanks for ur reply
yes mine is Redhat 8.0
All is installed
I will also go througth the documents
But can you say me wheather i went wrong because i configured as per the hepl documnets
and when i put nslookup in the linux server i get no error

when tell me whetaher the configuration i made is a DNS server
when i configure my windows clients it does connects

Guide me futher


Regards
Sabeer
 
Old 04-01-2003, 07:49 AM   #5
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
nslookup on the Linux machine is going to utilize the DNS server specified in /etc/resolv.conf, not nessasarily the Linux machine itself. To test the local DNS server, go into nslookup and type 'server 127.0.0.1' and see if that works. If not, try to start the named service with '/etc/rc.d/init.d/named start'.

Once nslookup - 'server 127.0.0.1' works on the Linux machines, the Windows client should be able to utilize the Linux machine as a DNS server.
 
Old 04-02-2003, 07:53 AM   #6
Sabeer
Member
 
Registered: Mar 2003
Posts: 38

Original Poster
Rep: Reputation: 15
Hi Bentz,

I did what you said and also followed the pdf document mentioned by you

I think everything went right but reverse not working

you asked me do nslookup 'server 127.0.0.1'

see i think my forward lookup is working well
i will aslo send the configuration which i done this is for internal DNS server

please see my configuration carefully

here are my configurations

Before that i will tell i did not use the DNS configuration tool given by Red Hat 8.0
I only used the named config files and made changes

1. named.config file

## named.conf - configuration for bind
#
# Generated automatically by redhat-config-bind, alchemist et al.
# Any changes not supported by redhat-config-bind should be put
# in /etc/named.custom
#
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};

include "/etc/named.custom";

include "/etc/rndc.key";

options {
directory "/var/named/";
};

zone "." IN {
type master;
file "db.root";
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "linuxsupport.com" IN {
type master;
file "linuxsupport.com.zone";
allow-update { none; };
};

zone "1.168.192.in-addr.arpa" IN {
type master;
file "linuxsupport.com.zone.rev";
allow-update { none; };
};


2. /var/named/linuxsupport.com.zone

$TTL 86400

@ IN SOA linuxsupport.com. hostmaster.linuxsupport.com. (
2003043001 ;serial number
;increase this number whenever you make
;changes to this file. Its necessary for
;secondary servers to know if they have to update
;their zone data
10800 ; refresh every 10800 seconds
; tells a secondary server how often to
; contact a (the) master server
1800 ; retry every 30 minutes
; if a connect fails to a primary name server,
; connect again in 1800 seconds
1209600 ; expires records received from master server if I
; was not able to contact him for 1209600 seconds
604800 ) ; TTL tells other servers (cache) to keep the
; records of this zone (file) for 604800 seconds,
; then "refresh"

; we need at least one of those entries to make this file valid

IN NS email.linuxsupport.com.

;where to find the email server for our domain

IN MX 10 email.linuxsupport.com.

;the records
email IN A 192.168.1.130

;aliases for the email server

ftp IN CNAME email;
telnet IN CNAME email;
smtp IN CNAME email;
mail IN CNAME email;
mailhost IN CNAME email;
ns IN CNAME email;
ns1 IN CNAME email;

3. /var/named/linuxsupport.com.zone.rev

$ TTL 86400

@ IN SOA 1.168.192.in-addr.arpa. hostmaster.linuxsupport.com. (

3 ; serial
28800 ; refresh
7200 ; retry
604800 ; expire
86400 ; ttl
)

;we need at least one of those entries to make this file valid

IN NS email.linuxsupport.com.

;here we list the ip address in use

130 IN PTR email.linuxsupport.com.

4. /var/named/db.root

$TTL 86400

. IN SOA email.linuxsupport.com

root.email.linuxsupport.com. (

200304021 ; Serial
28800 ; Refresh
14400 ; Retry
3600000 ; Expire
86400 ) ; Minimum

IN NS email.linuxsupport.com.

email.linuxsupport.com. IN A 192.168.1.130

linuxsupport.com. IN NS email.linuxsupport.com.


So these are the configurations

i in my linux machine i went and put

nslookup
> email.linuxsupport.com

Result : Server: 192.168.1.130
Address: 192.168.1.130#53

Name: email.linuxsupport.com
Address: 192.168.1.130

So i think this is correct i am i right

Now if it put nslookup
> 192.168.1.130
Result:
Server: 192.168.1.130
Address: 192.168.1.130#53

** server can't find 130.1.168.192.in-addr.arpa: SERVFAIL

So this is the error

and wehn i put nslookup 'server 127.0.0.1'
Result:
Server: 192.168.1.130
Address: 192.168.1.130#53

** server can't find server\032127.0.0.1: SERVFAIL

and for nslookup ' server 192.168.1.130'
Server: 192.168.1.130
Address: 192.168.1.130#53

** server can't find server\032192.168.1.130: SERVFAIL


My primary DNS Server setting in Network configuration is 192.168.1.130
and host is texlinux

So these are all the details

I think some error in reverse lookups so can you please guide

and not able to query in windows client as i said you earlier

So kindly guide me where i went wrong i want to get sorted it out

waiting for your reply

Reagrds
Sabeer
 
Old 04-02-2003, 01:37 PM   #7
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
/var/named/linuxsupport.com.zone.rev needs to read:

@ IN SOA email.linuxsupport.com. hostmaster.linuxsupport.com. (

3 ; serial
28800 ; refresh
7200 ; retry
604800 ; expire
86400 ; ttl
)

Because the name server 'email.linuxsupport.com' is authoritative for the IP addess zone 1.168.192.in-addr.arpa, meaning that email.linuxsupport.com can be used to guide a client to reverse-resolving this IP addess to a name.

If your Windows clients aren't able to go into nslookup and type 'server 192.168.1.130' successfully, you've got some other problems...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcp internal dns problem snoyl Linux - Networking 0 12-02-2005 05:17 AM
DNS registration on internal network acb67 Linux - Networking 4 03-02-2005 01:14 PM
internal DNS Dawie Linux - Networking 1 09-11-2003 06:31 AM
Internal DNS Resolution Problem WeNdeL Linux - Networking 12 01-17-2003 01:12 PM
DNS For an internal network??? Milkman00 Linux - General 6 09-02-2002 03:38 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration