LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 12-20-2012, 09:58 AM   #1
dschuett
Member
 
Registered: Aug 2010
Posts: 40

Rep: Reputation: 1
Linux Gateway (CentOS) Randomly Loses Internet Connection


I have been using a Debian box as my gateway at my house. It has always worked great, but I decided to switch to CentOS because I am more familiar with it. However, I have been running into a very weird issue. Every once in awhile I will lose connection to the internet on eth0 (my WAN interface). The weird part is 'ifconfig' shows that I still have my public IP, 'route -n' shows all the correct routes, and 'ps ax | grep dhcpclient' shows:
Code:
/sbin/dhclient -1 -q -cf /etc/dhcp/dhclient-eth0.conf -lf /var/lib/dhclient/dhclient-eth0.leases -pf /var/run/dhclient-eth0.pid eth0
I have tried restarting networking, but I am still unable to route traffic across the internet. The only thing that seems to fix it is if I reboot the machine. It's almost as if when the modem goes offline, the box just never reconnects (even though it still shows that I have my public IP). Also, here is my /etc/sysconfig/network-scripts/ifcfg-eth0 file:

Code:
DEVICE="eth0"
BOOTPROTO="dhcp"
HWADDR="00:1B:B9:86:F4:D8"
ETHTOOL_OPTS="autoneg off speed 100 duplex full"
NM_CONTROLLED="no"
PEERDNS="no"
ONBOOT="yes"
TYPE="Ethernet"
UUID="5fecd87a-416b-4acc-8572-22bd04e16dac"
Hope someone can help me find the root cause of this strange issue.

Thanks for your time.
 
Old 12-20-2012, 11:15 AM   #2
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
You shoudl get back to debian

On a more serious note - it could be a DHCP issue, or a NIC bug. Run tcpdump on eth0 the next time you lose connectivity and see what you get. If it is a DHCP issue you might see requests going out and no replies. You can also try restarting the modem during the failure to see if it will reset it.
Are you using the same physical box with CentOS installed instead of Debian or a different PC?

Nik
 
  


Reply

Tags
centos, gateway, route


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu gateway box loses connection pavel989 Linux - Networking 8 10-29-2010 05:04 PM
[SOLVED] Internet connection randomly freezes. [MAC OS X] lupusarcanus Other *NIX 9 07-31-2010 11:59 PM
Internet connection quota with Linux gateway swcng2001 Linux - Networking 2 05-26-2006 10:20 AM
Internet connection drops randomly on Kubuntu 5.04 Electrolyte Linux - Networking 0 06-14-2005 01:48 PM
Sharing an internet connection with a Linux client through a 2000 server gateway thuan Linux - Networking 1 08-02-2001 02:55 PM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration