LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-10-2002, 05:30 PM   #1
GabeF
Member
 
Registered: Mar 2002
Location: New Hampshire, US
Distribution: Mandrake 8.0, Redhat 8.0
Posts: 101

Rep: Reputation: 15
LInux cable speed degrading


I have MDK8.0 connected through a Linksys BEFSR41 Cable Router. I have a Netgear fa311 nic.

At first, my speed was pretty good, but it seems to be degrading. On a cable connection, my speed on my winxp machine is about 70kb/s but on my linux box is only 150b/s. DHCP is off.

Here is the output from ifconfig:

eth0 Link encap:Ethernet HWaddr 00:02:E3:13:C3:AE
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:952 errors:555 dropped:0 overruns:0 frame:1576
TX packets:1016 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:455711 (445.0 Kb) TX bytes:149811 (146.2 Kb)
Interrupt:5 Base address:0x3000

I'm not a guru, but 555 errors probably isn't good.
 
Old 10-10-2002, 08:09 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
did you eliminate it being a cable problem?
 
Old 10-10-2002, 08:13 PM   #3
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
another thing,

maybe the cable router needs you to set a lower MTU

ifconfig eth0 mtu 1452
 
Old 10-10-2002, 08:20 PM   #4
kmistry
Member
 
Registered: Sep 2002
Distribution: Debian 3.0 (Sid)
Posts: 67

Rep: Reputation: 15
keep in mind linksys products aren't the greatest. during my experiance with them i would like to replace them with SMC or other products that are far superior. my router sometimes goes down to 75% packet loss!!! yes on ethernet part. (its dual wireless/ethenet)

a simple reset of the router (i guess ur distro should automatically figure out the connection is back on etc) and you should get your speeds back.
 
Old 10-10-2002, 08:48 PM   #5
GabeF
Member
 
Registered: Mar 2002
Location: New Hampshire, US
Distribution: Mandrake 8.0, Redhat 8.0
Posts: 101

Original Poster
Rep: Reputation: 15
Thanks for the suggestions. All though I thought I had fixed it, I think it is a cable problem.

Tried a "ping www.hotmail.com" as a test and got 100% packet loss

Last edited by GabeF; 10-10-2002 at 08:54 PM.
 
Old 10-11-2002, 02:20 AM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
www.hotmail.com is dropping pings

ping www.hotmail.com
PING www.hotmail.com (64.4.43.7) from ??.??.??.?? : 56(84) bytes of data.

--- www.hotmail.com ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss

try another address

ping www.linuxquestions.org
PING www.linuxquestions.org (208.247.106.177) from ??.??.??.?? : 56(84) bytes o
f data.
64 bytes from linuxquestions.org (208.247.106.177): icmp_seq=0 ttl=47 time=43.92
3 msec
64 bytes from linuxquestions.org (208.247.106.177): icmp_seq=1 ttl=47 time=39.84
0 msec

--- www.linuxquestions.org ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/mdev = 39.840/41.881/43.923/2.051 ms
 
Old 10-11-2002, 07:30 AM   #7
GabeF
Member
 
Registered: Mar 2002
Location: New Hampshire, US
Distribution: Mandrake 8.0, Redhat 8.0
Posts: 101

Original Poster
Rep: Reputation: 15
Yeah I remembed that after I posted.

other ping results:

ping www.linuxquestions.org:

55 packets transmitted, 47 packets received, 14% packet loss
round-trip min/avg/max/mdev 35.023/46.407/113.110/17.803

Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Degrading system performanc crithke Linux - General 4 04-25-2005 12:09 AM
degrading libtool yonderstar Linux - Software 0 04-15-2004 02:24 PM
Cable modem speed in Suse Linux 9 Professional interstat Linux - Networking 1 03-11-2004 04:33 PM
slow cable internet speed fitboy Linux - Networking 12 05-06-2002 01:41 PM
Slow internet speed with cable M.I. Linux - Networking 18 07-10-2001 12:16 AM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration