LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-28-2002, 06:14 AM   #1
aparna_chi
LQ Newbie
 
Registered: Feb 2002
Posts: 2

Rep: Reputation: 0
Red face Linux-apache


Hi,
I am logged as root on my linux machine.
My apache server is located in /u01/app/oracle/product/8.1.7/Apache/Apache
.

I have created one directory on root and placed a html file in it.
I have put it's alias as
follow
Alias /test/ "/root/test/"

But I am not able to access it.
I get the error
ForBidden
You do not have permission to access.

Why is that?
Please can anybody tell the solution fast?
 
Old 02-28-2002, 10:27 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
is this when your trying to access it from a browser or just trying to access it ?? if from a browser.. apache probably isn't setup to use the /root directory to place html files... probably not a good idea either.
 
Old 02-28-2002, 11:06 PM   #3
aparna_chi
LQ Newbie
 
Registered: Feb 2002
Posts: 2

Original Poster
Rep: Reputation: 0
Well that's true .
I get the error while accessing it from browser.
But even if I place it somewhere else it doesn't work.
How do we create a virtual directory on linux?
 
Old 03-01-2002, 05:40 AM   #4
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
might not wanna have the owner of your files be root either... and make sure that you have read enabled globally for the files you're trying to access.

but yeah... not a good idea to keep your files in the /root dir. security risk...

usually, what i do is leave the files in the default apache htdocs dir, and then just create a sym link to it in my ~/.

and for your "alias" query, i don't think you wanna use virtual hosts, you should be able to just use a symlink and that should solve the problem:

ln -s /your/target/path /your/sym/link
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache on Linux apogee General 8 10-02-2005 08:41 PM
Apache problem on Linux guest Linux - General 5 03-18-2005 05:55 AM
New To Linux and Apache envyadi LinuxQuestions.org Member Intro 2 03-15-2005 04:32 PM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 11:53 AM
Apache on Linux 7.3 pbajpei Linux - Software 3 08-28-2002 07:25 PM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration