LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Linux and inbound UDP traffic (http://www.linuxquestions.org/questions/linux-networking-3/linux-and-inbound-udp-traffic-169559/)

Dwarflord 04-13-2004 10:25 AM

Linux and inbound UDP traffic
 
Im having a problem with linux tracking inbound UDP connections, or UDP packet tracking. In either case, I can not figure out how to turn this UDP packet handling off on my RH 9 box. I dont have a firewall working, im not running nat. I do not know if conntrack is causing the problem for me or nettable/iptable.
But I was wondering if anyone knows how to turn this (UDP packet tracking or UDP connection tracking) off in linux RH 9. Apparently it is affecting an application I am running. The inbound UDP packet from a different server increments the port by 1, yet my linux box wont allow that connection to continue when this happens.
My server is a direct connect to the internet, no boxes behind it and all the settings I have running are default. No firewall rules, no ip tables.......
Ive been trying to get help on this for a few months and have not been successful to date.

maxut 04-13-2004 10:45 AM

u can create a iptables specific rule for incoming udp packets. what type of packets are they?
maybe a service which runs on your computer does that. visit www.netfilter.org for iptables.

Dwarflord 04-13-2004 12:37 PM

Quote:

Originally posted by maxut
u can create a iptables specific rule for incoming udp packets. what type of packets are they?
maybe a service which runs on your computer does that. visit www.netfilter.org for iptables.

If I dont have a firewall running and no boxes behind my server, iptables really wouldnt apply would it? It would have nowhere to forward packets if I understand iptables correctly.
The packets are UDP coming from a game master server (this problem isnt a game issue, but rather the way linux deals w/these udp packets) where the port changes, or something like that. I did find out that the linux kernel has packet filtering and there is some way to make config changes. And this would be the thing to change to M or Y, not sure what those are yet:
CONFIG_IP_NF_QUAKE3

Unfortunately, Im not all that certain this will resolve the problem, nor how to edit that "key" in netfilter, especially since I dont have a firewall working.
I dotn know, maybe Im missing something here, or overlooking something obvious, but it is apparent it is a UDP problem and the way Linux handles those incoming packets from Game servers..... Here is a couple links showing what others have seen:

http://lists.netfilter.org/pipermail...er/009474.html
http://www.netfilter.org/patch-o-mat...-conntrack-nat

--Im hoping im on the right track....

Dwarflord 04-14-2004 04:02 PM

ttt

maxut 04-16-2004 02:35 AM

im sorry, i think i couldnt understand your trouble.

i am not sure if iptables can solve your trouble. fisrt make sure if iptables doesnt work.
#service iptables status

firewall is active in redhat 9.0 default settings.



All times are GMT -5. The time now is 11:27 PM.