LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-28-2004, 12:20 AM   #1
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Rep: Reputation: 30
Linksys Router FTp and Changing IP schemes?


This is actually a two tiered problem.
I have to FTP some rather huge files to a friend who has an FTP server set
up on his DSL connection. When I was on Comcast on a Linksys BEFSR81
(older from before the Cisco buyout) I was able to FTP in with no problem,
start the transfer and go to bed. By morning it was just about done. Now
I moved out of that place, bought another BEFSR81, but this one is newer
and is branded with Cisco/Linksys. I can log into his FTP server with no
problems, but when i start the transfer, nothing goes. I go back to my
parents on Comcast and it works fine. But here I am on Prolog/ptd.net and
I get squat. I tried passive and normal. Then on IRC somebody set up his
ftp server and it worked perfectly with passive. I believe my friend has
a Linksys router as well - from what I understand two Linky's don't play
nice together.
Somebody suggested I change my static IP scheme for the internal (LAN)
side from the factory 192.168.1.xxx to 192.168.2.xxx. I tried that, BUT
once I do that the machien I changed no longer has connectivity. I didn't
touch the DNS, WINS, or gateway settings. Once I switch it back to the
1.xxx scheme all is well.
What the heck am I doing wrong?
 
Old 11-28-2004, 02:33 AM   #2
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Re: Linksys Router FTp and Changing IP schemes?

Quote:
Originally posted by Snump
Somebody suggested I change my static IP scheme for the internal (LAN)
side from the factory 192.168.1.xxx to 192.168.2.xxx. I tried that, BUT
once I do that the machien I changed no longer has connectivity. I didn't
touch the DNS, WINS, or gateway settings. Once I switch it back to the
1.xxx scheme all is well.
What the heck am I doing wrong?

Did you also change the setting from inside the router? I'm assuming you didn't. If you did then you would also have changed the gateway setting on your computer to match.

In essence, all computers on your local network (including the router) must be on the same subnet. I'd be willing to bet that either your computer or router are using a subnet mask of 255.255.255.0 . In other words, the first three sets of numbers must match between your computer and your router. Once you change your router's IP address, then you will need to update your gateway setting to reflect this new number.

Assuming you don't already know (and it wouldn't hurt my feelings if you did), you can log into your router from any web browser. Normally you would use http://192.168.0.1 , but you already said that you're on the 192.168.1.0. Use instead whatever is your current gateway.

(If you're using DHCP, type "route -n" and look in the gateway heading for the address beside 0.0.0.0)
 
Old 11-28-2004, 02:39 AM   #3
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Re: Re: Linksys Router FTp and Changing IP schemes?

Quote:
Originally posted by gd2shoe
Did you also change the setting from inside the router? I'm assuming you didn't. If you did then you would also have changed the gateway setting on your computer to match.

In essence, all computers on your local network (including the router) must be on the same subnet. I'd be willing to bet that either your computer or router are using a subnet mask of 255.255.255.0 . In other words, the first three sets of numbers must match between your computer and your router. Once you change your router's IP address, then you will need to update your gateway setting to reflect this new number.

Assuming you don't already know (and it wouldn't hurt my feelings if you did), you can log into your router from any web browser. Normally you would use http://192.168.0.1 , but you already said that you're on the 192.168.1.0. Use instead whatever is your current gateway.

(If you're using DHCP, type "route -n" and look in the gateway heading for the address beside 0.0.0.0)
I think you're misunderstanding. I never changed my router's IP addres. I just want to change the PCs on the LAN - their IPs. So the gateway settings shoudln't change.
Yes, going to http://192.168.1.1 allows me to go to my router's config page. But, that shouldn't matter either, since I'm using static. DHCP is evil for a network this small.
 
Old 11-28-2004, 03:13 AM   #4
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
No, I understand well enough.

Your router has two IP addresses. One is external (internet), the other is internal (lan). If any of your devices uses a netmask of 255.255.255.0 then there will be a communication failure between it and another device if the third number is changed.

For example: Say your router is set to 192.168.1.1 and your computer is set to 192.168.2.2 . If either device's netmask is 255.255.255.0 then the machines will not talk to one another. You can either go about changing all netmasks (or ensuring that they are all 255.255.0.0) or you can change your router's internal address to 192.168.2.1, and change the gateway settings accordingly. (If all your net masks are 255.255.0.0 then just say so and we can go from there.)
 
Old 11-28-2004, 03:31 AM   #5
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gd2shoe
No, I understand well enough.

Your router has two IP addresses. One is external (internet), the other is internal (lan). If any of your devices uses a netmask of 255.255.255.0 then there will be a communication failure between it and another device if the third number is changed.

For example: Say your router is set to 192.168.1.1 and your computer is set to 192.168.2.2 . If either device's netmask is 255.255.255.0 then the machines will not talk to one another. You can either go about changing all netmasks (or ensuring that they are all 255.255.0.0) or you can change your router's internal address to 192.168.2.1, and change the gateway settings accordingly. (If all your net masks are 255.255.0.0 then just say so and we can go from there.)
Okey doke. Here's what I've got.
I just tried it, and it still does the exact same thing.

http://img92.exs.cx/img92/8467/routerjustin1.png
 
Old 11-28-2004, 04:09 AM   #6
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
I just tried using zmodem over ssh and It does the same thing.
 
Old 11-28-2004, 04:09 PM   #7
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Hmm. Looks like I've got everyone stumped!
My friend uses the following ip schems: 192.168.245.xxx for his internal netowrk. He also uses a linux machine, not a router.
 
Old 11-28-2004, 10:18 PM   #8
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
When you say "exact same thing", what are you referring to? Not being able to connect to the net, or not being able to connect to your friend?

I'm trying to figure out why the two Linksys boxes wont talk. If you feel confident in your firewall settings, you may try setting your router to dmz your computer (sometimes called bridge mode). This way the router wont protect you any; all internet packets will be routed back to your computer. In most setups, there shouldn't be any way for a router setup this way to interfere with a connection.

Other things to try: Can you connect to other ftp servers? Is there any way you could trade this router for the one you used to use? I just did a bit of little research, you may try port forwarding of port 20.
 
Old 11-28-2004, 10:30 PM   #9
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gd2shoe
When you say "exact same thing", what are you referring to? Not being able to connect to the net, or not being able to connect to your friend?

I'm trying to figure out why the two Linksys boxes wont talk. If you feel confident in your firewall settings, you may try setting your router to dmz your computer (sometimes called bridge mode). This way the router wont protect you any; all internet packets will be routed back to your computer. In most setups, there shouldn't be any way for a router setup this way to interfere with a connection.

Other things to try: Can you connect to other ftp servers? Is there any way you could trade this router for the one you used to use? I just did a bit of little research, you may try port forwarding of port 20.
Like, a minute before I got the email notification We fixed it. It was my MTU setting. It was at 1,500, it should be at 1,492

The answer, yes I was ablt to connect two ohter ftp sites.
I dunno why the MTU setting would make a difference though.
 
Old 11-28-2004, 10:43 PM   #10
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
I find it odd that the problem was the MTU. In an odd sort of way, it does make sense. My work uses DigitalPath.net for our ISP. If our MTU's are set wrong (1400 is correct), then there are some sites we cannot access, such as Windows Updates. If the server thinks that it can send big packets, sometimes it will. These are then rejected by the hardware if there is a physical limitation. Changing the MTU (to my understanding) communicates to the server to send packets no larger than your connection can handle. This is the first time I've actually heard of an incorrect MTU setting in a normal environment.

Thank you for posting the solution. I'll need to remember this one.
 
Old 11-28-2004, 10:45 PM   #11
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Sorry, just to clarify. Our MTU settings must be 1400. 1492 is about normal.
 
Old 11-28-2004, 11:03 PM   #12
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Yeah, IMO it wasa bit unusual. in the older version of the BEFSR81 there is no MTU settings that I can remember. Either that or its set to a default of 1400.
What I don't understand is, why it would only affect uploading to my friend's site and nbody' elses.

I'm going to finish this Michelob and get to bed. heh.
 
Old 11-28-2004, 11:12 PM   #13
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Yeah, it affect some sites but not others. I don't know why it would affect communication with your friend specifically. Maybe his MTU is higher (and can be higher) and his computer wants to use the larger package size.

Oh, an I was trying to be clear. 1400 is NOT a normal size. It just happens to be what our ISP requires. I tend to see sizes at or just below 1500 in normal places.
 
Old 11-29-2004, 12:20 AM   #14
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gd2shoe
Yeah, it affect some sites but not others. I don't know why it would affect communication with your friend specifically. Maybe his MTU is higher (and can be higher) and his computer wants to use the larger package size.

Oh, an I was trying to be clear. 1400 is NOT a normal size. It just happens to be what our ISP requires. I tend to see sizes at or just below 1500 in normal places.
For example, 1,492? This is the same ISP that provides the T1 line at the office. I'm going to see if I can get on the router and see what the MTU is set for.
1,500 didn't work... 1,492, and 1,446 did.
What are these numbers based off of? Its not a power of two...
 
Old 11-30-2004, 01:31 AM   #15
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
No, not powers of two. Just plain old numbers. It just depends on the physical connection. Some connections (and hardware) find particular packet sizes to be inconvenient, so they have a built in maximum just below that. I don't know all the MTU ramifications. I'm just speculating that your hardware may handle more, but your ISP's hardware doesn't like 1500 bit packages.

I can't think of where, specifically, but I have seen 1492 used before as an MTU.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing Subnet on Linksys Router RemusX2 Linux - Networking 1 09-08-2005 10:19 PM
Need Help W/ Linksys Router Please. cmd Linux - Hardware 1 02-22-2004 10:38 AM
router problem with linksys router scheiße_comp Linux - Networking 10 08-20-2002 11:18 AM
Linksys Router hubergeek Linux - Networking 4 08-14-2002 05:48 PM
telnet, ftp malfunctioning after linksys router was installed doris Linux - Networking 1 08-04-2001 02:14 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration