Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 08-12-2005, 08:59 PM   #1
Registered: Jun 2004
Distribution: debian 3.1 etch
Posts: 76

Rep: Reputation: 15
Link encap:UNSPEC after k3b, cups , gftp install

hey guys,

Wasnt to sure where to put this, but i hope someone can help
I installed a few more programs to try on my debian etch 3.2(?) box, k3b, gftp, and i believe cups.. Everything was going great, i burnt one cd, played some tunes, browsed LQ for awhile, checked email etc.. Then i got sleepy and decided to shut down for the night. So i shut down my clarkconnect router, debian box and xp box... all is nice and quiet ZZZZZZ
I wake up, turn on the router xp and debian box and "starting MTA hangs....
uhoh.. finishes booting, i log in... startX no inet, gain cant connect hmmmm I check the router, dnsmasq is running and i can ping ip and dns.. XP box (wifes) is ok, no issues, can surf, ping etc... cant ping the debian box though (

So i go hunting some more. ifconfig eth0 gives

static ip of

ping loopback is ok
cant ping names or ip i get "destination host unreachable" eith on internal ips (gateway or XP box (

cat/etc/network/interfaces looks ok

iface etho inet static

my resolv.conf file seems ok

## i added my isp as well... i thought maybe something had changed as a requirement

nameserver 64.x.x.x
nameserver 64.56.x.x

cant ping either again, but can ping and surf via lynx (sp?) on my gateway

I have checked my switch, changed ports just in case, no change.

The only thing i can see different after i restarted is
Link encap:UNSPEC

instead of Link encap:ethernet

I thought that was alittle odd

there are no collision or dropped packets in ifconfig eth0 either

any suggestions on how to get this working again ?


Just Checked the ethernet cable, its working. Using knoppix now so i can at least chedk files on debian box... and i can surf in knoppicx now... debian still broke though
ifconfig shows below, note now in knoppix Link encap:Ethernet now not Link encap:UNSPEC

Link encap:Ethernet  HWaddr 00:11:2F:A8:FA:32
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::211:2fff:fea8:fa32/64 Scope:Link
          RX packets:3162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3374 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2244092 (2.1 MiB)  TX bytes:702308 (685.8 KiB)
          Interrupt:22 Memory:feaf8000-0

Last edited by byte.chaser; 08-12-2005 at 10:13 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
network weirdness, link encap:USPEC byte.chaser Debian 8 08-18-2005 11:17 PM
OpenBSD 3.6 install D-Link 300T / D-Link DFE 528TX lesleyb *BSD 2 04-01-2005 06:29 PM
k3b install snafu Linux - Software 3 05-29-2004 05:58 AM
cups-libs need to install cups illtbagu Linux - Newbie 3 01-23-2003 07:02 PM
MAC Address Encap Vs DHCP zooma Linux - Networking 0 11-21-2001 09:14 AM

All times are GMT -5. The time now is 07:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration