LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-28-2010, 12:40 AM   #1
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Unhappy laptop wireless won't connect in KDE but works in Gnome (Fedora 13)


After searching/googling for information related to the topic, I haven't been able to get this working in KDE.

Background: I have a Dell Studio 1745 with builtin Intel 5100bg wireless card. It connects to my Linksys WRT54G router just fine in openSUSE 11.2 & 11.3 using either KDE or Gnome. In Fedora 13 it only connects under Gnome, not KDE. Those are using NetworkManager. Using traditional ifup only works in Fedora under Gnome, i.e. nothing works under KDE in Fedora.

Specs: lspci
Code:
08:00.0 Network controller: Intel Corporation WiFi Link 5100
14:00.0 FireWire (IEEE 1394): O2 Micro, Inc. Device 10f7 (rev 01)
14:00.1 SD Host controller: O2 Micro, Inc. Device 8120 (rev 01)
14:00.2 Mass storage controller: O2 Micro, Inc. Device 8130 (rev 01)
20:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
lsmod
Code:
nf_nat                 19059  2 ipt_MASQUERADE,iptable_nat
stp                     1887  1 bridge
llc                     4557  2 bridge,stp
ip6t_REJECT             4055  6 
nf_conntrack_ipv6      17513  14 
ip6table_filter         2743  1 
ip6_tables             16558  1 ip6table_filter
ipv6                  267065  32 ip6t_REJECT,nf_conntrack_ipv6
iwlcore               220675  1 iwlagn
mii                     4142  1 r8169
mac80211              196945  2 iwlagn,iwlcore
cfg80211              117099  3 iwlagn,iwlcore,mac80211
dmesg | grep iwlagn
Code:
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 2.6.33.3-85.fc13.x86_64-kds
iwlagn: Copyright(c) 2003-2009 Intel Corporation
iwlagn 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:08:00.0: setting latency timer to 64
iwlagn 0000:08:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
iwlagn 0000:08:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
  alloc irq_desc for 33 on node -1
  alloc kstat_irqs on node -1
iwlagn 0000:08:00.0: irq 33 for MSI/MSI-X
iwlagn 0000:08:00.0: firmware: requesting iwlwifi-5000-2.ucode
iwlagn 0000:08:00.0: loaded firmware version 8.24.2.12
CONTENTS OF /etc/sysconfig/network-scripts/ifcfg-wlan0:
Code:
# Intel Corporation WiFi Link 5100
DEVICE=wlan0
HWADDR=##:##:##:##:##:##
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Wireless
NM_CONTROLLED=no
USERCTL=no
PEERDNS=yes
IPV6INIT=no
ESSID=XXXXXXXXXXX
MODE=Managed
RATE=auto
CHANNEL=
Error message from ifup wlan0:
Code:
Error org.freedesktop.NetworkManagerSettings.InternalError: unable to get the connection D-Bus path
Error org.freedesktop.NetworkManagerSettings.InternalError: unable to get the connection D-Bus path
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Invalid argument.
Determining IP information for wlan0... failed; no link present.  Check cable?
Steps taken so far:

1) completely deleted NetworkManager (and depends) with yum remove.

2) Removed all wireless related files in /etc/sysconfig/.

3) Re-installed wireless network in System > Admin > Network

No matter what I have done, the wireless refuses to work in KDE on Fedora. I've temporarily resorted to having my wife string a 50ft patch cord from the router in the basement to my laptop (I'm disabled, can't climb stairs).

Does anyone have a suggestion of what else I might try?

Thanks, Tom
 
Old 06-28-2010, 08:20 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,722

Rep: Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458
Since the wired network works, it may be that the network manager is the problem. When you reinstalled the network manager, did you reinstall the Gnome network manager?

If so, I can say I have found it to be unreliable except under the Gnome interface. For what it's worth, here's my experience.

I have a netbook running Ubuntu 8.04 (factory installed Ubuntu that does not automatically update versions--maybe it's a netbook thing; it works and I'm not going to mess with it). The Gnome network manager will connect to my wireless when I start the computer (from a restart or powered off condition) in Gnome, but not when I start it in Fluxbox. If I start it in Fluxbox, the Gnome network manager icon just rotates making pretty circles.

If I start it, go into Gnome, make the network connection, leave Gnome, then start Fluxbox, the connection works fine until I actually reboot or power off (I did an "uptime" before I powered it off the last time--it had been up for over 9 days, during which time I had commmonly logged out over-night.

In contrast, I have a laptop running Ubuntu current (it started with factory installed 8.04 but has lived through all the version updates). Early on, I replaced Gnome network manager with wicd. That box connects flawlessly to any wireless network, regardless of the window manager I use after powering up or rebooting.

In my experience, Gnome network manager does not play well with anything but Gnome on boot. YMMV.
 
Old 06-29-2010, 01:59 AM   #3
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Original Poster
Rep: Reputation: 34
Thanks for the reply, Frankbell;
Quote:
Originally Posted by frankbell View Post
Since the wired network works, it may be that the network manager is the problem. When you reinstalled the network manager, did you reinstall the Gnome network manager?
As stated in my original post, I did NOT reinstall NetworkManager.
Quote:
If so, I can say I have found it to be unreliable except under the Gnome interface. For what it's worth, here's my experience.

I have a netbook running Ubuntu 8.04 (factory installed Ubuntu that does not automatically update versions--maybe it's a netbook thing; it works and I'm not going to mess with it). The Gnome network manager will connect to my wireless when I start the computer (from a restart or powered off condition) in Gnome, but not when I start it in Fluxbox. If I start it in Fluxbox, the Gnome network manager icon just rotates making pretty circles.

If I start it, go into Gnome, make the network connection, leave Gnome, then start Fluxbox, the connection works fine until I actually reboot or power off (I did an "uptime" before I powered it off the last time--it had been up for over 9 days, during which time I had commmonly logged out over-night.

In contrast, I have a laptop running Ubuntu current (it started with factory installed 8.04 but has lived through all the version updates). Early on, I replaced Gnome network manager with wicd. That box connects flawlessly to any wireless network, regardless of the window manager I use after powering up or rebooting.

In my experience, Gnome network manager does not play well with anything but Gnome on boot. YMMV.
I'll have to give that a try if wicd (which I'll download tonight) doesn't work. Right now I've been able to get wired eth0 working by ifup method which it wasn't doing in KDE previously under F13. Oh, and I also re-installed F13 from DVD without NetworkManager.

Thanks, Tom
 
Old 06-29-2010, 07:57 PM   #4
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,722

Rep: Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458
I kicked myself this afternoon for not suggesting another possible test would be to try connecting by editing the wireless configuration file. It's not an ideal way for day-to-day use--something like wicd or some other network manager frontend is a lot easier to work with, but it might be a good test.

In Slackware, it's /etc/rc.d/rc.wireless. But, frankly, I don't know whether Fedora has an rc.wireless or equivalent--a search was not very comforting; my Ubuntu machine appears not to have one.

Here's a link I found. I'm not promising it will help, but it might be a http://beginlinux.com/appsm/wireless...wireless-setupstarting point.

Good luck.
 
Old 06-29-2010, 08:25 PM   #5
volga629
Member
 
Registered: Dec 2009
Posts: 67

Rep: Reputation: 21
Hi,
I would suggest to disable wpa supplicant and you use only Network Manager here the link setup wifi for CentOS , it is same family.

http://wiki.centos.org/HowTos/Laptop...899390b41a5c4c

Enjoy.

Last edited by volga629; 06-29-2010 at 08:26 PM.
 
Old 11-27-2010, 08:34 PM   #6
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
I had the same problem. I installed wlassistant while in Gnome (which does get Internet when KDE doesn't) After that, I restarted in KDE and ran wlassistant. My hidden WPA-Personal network showed up and I got on. Weirdly enough, it let me configure the wireless but not use it.

The solution has been posted elsewhere in LQ, but is worth repeating.
 
Old 11-28-2010, 08:31 AM   #7
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Originally Posted by mdlinuxwolf View Post
The solution has been posted elsewhere in LQ, but is worth repeating.
Would you mind posting a link?

Thanks, OP, for starting an interesting discussion -- I'm hoping for insight in getting wifi working on my MEPIS 8.0 (KDE 3.5.12) secondary install on my Eee PC 8G.
 
Old 11-28-2010, 08:46 AM   #8
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
Quote:
Originally Posted by archtoad6 View Post
Would you mind posting a link?

Thanks, OP, for starting an interesting discussion -- I'm hoping for insight in getting wifi working on my MEPIS 8.0 (KDE 3.5.12) secondary install on my Eee PC 8G.
Actually, the solution is pretty simple. Using Gnome Xfce or whatever other desktop does get wireless, install wlassistant. I used yum, but there is no reason why yumex or kpackagekit wouldn't also work. If there is no wireless to be had, then use a wired connection, somewhere you can get Ethernet or a wireless Ethernet bridge (WET-54g)

Configure your connection like normal using KDE's tools. The tools will allow you to set up the connection, just not activate it. Wlassistant did allow me to get online in KDE. Of course, the other solution is to just give up and use Xfce or Gnome instead.

------------

Mepis...

After you install Mepis, try to restart the machine and run synaptic for updates. You may have to use wired Ethernet for the first update, another words plugging your netbook directly into your modem or router. Run updates for everything. Then use Synaptic to search for a wireless driver for your NIC, if it hasn't already done so itself. Of course, using a Wireless Ethernet bridge on an open network will also work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless not working in KDE, but works in Gnome Ledfeather Ubuntu 8 07-13-2009 02:13 PM
Fedora 9 gnome xrandr causes X11 restart, works fine in KDE thorsten becker Fedora 0 07-01-2008 01:53 AM
Suspend on lid close works in kde but not gnome. fedora core 6 on dell inspiron 5100 mikegorb Linux - Laptop and Netbook 1 01-21-2007 11:35 PM
Asus laptop turning on wireless? (actual wireless works when on) Mikesoft Fedora 7 01-14-2007 10:30 AM
connect to windows share through smb://works great in gnome explorer,lousy in KDE? zeltak Linux - Software 0 01-09-2007 01:46 PM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration