LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-16-2003, 04:10 PM   #1
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
LAN works, WAN doesn't ?


Sorry if this question is a bit longer than it needs to be but....

I can ping local boxes, but I can't ping anything outside my LAN (on this one machine running RH 7.3). The machine was working before I switched ISPs and moved my office around. That said, nothing has changed on the machine - all the settings are the same. (The only changes I needed to make when switching ISPs were on the router).

I really don't know where to begin to look for a problem... I checked the gateway and name server settings in /etc/sysconfig/network and /etc/resolve.conf respectively. I can ssh into and out of it on my LAN, but cannot ssh into or out of it on the WAN. If I ping from the box, it resolves the name, but doesn't connect.... I suppose the ip & name could be cached somewhere in the machine (I'm not sure how that works) - but if I "ping yahoo.com" it gives back the correct IP address for yahoo.com, but gives "Destination Host Unreachable"

It should be noted that the machine in question has two NICs - one built into the motherboard (that stopped working a few weeks ago... well, it would work intermittently) and a replacement PCI card that *has* worked properly in the machine we're dealing with here. Both cards are set to the same IP. I have not officially disabled the "broken" card... maybe that's the problem? If so, how would I go about disabling the motherboard NIC?
 
Old 06-16-2003, 05:33 PM   #2
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
To disable the NIC, try going into your bios, there should be a place like "integrated peripherals" or some such. Find your NIC on the list and disable it.
 
Old 06-16-2003, 07:11 PM   #3
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
Quote:
Originally posted by uglydot
To disable the NIC, try going into your bios, there should be a place like "integrated peripherals" or some such. Find your NIC on the list and disable it.
well, I rebooted to do that & the machine wouldn't even post. Removed the NIC and it did (post), so I replaced it with a new one, disabled the onboard LAN, and everything seems to be up and running again.

Thanks for the hint.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
10.2 upgrade; lan works, wan doesn't Nd4Spd Slackware - Installation 18 11-20-2005 09:00 AM
2 routers WAN, LAN could you please tell me... microsmart Linux - Networking 5 08-06-2005 01:17 PM
SuSE 9.2 Pro, Centrino Card, Wireless works in LAN, not on WAN davidm_86 Linux - Wireless Networking 3 01-25-2005 04:09 AM
SSL works on LAN, not WAN? belorion Linux - Software 2 08-08-2004 04:33 PM
Routing LAN -> WAN -> LAN with unhelpful router synx13 Linux - Networking 2 06-14-2004 02:35 PM


All times are GMT -5. The time now is 08:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration