LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-09-2007, 05:04 AM   #1
kfir_w
LQ Newbie
 
Registered: Jun 2007
Location: Kunming, China
Distribution: Fedora 9
Posts: 5

Rep: Reputation: 0
L2TP works bad, PPTP doesn't work at all


Hi,
I'm using ubuntu 7.04 with a Thomson cable modem (eth0).
When I connect to my ISP with l2tp it works, yet disconnects
after several minutes (and it mesess up the resolve.conf file and I need to fix it after every connection).
So I tried configuring a connection using pon (pptp) and it passes veryfication yet no connection is made:
kfir@zalame:~$ sudo pon provider debug dump logfd 2 nodetach
pppd options in effect:
debug # (from command line)
nodetach # (from command line)
persist # (from /etc/ppp/peers/provider)
logfd 2 # (from command line)
linkname smileISP # (from /etc/ppp/peers/provider)
dump # (from command line)
noauth # (from /etc/ppp/peers/provider)
user kfir_w # (from /etc/ppp/peers/provider)
# (from /etc/ppp/options)
pty /usr/sbin/pptp pns.inter.net.il --nolaunchpppd # (from /etc/ppp/peers/provider)
noaccomp # (from /etc/ppp/options)
lcp-echo-failure 2 # (from /etc/ppp/options)
lcp-echo-interval 20 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/peers/provider)
noipdefault # (from /etc/ppp/options)
replacedefaultroute # (from /etc/ppp/options)
usepeerdns # (from /etc/ppp/peers/provider)
nobsdcomp # (from /etc/ppp/peers/provider)
nodeflate # (from /etc/ppp/peers/provider)
using channel 208
Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x761fea73> <pcomp>]
rcvd [LCP ConfReq id=0x1 <auth pap> <magic 0xf08245eb>]
sent [LCP ConfAck id=0x1 <auth pap> <magic 0xf08245eb>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x761fea73> <pcomp>]
sent [LCP EchoReq id=0x0 magic=0x761fea73]
sent [PAP AuthReq id=0x1 user="kfir_w" password=<hidden>]
rcvd [LCP EchoRep id=0x0 magic=0xf08245eb]
rcvd [PAP AuthAck id=0x1 ""]
PAP authentication succeeded
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [IPCP ConfReq id=0x1 <addr 213.8.255.156>]
sent [IPCP ConfAck id=0x1 <addr 213.8.255.156>]
rcvd [LCP EchoReq id=0x1 magic=0xf08245eb 76 1f ea 73]
sent [LCP EchoRep id=0x1 magic=0x761fea73 76 1f ea 73]
rcvd [IPCP ConfReq id=0x2 <addr 213.8.255.156>]
sent [IPCP ConfAck id=0x2 <addr 213.8.255.156>]
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [IPCP ConfNak id=0x2 <addr 80.230.4.129> <ms-dns1 192.116.202.222> <ms-dns3 213.8.172.83>]
sent [IPCP ConfReq id=0x3 <addr 80.230.4.129> <ms-dns1 192.116.202.222> <ms-dns3 213.8.172.83>]
rcvd [IPCP ConfAck id=0x3 <addr 80.230.4.129> <ms-dns1 192.116.202.222> <ms-dns3 213.8.172.83>]
local IP address 80.230.4.129
remote IP address 213.8.255.156
primary DNS address 192.116.202.222
secondary DNS address 213.8.172.83
Script /etc/ppp/ip-up started (pid 23050)
Script /etc/ppp/ip-up finished (pid 23050), status = 0x0
No response to 2 echo-requests
Serial link appears to be disconnected.
Connect time 1.0 minutes.
Sent 1169497632 bytes, received 0 bytes.
Script /etc/ppp/ip-down started (pid 23107)
sent [LCP TermReq id=0x2 "Peer not responding"]
Script /usr/sbin/pptp pns.inter.net.il --nolaunchpppd finished (pid 23044), status = 0x0
Modem hangup
Connection terminated.
using channel 209
Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
Script /etc/ppp/ip-down finished (pid 23107), status = 0x0
anon fatal[get_ip_addressptp.c:377]: gethostbyname 'pns.inter.net.il': HOST NOT FOUND
Modem hangup
Connection terminated.
anon fatal[get_ip_addressptp.c:377]: gethostbyname 'pns.inter.net.il': HOST NOT FOUND
Couldn't get channel number: Input/output error


Any ideas ??

Thanks,
Kfir
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to make my code to work on bsd (pptp script on bash) jabka *BSD 1 05-01-2007 12:53 PM
Can't get rdesktop to work over my pptp tunnel Mr. Swillis Linux - Networking 1 12-30-2006 11:29 PM
Cannot get PPTP to work on Trendnet Router davcefai Linux - Hardware 0 02-25-2006 01:55 PM
Opening a L2TP/PPTP tunnel from debian to win 2003 hq4ever Linux - Networking 2 01-23-2006 05:13 PM
Echo /devPrinting doesn't work, echo /usb/lp0 works, Testpage works, Printing doesn't Hegemon Linux - General 3 08-15-2002 01:13 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration