LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-01-2005, 07:52 AM   #1
SuSE 1983.
LQ Newbie
 
Registered: May 2005
Distribution: DEB+IAN 3.1r1
Posts: 29

Rep: Reputation: 15
Kppp can配 connect to any of my ISP酒, exit status 1


Deban Sarge, kernel 2.6.8, kde 3.3.

ATZ
OK
ATM1L1
OK
ATX3
OK
ATDT076610000
CONNECT 50667

Then Kppp shows that it is dialing number. After some time it tries to connect to my ISP, an then
after some 3 or 4 minutes, Kppp (or pppd) shows me this:

The pppd daemon died unexpectedly!
Exit status: 1
See 'man pppd' for an explanation of the error codes or take a look at the kppp FAQ on http://devel-home.kde.org/~kppp/index.html


After clicking on Details...

Jul 1 11:54:44 debian pppd[6347]: The remote system is required to authenticate itself
Jul 1 11:54:44 debian pppd[6347]: but I couldn't find any suitable secret (password) for it to use to do so.
Jul 1 11:54:44 debian pppd[6347]: (None of the available passwords would let it use an IP address.)

And this is situation for all my 5 ISPs.

In MAN PAGES of "pppd", exit status means:
1 An immediately fatal error of some kind occurred, such as an
essential system call failing, or running out of virtual memory.

...But isn配 that - man pages explanation - different from "Details"?!

HELP!

Last edited by SuSE 1983.; 07-01-2005 at 07:57 AM.
 
Old 07-01-2005, 05:06 PM   #2
ginetta
LQ Newbie
 
Registered: Nov 2004
Location: Canada
Posts: 28

Rep: Reputation: 15
(Taken from the page you included in your post) - Have you tried this yet?

pppd died - The remote system is required to authenticate itself ...
As far as I can tell there are two causes for this problem:

* /etc/ppp/options contains the auth option. Simply put a # comment character in front and try again.
* Your system already has a default route. Have you set up a local network ? In thise case recent versions of pppd will behave as if the auth had been specified. To override this you may add noauth to the pppd arguments in kppp' setup dialog. Alternatively you could take down the local network prior to dialing in. I'd be thankful if someone could provide instructions on how to peacefully combine the two network connections.
 
Old 07-02-2005, 09:00 AM   #3
SuSE 1983.
LQ Newbie
 
Registered: May 2005
Distribution: DEB+IAN 3.1r1
Posts: 29

Original Poster
Rep: Reputation: 15
I have edit file /etc/ppp/peers/kppp-options. There was #noauth. I remove "#" and left "noauth".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wvdial or kppp - can't make either one connect to a local isp lefty.crupps Linux - Software 2 07-06-2005 11:51 PM
exit status naflan Programming 2 10-22-2004 12:22 PM
exit status 17 kppp joshy Mandriva 3 10-08-2004 07:07 AM
kppp mdk10 ppp exit status 10 "CONNECT 44000/LAPM/" geek745 Linux - Networking 2 09-09-2004 11:04 PM
kppp daemon died unexpectedly exit status 4 steelrose Linux - Networking 1 04-03-2002 04:00 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration