LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-02-2008, 08:55 PM   #1
TechnoJunky
LQ Newbie
 
Registered: Aug 2007
Location: Chicago
Distribution: Mint 14
Posts: 16

Rep: Reputation: 0
KNetworkManager always prompts for password twice


Everytime I log into into my KDE, while using my wireless card, KDE never automatically connects to the network. I always have to right click on KNetworkManager, and select my network. Then it prompts me for my router password, times out, then prompts me for it again, afterwhich it connects and life is good till I reboot. I don't use Kwallet, although I suppose I could if you told me that all my problems would be solved by doing so.

Is there anyway to setup my wireless to connect automatically (maybe before login to X) and/or is there any way to stop the need for typing the password twice (it's rather long)?
 
Old 02-03-2008, 02:11 PM   #2
davesny
Member
 
Registered: Aug 2006
Posts: 36

Rep: Reputation: 15
It would be helpful to know your distro and perhaps more data such as the version of the KDE desktop environment.
I use openSuSE 10.X and there are two options to run the wireless card. The one which you are using is through NetworkManager - helpful if you are accessing the Internet through different wireless networks and/or want to see the network, and the other is through ifup, useful if you are accessing mainly through one wireless network. (My wife prefers using ifup except when we travel.)
If you use KwalletManager it will probably ask you for your password when your operating system loads. However, you shouldn't have to reenter your password for the Wireless Network each time.

I hope this gives you some help.
 
Old 02-03-2008, 04:40 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,149

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Sometimes wpasupplicant can timeout before you router responds (if you need wpasupplcant to access you network). You could try changing the setting in /etc/wpasupplicant/wpasupplicant.conf to see if it makes any difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
passwd prompts for new password only once when a short password is entered powah Linux - Security 0 09-19-2007 04:20 PM
passwd prompts for new password only once when <enter> is pressed powah Linux - General 1 09-13-2007 06:18 AM
Simple Shell Question Regarding Password Prompts pr0gr4mm3r Linux - Software 4 03-05-2007 02:48 PM
SVN and Apache, multiple password prompts watsoncj Linux - Software 0 10-10-2005 01:36 PM
mount - a passwdless 98 share prompts for password bkeating Linux - Software 1 11-22-2002 01:06 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration