LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-12-2006, 12:58 AM   #1
rcbell
LQ Newbie
 
Registered: Jul 2005
Posts: 6

Rep: Reputation: 1
keeping Xvnc alive after vncviewer dies


I have xinetd set up to start my Xvnc server. Occaisionally, my VPN hangs or disconnects and so I lose my vncviewer/client session. I would expect to be able to reconnect to the Xvnc server by restarting vncviewer, but xinetd seems to be terminating the server when my vncviewer session ends. I would like the Xvnc server to stay alive so I can reconnect to it with vncviewer.

As a workaround, I've stopped xinetd and started a Xvnc session from the command line, and this works exactly as I want. But I have to stop xinetd to accomplish this, or else my vncviewer sessions only connect to the Xvnc server which is started by xinetd.

I've tried many different Xvnc opions to accomplish this (-noreset, removed
the -once, etc) but none seem to matter. I've also changed the xinetd WAIT
from no to yes, but that doesn't work either. (In fact, it has a wierd
side effect of spinning on starting a Xvnc server, which immediately dies,
and so it starts another one.)

And as long as we're on this subject, what is the ":42" in the server options in /etc/xinetd.d/vnc? The normal way to start Xvnc is the :1, :2 etc which correspond to the display for the vncviewer session.

I guess I just need to learn where can I learn more about how xinetd controls Xvnc.

Thanks!
Craig
 
Old 10-12-2006, 07:45 PM   #2
Sertys
Member
 
Registered: Oct 2006
Posts: 42

Rep: Reputation: 15
It's not an (x)inetd issue. It's about X11vnc's default behaviour. Just put a -forever option and you've got it.
Like so :

/usr/bin/x11vnc -rfbauth ~/.vnc/passwd -display :0 -forever &
 
Old 10-12-2006, 08:40 PM   #3
rcbell
LQ Newbie
 
Registered: Jul 2005
Posts: 6

Original Poster
Rep: Reputation: 1
I'm not running X11vnc, which is another version of the server. It's just Xvnc, and -forever is not a valid option (I tried it).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[root@localhost Desktop]# vncviewer 192.168.0.11:2 vncviewer not viewing kde display nickleus Linux - Software 13 10-27-2006 03:58 AM
LXer: FOSS for OS/2: Keeping the flame alive LXer Syndicated Linux News 0 02-17-2006 08:31 AM
x server dies...dies...dead! aquaboot Linux - Software 2 08-28-2005 11:54 AM
Keeping the connection alive? NonSumPisces Linux - Networking 2 07-08-2004 05:12 PM
Keeping dialup alive kobe Linux - General 3 08-18-2002 01:46 AM


All times are GMT -5. The time now is 06:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration