LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Isp blocking port 25 (http://www.linuxquestions.org/questions/linux-networking-3/isp-blocking-port-25-a-88655/)

terek 09-02-2003 10:37 PM

Isp blocking outgoing port 25
 
This has been a most frusterating ordeal with this new isp my family chose to go with (unfortunately I have no say in going back to our old isp.)

The first week I called them saying they had port 25 blocked. Their response "we block port 25 for the first 30 days because this is a 30 day free trial and we don't want people spamming for 30 days, canceling their service and end up on not paying anything." Well being that I hate spam with a passion I felt that was a wise decision on their company.

about 35 days later I still had port 25 blocked. I called them up. Their response "we always block port 25 to all of the people we provide isp service to"

Ok gripe time over. Here's my question:
Is there any way to get around this and still be able to send out mail? (Incomming port 25 is not blocked.)

possibility 1
I read a little about smtps but I am not sure every email server out there is listening for any smtps communication (mine isn't at the time.)

Possibility 2
Could I configure my sendmail to send on a different port to another computer out there that will remap my port XXXX to port 25 and form a communication between us two?

Possibility 3
Could I get someone else to recieve mail on a different port, have them make my domain a person trusted to relay mail for, and relay the mail through them?

My brother is willing to let me configure his server to do either option 2 or 3, but can sendmail listen for mail on more than one port? I know I can configure it to make mydomain.com a trusted computer to relay for.

Thanks for any advice on how to handle this situation

ckmehta 09-03-2003 01:11 AM

Check out this thread, I just solved your same problem:
http://www.linuxquestions.org/questi...threadid=87120

terek 09-05-2003 12:43 AM

ISP blocking outgoing port 25
 
Ok I have gotten it working with sendmail.

First of all ckmehta your problem isn't the same as mine. You appear to have incomming port 25 blocked. That is not the case for me. I can receive mail. Just can't send it.

For me outgoing only on port 25 is blocked.

I decided to go with Option number 3 and here are the things I did in case someone else wants to try this.

First of all I had to find someone willing to do this (my brother agreed to let me configure his computer to relay mail for me.)

Step 1. Configure friends computer to listen on two ports

This thread helped me out with figureing out how to listen on two ports

in my friends sendmail.cf file I made sure there were two DaemonPortOptions set up to get sendmail listen on two ports (NOTE earlier versions of sendmail do not support having you set up two different Daemons in one sendmail.cf file.)

#this DaemonPortOption listens for any incomming port 25 communication
O DaemonPortOptions=Port=smtp, Name=nameofyourchoice1

#this DaemonPortOption listens for any incommong port XXXX (you fill in the xxxx's)
O DaemonPortOptions=Port=XXXX, Name=nameofyourchoice2


Nameofyourchoice1 is defaulted to MTA (for mail transfer agent) It can affect how mail gets sent out if you configure different options with it but with those two lines I set up it wouldn't matter what either are called.

Next in my friends access file I had to add an option get his sendmail to allow relaying from me
mydomain.com RELAY

then you convert the access file into the access.db and restart sendmail (/etc/init.d/sendmail restart)

Now my friend's computer will relay from my own.

This is what I had to do on my computer.

First I had to set my computer's smart host to be his computer.

To find this look for a comment that says something like ""Smart" relay host (may be null)"
There is a "DS" that has nothing after it. (D means macro definition S is for the Smart Host macro definition)
I changed the DS line to this
DSmyfriendsdomain.com

Last thing I had to do is to configure my sendmail to send mail on the same port that I had my friend listen on (port XXXX)

I am not quite sure if I changed more than I had to but this is what I did and it worked for me.

everywhere I found a A=TCP $h I changed it to: A=TCP$h XXXX

Well hope this helps.

GraemeK 09-05-2003 05:04 AM

interesting...

my isp blocked port 25 outbound too until they confirmed i wasnt an open relay. once they did a check they openned it up and thats it!

glad you found a work around.

G

terek 09-05-2003 07:38 PM

Oops I made a mistake. When I said aliases file I meant access file in the /etc/mail directory. I am fixing the message so it is right.


All times are GMT -5. The time now is 03:26 AM.