LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-03-2013, 09:23 AM   #1
norahs63
LQ Newbie
 
Registered: Sep 2011
Posts: 1

Rep: Reputation: Disabled
Question IPV6 Network does not ping


I work as a hardware tester. I set up an interrupt test for the first time using IPV6. This is the first time we've used IPV6 in our lab so I am the guinea pig. The network is localized and has no internet access. It's two racks with three chassis. I'm trying to network two servers - each in a different chassis connected with four switches in each chassis and one switch connecting the two chassis. If I set the test up with IPV4 it pings. IPV6 - I get a message saying it can't find the host. I'm using SLES 11 SP 2.

Here's how I set it up:

Server 1 - eth0: #ifconfig eth0 inet6 add fe80::a0d:5f0a/112
Server 2 - eth0: #ifconfig eth0 inet6 add fe80::a0d:190a/112

The IPV4 addresses I converted are 10.13.95.10/16 and 10.13.25.10/16.

Ping (neither method works):

ping6 fe80::a0d:190%eth0
or
ping6 -i 5 eth0 fe80::a0d:190

Does anyone see a problem or have any advice? Appreciate your time!
 
Old 02-03-2013, 09:33 AM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,919

Rep: Reputation: Disabled
You're pinging a different address (fe80::a0d:190) than the one you assigned (fe80::a0d:190a).

Also, you're using a non-standard prefix length for a link local address, but that shouldn't really cause any problems.

Have you tried pinging the automatically assigned link local addresses?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stumped on IPv6 ping in c language with PF_PACKET/SOCK_DGRAM pdbuchan Programming 7 11-19-2011 10:31 AM
can ping network computer, cannot ping google.com (help needed) ben_build#2.1.0 Linux - Wireless Networking 23 11-07-2010 12:55 PM
can you use PING for an IPv6 address? jrevier Linux - Newbie 3 12-07-2009 11:40 PM
ipv6/ ip6tables can't ping from behind router donnied Linux - Networking 0 08-25-2008 07:25 PM
perl: Net::Ping and ipv6 Kostko Programming 1 05-11-2003 12:14 AM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration