LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-29-2012, 05:59 AM   #1
AlexFr
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 0
IPv6 address is not working


Telnet connection with echo service succeeds for localhost and 127.0.0.1 host names, but fails with ::1 host name:
Code:
alex@u120432:~$ telnet localhost 7
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
123
123
^]

telnet> q
Connection closed.
alex@u120432:~$ telnet ::1 7
Trying ::1...
telnet: Unable to connect to remote host: Connection refused
alex@u120432:~$
My own program also fails, trying to talk using IPv6 address. Why IPv6 address is rejected?
OS: Ubuntu 12.04 32 bit.
For any TCP/UDP server-client programs (not only telnet + echo) I tried different host names. Assuming that computer IP address is 10.90.185.73 (fe80::21b:21ff:fe5e:28af), I tested the following options:
Code:
localhost - works
127.0.0.1 - works
::1 - Connection refused
10.90.185.73 - works
computer-name - works
::ffff:10.90.185.73 - works
fe80::21b:21ff:fe5e:28af - Connection refused

Last edited by AlexFr; 11-29-2012 at 07:58 AM.
 
Old 11-29-2012, 11:07 AM   #2
mmheera
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Ubuntu, Debian, Fedora,Windows 7
Posts: 107

Rep: Reputation: 11
I guess your telnet server is configured by default only for ipv4 addresses. You can quickly check it by doing a "netstat -na" and see if tcp port 23 (telent) is open only for ipv4 addresses. You need to configure the /etc/inetd.conf or /etc/xinetd.conf file and add an entry for tcp6/ipv6 support. Then restart /etc/init.d/openbst-inetd or /etc/init.d/xinetd and it should work.
 
1 members found this post helpful.
Old 12-02-2012, 05:10 AM   #3
AlexFr
LQ Newbie
 
Registered: May 2010
Posts: 24

Original Poster
Rep: Reputation: 0
Thanks. I am trying to talk with echo service, port 7. There are no /etc/inetd.conf or /etc/xinetd.conf files on my computer, it uses /etc/xinetd.d directory, which contains echo file:
Code:
service echo
{
	disable		= no
	type		= INTERNAL
	id		= echo-stream
	socket_type	= stream
	protocol	= tcp
	user		= root
	wait		= no
}                                                                               

service echo
{
	disable		= no
	type		= INTERNAL
	id		= echo-dgram
	socket_type	= dgram
	protocol	= udp
	user		= root
	wait		= yes
}
Is there something I can do with this file to enable IPv6 address?
 
Old 12-02-2012, 05:42 AM   #4
mmheera
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Ubuntu, Debian, Fedora,Windows 7
Posts: 107

Rep: Reputation: 11
Try to add the following line after the protocol line to both the service files:

flags = IPv6


Then restart the xinetd and see.

Thanks!
 
1 members found this post helpful.
Old 12-04-2012, 12:49 AM   #5
AlexFr
LQ Newbie
 
Registered: May 2010
Posts: 24

Original Poster
Rep: Reputation: 0
Thanks! Adding flags = IPv6 solved the problem.
 
Old 12-04-2012, 04:23 PM   #6
mmheera
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Ubuntu, Debian, Fedora,Windows 7
Posts: 107

Rep: Reputation: 11
Good to know that it worked. You are welcome!
 
  


Reply

Tags
ipv4, ipv6


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't use ipv6 although getting address bingmou Linux - Networking 2 07-02-2009 04:58 AM
ipv6 address sarathius Programming 1 04-22-2008 02:31 PM
How to set IPv6 address on IPv6 router tlemons Linux - Networking 3 09-17-2007 01:25 PM
IPv6 address ????????? hegdeshashi Programming 3 06-19-2006 03:13 AM
getting IPv6 address lacitpo Linux - Networking 1 03-18-2005 11:09 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration