LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-03-2006, 05:35 PM   #1
Goblin82
LQ Newbie
 
Registered: Feb 2005
Posts: 20

Rep: Reputation: 0
IPv4 not there???


hey I'm trying to connect my SuSE box to my router but It's not connecting to it for some reason. I read somewhere that most routers only work on IPv4 and in order for it to work you need to disable IPv6 which I did but when I go to Devices I don't even see IPv4. Is there any way I can set this up so my internet would work.
 
Old 03-03-2006, 06:59 PM   #2
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Is your router set up for DHCS, does it assign your IP number automatically? Most routers have a setup page with will allow you to see if your IP address was assigned. When you configure your eth0 you should be able to see the gateway address of your router. If so, try pinging your router.

example: from a command line,

$ping 192.168.2.1 (or whatever address your router is)

If your machine is communicating with your router, you will see a list of "packets" being delivered and returned to you. If you see this, after a few lines, press <control><c> to stop it (or it will just continue on.)

This will tell if your router is working with your comupter. If it is, then it is just a matter of proper configuration.

Hope this helps

Bob
 
Old 03-03-2006, 07:08 PM   #3
Goblin82
LQ Newbie
 
Registered: Feb 2005
Posts: 20

Original Poster
Rep: Reputation: 0
ok, well when I said it wasn't connecting I meant that it's not comunicating with the router, I did try pinging and I did multiple tests configuring the SuSE box. My router does detect the MAC address of my ethernet card on my SuSE box but does not give it an ip address for some reason and there's no way to assign an ip manually with the router (it's a special gateway assigned by the isp). like I stated before and I'll say it again: I beleive the problem is with the IPv4 thing, I need to set my eth0 to use that and not use IPv6 but I don't know how.
 
Old 03-03-2006, 07:30 PM   #4
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
OK, knowing nothing of your router then I will say this. It's been a long time since I used SuSe (use FC4), but normally in Network Device Control you double click on the highlighted eth0. This brings up a dialog box which allows you to uncheck the box for IPv6 support leaving only IPv4 support. I would assume there is something similar in Suse.

Bob
 
Old 03-03-2006, 08:07 PM   #5
Goblin82
LQ Newbie
 
Registered: Feb 2005
Posts: 20

Original Poster
Rep: Reputation: 0
YES! there is actually, but I thought that if I disabled IPv6 then I had to enable IPv4 somehow, when I go to devices I used to have IPv6 to select for my eth0 but now I have nothing to select and my eth0 info is all at 0 or unavailable... sigh I seriously have no idea what I'm doing... LOL. I'm open to any suggestions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ipv4 to ipv6 anant_wsu Linux - Networking 1 01-03-2006 05:28 PM
Ipv4 reverse Tomanas Slackware 2 07-26-2005 05:29 AM
IPv6 to IPv4 thomjakub *BSD 1 03-06-2004 02:17 AM
IPV4 problem don_dimo Linux - Networking 5 11-01-2003 06:01 AM
IPv4 Question RecoilUK Linux - Networking 4 11-04-2001 06:13 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration