LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-16-2004, 07:27 AM   #1
vimes
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE Enterprise Server 9
Posts: 12

Rep: Reputation: 0
Ip Addresses responding on wrong NICs


Hi All,

I hope someone can be of some assistance. I have a standard Suse 9.0 installation (no extras included or removed) with three Network cards. I configured them in Yast and everything went fine. The only problem now is that although I configured each card to have only one IP address, and each card has a unique IP address, one card responds to all the IP's and the other two do not respond at all.

i.e. If remove the network cable from eth1 and eth2 and ping the box with the IP addresses of eth0 or eth1 or eth2, I get a response.

If I remove the cable from eth0 and plug in eth1 and eth2 and ping the box with the IP address of eth0 or eth1 or eth2 I get no respose.

How can this be happenig? I did a standard installation and set up the network cards with Yast, that all I did. I even re-installed Suse but that did not help. Attached is a dump from ifconfig.

Any help will be greatly appreciated.

Regards,
Adrian



eth0 Link encap:Ethernet HWaddr 00:02:B3:CB8:67
inet addr:192.168.0.25 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::202:b3ff:fecb:d867/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:288 (288.0 b)
Interrupt:11 Base address:0xdf00 Memory:feafe000-feafe038

eth1 Link encap:Ethernet HWaddr 00:07:E9:F2:CE:90
inet addr:192.168.0.222 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:fef2:ce90/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:330 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:64698 (63.1 Kb) TX bytes:288 (288.0 b)
Interrupt:11 Base address:0xde80 Memory:feafd000-feafd038

eth2 Link encap:Ethernet HWaddr 00:07:E9:F2:CE:92
inet addr:192.168.0.223 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:fef2:ce92/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:288 (288.0 b)
Interrupt:11 Base address:0xdd80 Memory:feafc000-feafc038

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2808 (2.7 Kb) TX bytes:2808 (2.7 Kb)
 
Old 10-16-2004, 08:10 AM   #2
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Please respond to the duplicate thread here
http://www.linuxquestions.org/questi...hreadid=243368

Please don't post the same thread more than once.
http://www.linuxquestions.org/rules.php
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel D845GLLY + Multiple Intel Pro 100 NICs + kernel 2.6.x = NICs don't work egable Linux - Hardware 0 02-04-2005 02:30 PM
my time is wrong and calender is also wrong Paxmaster Linux - General 6 12-16-2004 12:46 AM
Ip Addresses responding on wrong NICs vimes Suse/Novell 1 10-16-2004 07:50 AM
g++ and wrong struct member addresses / struct size misreporting sonajiso Linux - General 5 05-22-2004 10:16 PM
wrong domain IP addresses _stef_ Linux - Networking 1 05-21-2002 05:51 AM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration