LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-09-2010, 06:29 PM   #1
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
invalid eth0:1 interface and strange pan0 interface


To get Internet access I use with my ThinkPad T60 Slackware 13.1 box ASMAX AR 1004g modem-router.

[EDIT]
11th Oct 2010 at 03:00
Formerly I used binary phone line with a modem. In that configuration my modem provided Internet access on ppp0 interface leaving eth0 interface free for an internal network. My new analog modem-router provides the Internet access by default on eth0 interface. In such case I lose the internal network. After some researching I managed to find the configuration of the modem-router and the system allowing to use in the same time internal network on eth0 interface and Internet access on pan0 interface. It wasn’t my intention to use pan0 interface and I wonder how my machine can communicate with modem-router using Bluetooth interface.

Below I describe how I found that configuration and I ask three questions related to that problem.
[/EDIT]

[EDIT]
15th Oct 2010 at 16:05
The above problem was solved in posts from 2 to 5 but a new problem arose in posts from 4 to 7. It concerns the validity of my LAN and WAN network configuration. So the thread is still alive.
[/EDIT]

The first scenario – router offers private IP

In default configuration ASMAX offers IP number from 192.168.1.* private class. That IP address is invisible from Internet. Moreover in such a situation I lose my private network:

# ifconfig eth0
Code:
eth0      Link encap:Ethernet  HWaddr ba:be:de:ad:ab:ed  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: deaf:abbe:bade:dead:beef:feed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:100 errors:0 dropped:0 overruns:0 frame:0
          TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:21449 (20.9 KiB)  TX bytes:10388 (10.1 KiB)
          Memory:ee000000-ee020000
# route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
localnet        *               255.255.255.0   U     202    0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         netiabox.pl     0.0.0.0         UG    202    0        0 eth0

The second scenario – router offers public IP

Fortunately ASMAX Advanced Setup WAN configuration offers PPP IP extension option. After switching it to on ASMAX starts to offer IP number from public class. That IP address is visible from Internet. My former modem assigned public IP number to ppp0 interface so I still had local network assigned to eth0 interface. ASMAX modem-router assigns that public IP number to eth0 interface. So in that case I lose my private network too:

# ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr ba:be:de:ad:ab:ed  
          inet addr:77.23.12.31  Bcast:77.23.12.255  Mask:255.255.255.0
          inet6 addr: deaf:abbe:bade:dead:beef:feed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:107 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:22729 (22.1 KiB)  TX bytes:11455 (11.1 KiB)
          Memory:ee000000-ee020000
# route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
77.23.12.0    *               255.255.255.0   U     202    0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         77-23-12-31.a 0.0.0.0         UG    202    0        0 eth0
In both the above scenarios I enabled DHCP in the configuration file:

/etc/rc.d/rc.inet1.conf:
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

The third scenario – invalid eth0:1 interface and strange pan0 interface

After some researching I found that it’s enough switch off DHCP and set local IP to get private network working:

/etc/rc.d/rc.inet1.conf:
Code:
# Config information for eth0:
IPADDR[0]="192.168.1.2"
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
In such case dhcpcd tries to run Internet connection during boot procedures using eth0:1 interface but it fails:

/var/log/messages:
Code:
brightstar logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -t 10  eth0:1
brightstar dhcpcd: version 5.2.2 starting
brightstar dhcpcd: eth0:1: waiting for carrier
brightstar kernel: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
brightstar kernel: 0000:02:00.0: eth0: 10/100 speed: disabling TSO
In result the full output of ifconfig looks like this:

# ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr ba:be:de:ad:ab:ed  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: deaf:abbe:bade:dead:beef:feed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:330 (330.0 B)  TX bytes:468 (468.0 B)
          Memory:ee000000-ee020000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7204 (7.0 KiB)  TX bytes:7204 (7.0 KiB)

wlan0     Link encap:Ethernet  HWaddr de:ad:fa:ce:de:ed  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
# route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
localnet        *               255.255.255.0   U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
Now when I want to get Internet wired access I run dhcpcd command without any options:

# dhcpcd
Code:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: broadcasting for a lease
dhcpcd: pan0: checking for 19.24.11.12
dhcpcd: wlan0: waiting for carrier
dhcpcd: eth0: offered 87.25.19.29 from 192.168.1.254
dhcpcd: eth0: acknowledged 87.25.19.29 from 192.168.1.254
dhcpcd: eth0: checking for 87.25.19.29
dhcpcd: pan0: using IPv4LL address 19.24.11.12
dhcpcd: forking to background
In result I get an Internet access on pan0 interface keeping in the same time local network on eth0 interface:

# ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr ba:be:de:ad:ab:ed  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: deaf:abbe:bade:dead:beef:feed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:4710 (4.5 KiB)  TX bytes:3300 (3.2 KiB)
          Memory:ee000000-ee020000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:85 errors:0 dropped:0 overruns:0 frame:0
          TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7360 (7.1 KiB)  TX bytes:7360 (7.1 KiB)

pan0      Link encap:Ethernet  HWaddr ce:de:be:ad:ca:fe  
          inet addr:19.24.11.12  Bcast:19.24.255.255  Mask:255.255.0.0
          inet6 addr: cafe:babe:bade:deaf:abbe:face/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:2503 (2.4 KiB)

wlan0     Link encap:Ethernet  HWaddr de:ad:fa:ce:de:ed  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
# route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
localnet        *               255.255.255.0   U     0      0        0 eth0
87.25.19.0    *               255.255.255.0   U     202    0        0 eth0
19.24.0.0     *               255.255.0.0     U     204    0        0 pan0
loopback        *               255.0.0.0       U     0      0        0 lo
default         87-25-19-29. 0.0.0.0         UG    202    0        0 eth0

My three questions

Searching Internet I found two information: eth0:* is for network aliases and pan0 is a Bluetooth interface.

Quote:
Personal Area Networking Profile (PAN) allows Bluetooth devices to form an ad-hoc network, access a remote network through a network access point.
My machine has Ethernet, WiFi and Bluetooth devices. My modem-router has wired and wireless interface (but no Bluetooth).

So I ask you three questions:

1. Why dhcpcd tries eth0:1 interface during boot procedures?

2. How can my machine use pan0 interface to establish wired communication to my modem-router?

3. Should I worry about it?

Last edited by w1k0; 10-15-2010 at 10:05 AM.
 
Old 10-11-2010, 07:08 AM   #2
dr_agon
Member
 
Registered: Sep 2007
Location: Poland
Distribution: Ubuntu 8.04
Posts: 80
Blog Entries: 12

Rep: Reputation: 24
Quote:
Originally Posted by w1k0 View Post
1. Why dhcpcd tries eth0:1 interface during boot procedures?
I don't know, and I don't think it is important.

Quote:
Originally Posted by w1k0 View Post
2. How can my machine use pan0 interface to establish wired communication to my modem-router?
If pan0 is the name of your Bluetooth interface, than you cannot use it to get wired connection to router. You cannot connect to router via Bluetooth at all.

Quote:
Originally Posted by w1k0 View Post
3. Should I worry about it?
If it works - you can leave it as it is. You write:
Quote:
Originally Posted by w1k0 View Post
In result I get an Internet access on pan0 interface keeping in the same time local network on eth0 interface:
But I wonder if you really have internet connection via pan0 interface?

-------------
I would just connect to router via WiFi (wlan0) and to LAN via eth0.
-------------
KISS rule(z)
 
1 members found this post helpful.
Old 10-11-2010, 09:28 AM   #3
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Original Poster
Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by dr_agon View Post
I don't know, and I don't think it is important.
Thanks for calming me down.

Quote:
If pan0 is the name of your Bluetooth interface, than you cannot use it to get wired connection to router. You cannot connect to router via Bluetooth at all.
I don’t know if pan0 is the name of my Bluetooth interface in the situation described above. After some reading I know it’s the name of Bluetooth interface in general. In my case pan0 seems to communicate with my router. I wonder how it’s possible.

Quote:
If it works - you can leave it as it is.
Thanks once again.

Quote:
But I wonder if you really have internet connection via pan0 interface?
So there are two of us wondering about it.

Three programs – dhcpcd, ifconfig and route – report pan0 interface usage. The speed of Internet connection through pan0 is up to 10 Mbits/sec. After I switch my router off the Internet connection ends. So it seems pan0 co-operates with the router in my case and I wonder how it’s possible.

Quote:
I would just connect to router via WiFi (wlan0) and to LAN via eth0.
I tried that at the very beginning. When I run wlan0 Internet connection it throw my local network away from eth0 interface.

Quote:
KISS rule(z)
I know KISS rule – just see my Slackware desktop. I started with a very basic configuration. Because it didn’t work I tried different options. Finally I found the method to get LAN and WAN at the same time. It isn’t simple but it seems that it’s the simplest way of get both of them in my case.

Now I intend to buy WiFi and Bluetooth devices for my old ThinkPad T40 to make possible Internet connections working together with the local network on that machine.

Your post was helpful. Thank you once again.

I still don’t know how it’s possible for my machine to establish Internet connection to my router via pan0 interface.
 
Old 10-12-2010, 05:00 AM   #4
dr_agon
Member
 
Registered: Sep 2007
Location: Poland
Distribution: Ubuntu 8.04
Posts: 80
Blog Entries: 12

Rep: Reputation: 24
Since it works - it seems that pan0 interface name is assigned to your wireless card, not to the Bluetooth adapter, or you will not get the connection to your router. You can try to get more info from iwcofig pan0 to see if this is in fact wireless interface.

There are few things to note on the output you previously posted:
1. on pan0 you have RX bytes:0
2. route reports eth0 as default route
So unless you have some specific configuration (proxy?) you should not have internet access via pan0. Check it.

Also, unless you have a good reason, the natural way would be to connect your modem-router (preferably by wire) to whatever network device creates your LAN (switch?) and share the internet connection for all LAN/WLAN workstation. Then you would have only one network connection from each workstation. It is much easier to manage, and you can grant/restrict internet access to selected workstation if you need.

Be careful with forwarding public IP to a machine behind the router. Also note, that you cannot add second workstation (e.g. laptop) connected to internet with such configuration. I'd recommend re-organize your topology.
If you need help - write more about your LAN device and confirm that you do not want or cannot connect router to LAN.
 
1 members found this post helpful.
Old 10-14-2010, 09:16 AM   #5
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Original Poster
Rep: Reputation: 196Reputation: 196
Quote:
Since it works - it seems that pan0 interface name is assigned to your wireless card, not to the Bluetooth adapter, or you will not get the connection to your router. You can try to get more info from iwcofig pan0 to see if this is in fact wireless interface.
pan0 interface appears when I establish wired connection to Internet so it isnít assigned to my wireless card. In such circumstances wicd-curses reports ďwired-defaultĒ connection. The command you suggested reports there isnít wireless connection too.

# iwconfig pan0
Code:
pan0      no wireless extensions.
Quote:
1. on pan0 you have RX bytes:0
Thatís right.

Quote:
2. route reports eth0 as default route
Thatís right.

Quote:
So unless you have some specific configuration (proxy?) you should not have internet access via pan0. Check it.
Finally I decided to switch Bluetooth off and try to run dhcpcd command:

# dhcpcd
Code:
dhcpcd: version 5.2.2 starting
dhcpcd: wlan0: up_interface: Unknown error 132
dhcpcd: eth0: broadcasting for a lease
dhcpcd: wlan0: waiting for carrier
dhcpcd: eth0: offered 77.25.89.58 from 192.168.1.254
dhcpcd: eth0: acknowledged 77.25.89.58 from 192.168.1.254
dhcpcd: eth0: checking for 77.25.89.58
dhcpcd: eth0: leased 77.25.89.58 for 30 seconds
dhcpcd: forking to background
# ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr de:ad:ba:be:ab:ed  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 deaf:abbe:bade:dead:beef:feed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:1664 (1.6 KiB)  TX bytes:1420 (1.3 KiB)
          Memory:ee000000-ee020000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7204 (7.0 KiB)  TX bytes:7204 (7.0 KiB)
# route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
77.25.89.0     *               255.255.255.0   U     202    0        0 eth0
localnet        *               255.255.255.0   U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         77-25-89-58.ad 0.0.0.0         UG    202    0        0 eth0
As it turned out both WAN and LAN work without Bluetooth and pan0 interface:

# ping -c 3 192.168.1.4
Code:
PING 192.168.1.4 (192.168.1.4) 56(84) bytes of data.
64 bytes from 192.168.1.4: icmp_req=1 ttl=64 time=0.617 ms
64 bytes from 192.168.1.4: icmp_req=2 ttl=64 time=0.361 ms
64 bytes from 192.168.1.4: icmp_req=3 ttl=64 time=0.797 ms

--- 192.168.1.4 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.361/0.591/0.797/0.181 ms
# ping -c 3 google.com
Code:
PING google.com (74.125.39.106) 56(84) bytes of data.
64 bytes from fx-in-f106.1e100.net (74.125.39.106): icmp_req=1 ttl=54 time=225 ms
64 bytes from fx-in-f106.1e100.net (74.125.39.106): icmp_req=2 ttl=54 time=54.5 ms
64 bytes from fx-in-f106.1e100.net (74.125.39.106): icmp_req=3 ttl=54 time=55.3 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 54.555/111.813/225.561/80.432 ms
Thank you for guiding me to the solution of that problem. I was sure Bluetooth plays some role in that process. Meanwhile pan0 entry in ifconfig output means nothing. I was deluded by meaningless information displayed by the program.

Quote:
Also, unless you have a good reason, the natural way would be to connect your modem-router (preferably by wire) to whatever network device creates your LAN (switch?) and share the internet connection for all LAN/WLAN workstation. Then you would have only one network connection from each workstation. It is much easier to manage, and you can grant/restrict internet access to selected workstation if you need.
Iím afraid I donít understand your suggestion. As far I used three machines connected to the router. Each of them sees two others through local network.

Iím able to connect to Internet the first machine using wire of wireless method. Wired method I described above. So far I suspected it uses somehow Bluetooth device. Now I see pan0 interface is irrelevant.

The second machine doesnít connect to Internet. So far I thought the problem is caused by lacking of Bluetooth device. Now I see I have to find some new reason of such state of affairs.

I performed a few tests and I think Iíll start a new thread soon.

Code:
Be careful with forwarding public IP to a machine behind the router. Also note, that you cannot add second workstation (e.g. laptop) connected to internet with such configuration. I'd recommend re-organize your topology.
Is forwarding public IP to the machine behind the router insecure even when I use iptables-based firewall?

I decided to use that method because when I used private IP it overrode my local IP disabling usage of the local network. Moreover such programs as MLDonkey worked in the configuration based on private IP with low bandwidth.

Quote:
If you need help - write more about your LAN device and confirm that you do not want or cannot connect router to LAN.
Iím still not sure I understand you.

I have analog phone line. Modem-router is connected to that line by wire. Three machines are connected by wires to three Ethernet ports in the router. Each machine sees two other in the local network. The first machine connects to Internet as I described above. The second machine refuses to connect. If I donít find the solution Iíll describe it in a new thread.

Thank you very much for your last post. You helped me to resolve one of my problems. Now I know I donít have to buy Bluetooth device for the second machine.

Iím sorry I reply after two days of delay. In the meantime I struggled with some other problem.
 
Old 10-15-2010, 07:49 AM   #6
dr_agon
Member
 
Registered: Sep 2007
Location: Poland
Distribution: Ubuntu 8.04
Posts: 80
Blog Entries: 12

Rep: Reputation: 24
Quote:
Originally Posted by w1k0 View Post
As it turned out both WAN and LAN work without Bluetooth and pan0 interface:
Good, you simplified the situation

Quote:
Originally Posted by w1k0 View Post
Iím afraid I donít understand your suggestion.
OK, I got the impression, that you had some large LAN already working, and now added modem-router to it.
But you have just one modem-router and three workstations, nothing more, right?

Quote:
Originally Posted by w1k0 View Post
Is forwarding public IP to the machine behind the router insecure even when I use iptables-based firewall?
Yes, it is less secure. But you can do it if you want.

Quote:
Originally Posted by w1k0 View Post
I decided to use that method because when I used private IP it overrode my local IP disabling usage of the local network.
When you forwarded the only public IP to one of machines, other machines have no chance to get a route to WAN (all traffic must be routed through a device with public IP).

Quote:
Originally Posted by w1k0 View Post
Moreover such programs as MLDonkey worked in the configuration based on private IP with low bandwidth.
That's what port forwarding on router is meant for.

There is one more thing to check and probably simplyfy:
Dhcp offers 77.25.89.58 for eth0, yet ifconfig reports inet addr:192.168.1.2. It looks like you have 2 addresses assigned to eth0, and that would explain why you had some messages about eth0:1.

To make WAN available to all machines you must get back to the configuration with router having public IP, other machines having private IP numbers. Start from the beginning and do it step by step, all on wired connections, either all on DHCP configured on router, or all on static IP. Try to ping not the other machine on LAN, but your router first, then the default gateway configured on router (the first machine outside your LAN), then your DNS server. Then add next machine. This must work.
Cheers!
 
1 members found this post helpful.
Old 10-15-2010, 09:39 AM   #7
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Original Poster
Rep: Reputation: 196Reputation: 196
Quote:
OK, I got the impression, that you had some large LAN already working, and now added modem-router to it.
But you have just one modem-router and three workstations, nothing more, right?
That's right.

Quote:
Yes, it is less secure. But you can do it if you want.
In fact I did it already. I started with Alien’s Bob Easy Firewall Generator for IPTables using Internet interface +. Then I added to it the rules for WWW, SSH, aMule, MLDonkey and local network. By default only local network rules are switched on. The other sets of rules I switch on when I need them. For example I switch WWW rules on when I want to give someone the access to my home page stored on my machine. This is the reason for which I need a public IP address.

I’m aware that using public IP is less secure than using private IP. On the other hand my router offers dynamic IP. From my point of view it’s more secure than static IP because it makes harder to someone to collect the information about my machines.

Quote:
When you forwarded the only public IP to one of machines, other machines have no chance to get a route to WAN (all traffic must be routed through a device with public IP).
I’m starting to understand you, though I have the impression that I had two parallel Internet connections via router before I upgraded Slackware on my second machine to the newest version. Moreover with the older Slackware version on the second machine I didn’t notice the problem described in kernel: dhcpcd segfault at... I think I should to move back and try it once again from the beginning.

Quote:
Dhcp offers 77.25.89.58 for eth0, yet ifconfig reports inet addr:192.168.1.2. It looks like you have 2 addresses assigned to eth0, and that would explain why you had some messages about eth0:1.
One more doubt solved. Thank you.

Quote:
To make WAN available to all machines you must get back to the configuration with router having public IP, other machines having private IP numbers. Start from the beginning and do it step by step, all on wired connections, either all on DHCP configured on router, or all on static IP. Try to ping not the other machine on LAN, but your router first, then the default gateway configured on router (the first machine outside your LAN), then your DNS server. Then add next machine. This must work.
Now I just reply to your post. I’ll try your advices later. After that I’ll report here the results. At the moment I have some big trouble concerning my second machine. I reported it in kernel: dhcpcd segfault at... Fourtunately I have the third machine. I installed on it trimmed down Slackware 13.0 an I could use it for the tests of the Internet connection. On the other hand my second machine worked fine with Slackware 13.0 and started to fail with Slackware 13.1. So I think the better starting point is to downgrade Slackware on the second machine to 13.0 and test everything from the very beginning. As I see I have a lot tests to perform.

Thank you very much for your constant assistance, dr_agon.
 
Old 10-15-2010, 02:49 PM   #8
dr_agon
Member
 
Registered: Sep 2007
Location: Poland
Distribution: Ubuntu 8.04
Posts: 80
Blog Entries: 12

Rep: Reputation: 24
I looked at your other thread. I would just leave the dhcp and put everything on static IPs.

You are welcome to ask more if you want.
 
Old 10-16-2010, 10:54 AM   #9
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Original Poster
Rep: Reputation: 196Reputation: 196
Finally I managed to force both my machines to connect to Internet (not in the same time). I described it in the third post from kernel: dhcpcd segfault at... thread. Now I'll try your and emage's tips concerning sharing of Internet connection. I close that thread as solved. After finishing the work I'll report here how I achieved the solution.

[EDIT]
At the moment I stated I don't need to share Internet connection. It's enough for me to connect to Internet at the same time using one of my machines. So my problem is solved completely. Thank you dr_agon for your companionship. Best wishes.
[/EDIT]

Last edited by w1k0; 10-20-2010 at 03:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The interface does not exist (UBUNTU) interface eth0 not configured anshulbhatt Linux - Networking 2 11-20-2008 01:23 PM
Cannot get interface flags: Invalid argument nasim751 Linux - Software 1 04-21-2008 08:20 PM
Cannot get interface flags: Invalid argument nasim751 Linux - Software 1 04-21-2008 08:18 PM
Bringing up interface eth0 Delaying eth0 initialization. [ FA bansal_ashok Linux - Networking 4 05-27-2005 11:09 AM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM


All times are GMT -5. The time now is 09:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration