LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 06-19-2001, 08:39 AM   #1
futard
LQ Newbie
 
Registered: Jun 2001
Posts: 7

Rep: Reputation: 0
Question


ok what i have setup is a small home lan using verizon dsl, westell external modem, pppoe, tyring to set it up so this machine, running redhat 7.1 can share internet with 2 win machiens (1 95 and one 98)

dsl is working fine on redhat machine.

i have the following lines in rc.local, i have

echo "Loading the ipchains rules.."
echo 1 > /proc/sys/net/ipv4/ip_forward
echo 1 > /proc/sys/net/ipv4/ip_dynaddr

/sbin/ipchains -A forward -s 192.168.1.0/24 -j MASQ
/sbin/ipchains -P forward DENY

and i ./rc.local and it works ok.

on the 95 machine, (have not touched the 98 machine) i have its ip address set to 192.168.1.2 (98 will be 1.3, ip for linux machine is 1.1), its subnet mask to 255.255.255.0, its dns to my isp's dns, and i made up some things for domain and host.
all this is in tcp/ip options for the network adapter on the 95 machine

on the 95 machine i can ping 192.168.1.1 and it works ok, but when i load internet explorer and try to go to a site it is EXTREMELY slow, and aim just stays at 'connecting' for minutes upon end, never loading up.

any clues to whats causing htis massive slowdown?
maybe some win settings or another line i'm missing in rc.local ???

any help would be much appreciated
nick (quoting his roomate ray, who posted the same thing on dslreports)
 
Old 06-19-2001, 09:09 AM   #2
smurf
Member
 
Registered: Apr 2001
Posts: 113

Rep: Reputation: 15
Do you get a webpage up onscreen on the win95 box at all???

And have you set a gateway on the win95 machine. if not do this:-

Goto network properties
select NIC TCP/IP protocol
Select gateway tab
add the ip address of the linux box (192.168.1.1)

Hope this helps

_______________________________________
Have Fun
 
Old 06-19-2001, 09:15 AM   #3
futard
LQ Newbie
 
Registered: Jun 2001
Posts: 7

Original Poster
Rep: Reputation: 0
yeah, we did that already. I had to go to bed last night while my roommate carried the torch and worked on it so i am not 100% sure on the details. In a text message he left on my screen (which i only gave a cursory glance because i had to leave for work, where i am now) he had said that the internet DOES work only incredibly slow. I tried it real quick on the win95 machine and nothing came up in about 20-30 seconds so i left for work. I would assume though that he was able to get something to come up in the browser after a while, or at least ping a website, or something.

-nick
 
Old 06-19-2001, 11:58 AM   #4
Lardofutardo
LQ Newbie
 
Registered: Jun 2001
Posts: 3

Rep: Reputation: 0
well see

i can ping the linux machine 192.168.1.1 and it responds quickly and works

when i try to go to a webpage it just says finding site, and never connects

maybe we have the wrong dns servers in?

does the host and domain on the win95 machine have to be localhost and localdomain?

 
Old 06-19-2001, 01:13 PM   #5
futard
LQ Newbie
 
Registered: Jun 2001
Posts: 7

Original Poster
Rep: Reputation: 0
hmmm
i forget where i got those dns servers from. it was some text file... conf.dns or dns.conf or something, perhaps in /etc/bin or just /etc or i dont know. Try going to network configuration (kde menu --> system --> network configuration or something similar) and looking in there. I believe they may be listed in there.

hmm maybe try uncommenting the rc.firewall line and running that? i'm not sure how to fun it though because eye ehm dumm. looky at things on http://www.linuxdoc.org/HOWTO/IP-Masquerade-HOWTO.html
bb i dont know
 
Old 06-19-2001, 02:18 PM   #6
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
just a few thoughts

Does the linux box connect to the web fine on its own, say using Lynx or are things slow there too? I'd advise you check your DNS settings (as previously mentioned), and I've only ever tried setting the policy for ipchains before setting up any rules on the chain, you may want to look at that. I've never had to use ip_dynaddr before either.

HTH - good luck

Jamie...
 
Old 06-19-2001, 02:30 PM   #7
Lardofutardo
LQ Newbie
 
Registered: Jun 2001
Posts: 3

Rep: Reputation: 0
Re: just a few thoughts

Quote:
Originally posted by jharris
Does the linux box connect to the web fine on its own, say using Lynx or are things slow there too? I'd advise you check your DNS settings (as previously mentioned), and I've only ever tried setting the policy for ipchains before setting up any rules on the chain, you may want to look at that. I've never had to use ip_dynaddr before either.

HTH - good luck

Jamie...

yeah, the linux box is fine on the internet itself, dsl and all (i was on it when i posted that last message)

what do you mean by setting the policy for ipchains before setting the rules? we're basically going off of what someone i talked to on aim told us to do, not fully awayre of *what* it is that we were doing

i'll check the dns i guess
 
Old 06-19-2001, 02:45 PM   #8
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Re: Re: just a few thoughts

Quote:
Originally posted by Lardofutardo
what do you mean by setting the policy for ipchains before setting the rules? we're basically going off of what someone i talked to on aim told us to do, not fully awayre of *what* it is that we were doing
You currently use

/sbin/ipchains -A forward -s 192.168.1.0/24 -j MASQ
/sbin/ipchains -P forward DENY

which sets the policy of the chain (... -P forward DENY) after you setup the first rule of the chain (... -A forward -s .... -j MASQ). I've only ever seen it done around the otherway:

/sbin/ipchains -P forward DENY
/sbin/ipchains -A forward -s 192.168.1.0/24 -j MASQ

Although I would have thought that ipchains would have warned you if this caused a problem. As previously mentioned check out the IP-Masquerading HOWTO and also look at the one for ipchains at http://www.linuxdoc.org/HOWTO/IPCHAINS-HOWTO.html

HTH

Jamie...
 
Old 06-19-2001, 03:28 PM   #9
futard
LQ Newbie
 
Registered: Jun 2001
Posts: 7

Original Poster
Rep: Reputation: 0
ray: all the ip masq lines are in that /etc/rc.d/rc.firewall file that we commented out when working on it the other day. i'd say to try deleting (or just commenting out) those other lines and re-enabling the rc.firewall and follow the instructions at http://www.linuxdoc.org/HOWTO/IP-Mas...O-3.html#ss3.3 to make it an executable and execute it and such, than doe the tests in that page to try to test it. Whatever, you're probably at work now anyway, and i will be home in a few hours. we will get this working tonight by crikey.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with Internet connection sharing between Windows XP and Linux DownloadTHIS Linux - Networking 1 08-28-2005 08:45 PM
Internet Connection Sharing backroger Linux - Networking 2 02-25-2005 01:13 AM
Internet sharing and dhcp trouble iceaway Mandriva 2 03-12-2004 04:50 PM
Still having trouble with Connection Sharing... Volcom Linux - Networking 3 09-28-2003 09:24 AM
Internet Connection Sharing qsilver Linux - Networking 1 07-19-2001 02:31 AM


All times are GMT -5. The time now is 11:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration