LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Internet connection sharing help...using USB modem & Network card (http://www.linuxquestions.org/questions/linux-networking-3/internet-connection-sharing-help-using-usb-modem-and-network-card-172576/)

Daz155HGT 04-20-2004 02:24 PM

Internet connection sharing help...using USB modem & Network card
 
I am running Mandrake v10...

I have a USB broadband modem, which i am using to connect to the internet which is working fine...

I also have a network card which i want to use to share my internet connection to the other PC's on my home network...

If i use the ifconfig -a command it shows 3 items...2 network cards, and a loopback adapter...

On 1 network card, it gives an IP address which i know is my USB broadband modem, and on the other network card it doesnt have an IP address...

This is where i get stuck, I am a very new user of linux so please be gentle...

Thanks in advance...

Darren

jmmoss 04-20-2004 03:45 PM

Help Needed as well....
 
I am in the same boat as you were or are, did you ever find out how to get it to work? Thank you.

Daz155HGT 04-20-2004 03:59 PM

Not really m8...

I have looked though some other posts, and the only thing i could find was this...

At the command line type...
make load
ifconfig eth0 up

I am a complete novice (only installed linux yesterday), so this may be way off track...lol

I havent had a chance to try it yet...

Darren

rustyimp 04-20-2004 10:26 PM

i hope this helps
 
hello saw your reply im kinda new to linux my self and i use Slackware what kind of card are your trying to use a lan pci nic if so you need to set the ip address in slackware its ifconfig etho (for your first card your second replace etho with eth1) so when you open a shel you should type somthing like this
ifconfig -a eth1 192.168.0.1 thats sets your ipaddress for you local network on your card then just type ifconfig to see if the ip was set now to route the traffic between the 2 networks you should then type in the shell (make sure ipv4 is set up in your kernel as weel)next what you need to do is set up you linux box to do is route the traffic between the 2 networks to enable ipv4_forward on a runnning system in the shell you need to type this command echo 1 > /proc/sys/net/ipv4/ip_forward
to keep it up and ruuning after you shut down or send a HALT signel to the system you need to go into your /etc/rc.d/rcinet2. and change the line
IPV4_FORWARD=0 to IPV4_FORWARD=1 0 mean no routing 1 means yes to routing and hopefully that should do it now remember i use Slackware it might be different for you Distrabution of linux if this doesent work contact the people you got your distro from and also you8 should check your man pages that came with it that specificly deal with networking personaly i love this kinda stuff and im planing on going to college to get a degree in networking if you want let me know if this was helpfull and i hope it was asta

Daz155HGT 04-22-2004 02:16 PM

Thanks for your help...i can now ftp and ping my Linux machine from my other windows machines and my xbox on my local network :)

But i still cannot share my internet connection :(

Where you said to do the following...

"you need to go into your /etc/rc.d/rcinet2. and change the line
IPV4_FORWARD=0 to IPV4_FORWARD=1 0 mean no routing 1 means yes to routing and hopefully that should do it"

...I havent got this file...'rcinet2.'...why haven't i got this file? (i guess i need to install something?)

Any help from anyone would be appreciated, as i think i am almost there...

Daz

Dasha 04-28-2004 06:54 AM

Hi,

I am very new to linux myself.....however I have managed to set up Internet Connection sharing from my Linux box (which connects to the internet via 128k ISDN connection) to my Notebook running Windows XP. After reading LQ I managed to pick up quite a bit of info....however, searching in google I came across this site which tells u how exactly to set up IP Masquerade which is what u need.

http://www.ibiblio.org/pub/Linux/doc...PMASQ-INTRO1.0

Bacially I set up my Eth0 (on linux) with these settings
IP : 192.168.0.1
Subnet : 255.255.255.0
Gateway : 192.168.0.1

Windows with these :
IP : 192.168.0.2
Subnet :255.255.255.0
Gateway : 192.168.0.1

DNS :
Primary - Obtain from your ISP or from /etc/resolv.conf
Secondary - Obtain from your ISP or from /etc/resolv.conf

then after uv set up Masquerade as per the website, run /etc/rc.d/rc.firewall-2.* if thats your kernel. Make sure u set the devices in your rc.firewall-2.* script correctly :
ie .
EXTIF="ppp0"
INTIF="eth0"
echo " External Interface: $EXTIF"
echo " Internal Interface: $INTIF"

And u should have internet sharing. Hope this helps some.

Cheers

Dasha

mermxx 04-28-2004 01:44 PM

In windoze u may want to go to lan connections and also add proxy connections
ie ur linux ip address and ports 80 http 1080 socks...etc, if u r still having probs connecting


All times are GMT -5. The time now is 04:38 PM.