LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-10-2010, 08:22 AM   #1
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Rep: Reputation: 15
Internet connection fine in Windows, extremely slow in Fedora 14, router?


Hello all,

I've been troubleshooting this problem for several hours now and I'm out of ideas. My internet connection is fine in Windows 7 but an older computer I resurrected (AMD Athlon 1.7 GHz, 512 MB RAM, Fedora 14 Security Lab Spin) is having the stop-and-go's with its internet connection. It will work for very briefly, then it gets extremely slow, where any page I try to navigate to in Firefox 3.6 takes forever to load.

I have a DSL connection and my DSL modem is connected to a Linksys WRT54G2 router. I set up a static IP in Windows but don't know how to do this yet in Fedora 14, and I need to get my internet connection working so I can troubleshoot further, but with it being so slow, I'm having to use Windows to search for problems and then switch over to the Fedora box via KVM (IOGEAR), which I also just started using. I don't think that would be related, but who knows.

pinging seems to work, the router has DHCP enabled... is there any other information that would help?

Thanks
 
Old 12-10-2010, 08:31 AM   #2
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
To give more details on what I've been trying:

--I assigned the router as a dns server as well as openDNS servers with "nameserver <IP address>" in resolv.conf

--I set up a firewall and I believe it's correct, not sure how to test it fully

--I can access my router and the Fedora computer's MAC address has been added to an internet access policy to allow at all times and days

--I tried 'service network restart' but it's still running very slow after multiple restarts
 
Old 12-10-2010, 08:38 AM   #3
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,753

Rep: Reputation: 189Reputation: 189
Firefox has a javascript problem in version 3 that slows it way down. Disable Javascript in preferences and it will fly again. It you have to have it then use it or use another browser. Version 4 beta is suppose to have a new javascript engine that works faster.

As far as configuring a fixed IP on that Linux box, thats a snap.
Look at
man ifconfig
man route
Something like
Code:
#ifconfig dc0 172.15.0.6 netmask 255.255.255.0
Code:
#route add 172.15.0.1

Your distro will keep it's config files in it's own place
This should help

http://www.linuxhomenetworking.com/
http://www.linuxhomenetworking.com/w...nux_Networking
 
Old 12-10-2010, 08:46 AM   #4
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,753

Rep: Reputation: 189Reputation: 189
You may want to use the DNS server of your ISP instead of the router. Although that's how I usually do it also.

Does a ping to Yahoo for example give normal times? How about a ping to it's IP address? Is it just the web browser that is slow or is the whole network connection lazy?

If it's the browser then see above. If it's the whole network connection then look at how the card is configured.
man ethtool
See if it's set at 10 mb instead of wide open.

Also look and see if there has been problems with the device module that Linux uses. Broadcom for example usually bites becuase they won't release any info so the linux modules can be made. The ones we have been reverse engineered by some bright people. But still might not work well. Solution, put another card in it.
 
Old 12-10-2010, 09:10 AM   #5
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
I disabled Javascripts but no improvement. I will get back once I've set up a static IP.
 
Old 12-10-2010, 09:17 AM   #6
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,753

Rep: Reputation: 189Reputation: 189
While we are on Firefox some in this thread

Here are some Tips-Tricks that can help you double the speed of Firefox.

1. Type about:config in the address bar and then press Enter.

2. In the filter search bar type network.http.pipelining. Be sure the value field is set true,if not double-click to set true.

HTTP is the application-layer protocol that most web pages are transferred with. In HTTP 1.1, multiple requests can be sent before any responses are received. This is known as pipelining. Pipelining reduces page loading times, but not all servers support it.

3. Go back to the filter search bar and type network.http.pipelining.maxrequests. Double-click this option and set its value to 8.

4. In the filter search bar and type network.http.proxy.pipelining. Once opened double-click on it and set it to true.


5. In IPv6-capable DNS servers, an IPv4 address may be returned when an IPv6 address is requested. It is possible for Mozilla to recover from this misinformation, but a significant delay is introduced.
Type network.dns.disableIPv6 in the filter search bar and set this option to true by double clicking on it.

6. CONTENT INTERRUPT PARSING
This preference controls if the application will interrupt parsing a page to respond to UI events. It does not exist by default.
Right-click (Apple users ctrl-click) anywhere in the about:config window, select New and then Boolean from the pop-up menu. Then:

A. Enter content.interrupt.parsing in the New boolean value pop-up window and click OK

B. When prompted to choose the value for the new boolean, select true and click OK.

7. Rather than wait until a page has completely downloaded to display it to the user, Mozilla applications will regularly render what has been received to that point. This option controls the maximum amount of time the application will be unresponsive while rendering pages.

Right-click (Apple users ctrl-click) anywhere in the about:config window, select New and then Integer from the pop-up menu.

A. Enter content.max.tokenizing.time in the New integer value pop-up window and click OK

B. You will be prompted to enter a value. Enter 2250000 and click OK.

8. CONTENT NOTIFY INTERVAL

This option sets the minimum amount of time to wait between reflows. Right-click (Apple users ctrl-click) anywhere in the about:config window, select New and then Integer from the pop-up menu.

A. Type content.notify.interval in the New integer value pop-up window and click OK.

B. You will be prompted to enter a value. Enter 750000 and click OK.

9. CONTENT NOTIFY ONTIMER

A. This option sets if to reflow pages at an interval any higher than that specified by content.notify.interval. Right-click (Apple users ctrl-click) anywhere in the about:config window and select New and then Boolean from the pop-up menu.

B. Type content.notify.ontimer in the New boolean value pop-up window and click OK.

C. You will be prompted to choose the value for the new boolean. Select true and click OK.

10. Notify Backoffcount
This option controls the maximum number of times the content will do timer-based reflows. After this number has been reached, the page will only reflow once it is finished downloading. Right-click (Apple users ctrl-click) anywhere in the about:config window and select New and then Integer from the pop-up menu.

A. Enter content.notify.backoffcount in the New integer value pop-up window and click OK.

B. You will be prompted to enter a value. Enter 5 and click OK.

11. CONTENT SWITCH THRESHOLD
You can interact with a loading page when content.interrupt.parsing is set to true. When a page is loading, the application has two modes: a high frequency interrupt mode and a low frequency interrupt mode. The first one interrupts the parser more frequently to allow for greater UI responsiveness during page load.

The low frequency interrupt mode interrupts the parser less frequently to allow for quicker page load. The application enters high frequency interrupt mode when you move the mouse or type on the keyboard and switch back to low frequency mode when you had no activity for a certain amount of time. This preference controls that amount of time. Right-click (Apple users ctrl-click) anywhere in the about:config window and select New and then Integer from the pop-up menu.

A. Enter content.switch.threshold in the New integer value pop-up window and click OK.

B. You will be prompted to enter a value. Enter 750000 and click OK.


12. NGLAYOUT INITIALPAINT DELAY
Mozilla applications render web pages incrementally, they display what’s been received of a page before the entire page has been downloaded. Since the start of a web page normally doesn’t have much useful information to display, Mozilla applications will wait a short interval before first rendering a page. This preference controls that interval. Right-click (Apple users ctrl-click) anywhere in the about:config window and select New and then Integer from the pop-up menu.

A. Enter nglayout.initialpaint.delay in the New integer value pop-up window and click OK.

B. You will be prompted to enter a value. Enter 0 and click OK.
 
Old 12-10-2010, 09:23 AM   #7
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
A ping to yahoo gives an avg of 80 ms, which is the same as in Windows. A ping to yahoo's IP (what I found was 69.147.76.15), didn't return at all.

The whole network connection is slow (in Linux-- Windows is fine, as mentioned before).

It looks like ethtools isn't installed... I'm looking into that. The NIC is onboard Yukon... 2 ports... I switched and it seemed fine very briefly. ASUS A7N8X-E motherboard. I have a Linksys NIC but it's from around 2000... would it be worth a try or too old?

teckk -- thanks for posting the Firefox tips. I went through all of them and will also do so in Windows, thanks!







Quote:
Originally Posted by teckk View Post
You may want to use the DNS server of your ISP instead of the router. Although that's how I usually do it also.

Does a ping to Yahoo for example give normal times? How about a ping to it's IP address? Is it just the web browser that is slow or is the whole network connection lazy?

If it's the browser then see above. If it's the whole network connection then look at how the card is configured.
man ethtool
See if it's set at 10 mb instead of wide open.

Also look and see if there has been problems with the device module that Linux uses. Broadcom for example usually bites becuase they won't release any info so the linux modules can be made. The ones we have been reverse engineered by some bright people. But still might not work well. Solution, put another card in it.

Last edited by mbvpixies78; 12-10-2010 at 09:39 AM.
 
Old 12-10-2010, 09:49 AM   #8
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
The most likely culprit is the IPv6 support in Firefox slowing down the lookups. If you ping TTS is the same as in Windows, then it looks like the connection is fine, it's just browsing that's slow. So, I'd make sure ipv6 support in Firefox is disabled, in about:config, as explained by teckk (number 5 in the list above).
 
Old 12-10-2010, 10:17 AM   #9
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,753

Rep: Reputation: 189Reputation: 189
69.147.76.15 isn't answering the ping. Yahoo could have that disabled.
Code:
whois 69.147.76.15
..........
NetRange:       69.147.64.0 - 69.147.127.255
CIDR:           69.147.64.0/18
OriginAS:
NetName:        A-YAHOO-US5
NetHandle:      NET-69-147-64-0-1
Parent:         NET-69-0-0-0-0
NetType:        Direct Allocation
NameServer:     NS2.YAHOO.COM
NameServer:     NS1.YAHOO.COM
......................
69.147.125.65 did. Which is what I got from yahoo.com

In short if you can ping by IP and DNS then it works.

Have you tried another browser in Linux other than Firefox?

No offense to Firefox fans but Firefox since version 3 needs help. 4 is suppose to fix some things. Look at the IP6 in Firefox too.

Then there is flash block, add block, no javascript which will sped things. Take a look at Dillo. No frame support though. Then there is Opera, well....choose what you find and like.

Last edited by teckk; 12-10-2010 at 10:19 AM.
 
Old 12-10-2010, 09:40 PM   #10
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pwc101 View Post
The most likely culprit is the IPv6 support in Firefox slowing down the lookups. If you ping TTS is the same as in Windows, then it looks like the connection is fine, it's just browsing that's slow. So, I'd make sure ipv6 support in Firefox is disabled, in about:config, as explained by teckk (number 5 in the list above).
I applied all the suggested changes for Firefox from teckk in about:config but still no change for the better.
 
Old 12-10-2010, 10:21 PM   #11
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 281

Rep: Reputation: 46
One thing that you have not mentioned. Are you wired, or wireless? If you are wireless are you sure that you are connected to your AP, and have you tried being directly connected to the router?
 
Old 12-11-2010, 01:00 AM   #12
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
I can't get any man page to load on ifconfig-- what do I need to do to make sure all man pages are accessible from the command prompt?

Also of somewhat less importance, how do I enable help pages in the Fedora GUI? None of them seem to work.




Quote:
Originally Posted by teckk View Post
Firefox has a javascript problem in version 3 that slows it way down. Disable Javascript in preferences and it will fly again. It you have to have it then use it or use another browser. Version 4 beta is suppose to have a new javascript engine that works faster.

As far as configuring a fixed IP on that Linux box, thats a snap.
Look at
man ifconfig
man route
Something like
Code:
#ifconfig dc0 172.15.0.6 netmask 255.255.255.0
Code:
#route add 172.15.0.1

Your distro will keep it's config files in it's own place
This should help

http://www.linuxhomenetworking.com/
http://www.linuxhomenetworking.com/w...nux_Networking
 
Old 12-11-2010, 01:03 AM   #13
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
I disabled wireless for security and am using RJ-45's connected to the router which is connected to the DSL modem. My printer is the only thing with a wireless receiver at this time, aside from the router itself. I'll get the printer set up to serve all the computers wirelessly after I figure out the browser speed issue.

Quote:
Originally Posted by grim76 View Post
One thing that you have not mentioned. Are you wired, or wireless? If you are wireless are you sure that you are connected to your AP, and have you tried being directly connected to the router?
 
Old 12-11-2010, 01:08 AM   #14
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
teckk:

I'm able to ping the yahoo IP you mention below (69.147.125.65) as well as by directly pinging yahoo.com, both with good speed.

I'm trying to get man pages working so I can learn about ifconfig.


Quote:
Originally Posted by teckk View Post
69.147.76.15 isn't answering the ping. Yahoo could have that disabled.
Code:
whois 69.147.76.15
..........
NetRange:       69.147.64.0 - 69.147.127.255
CIDR:           69.147.64.0/18
OriginAS:
NetName:        A-YAHOO-US5
NetHandle:      NET-69-147-64-0-1
Parent:         NET-69-0-0-0-0
NetType:        Direct Allocation
NameServer:     NS2.YAHOO.COM
NameServer:     NS1.YAHOO.COM
......................
69.147.125.65 did. Which is what I got from yahoo.com

In short if you can ping by IP and DNS then it works.

Have you tried another browser in Linux other than Firefox?

No offense to Firefox fans but Firefox since version 3 needs help. 4 is suppose to fix some things. Look at the IP6 in Firefox too.

Then there is flash block, add block, no javascript which will sped things. Take a look at Dillo. No frame support though. Then there is Opera, well....choose what you find and like.
 
Old 12-11-2010, 02:04 AM   #15
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
ethtool

Ok, I installed and ran ethtool with following output which seems fine:

Quote:
Originally Posted by mbvpixies78 View Post
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: pg
Wake-on: g
Current message level: 0x00000037 (55)
Link detected: yes

Last edited by mbvpixies78; 12-11-2010 at 02:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extremely Slow Internet Connection on Slack technik733 Linux - Software 5 05-25-2009 04:12 PM
Windows internet connection fine, FC 5 can't connect to DSL modem rreece Linux - Networking 15 11-03-2006 07:05 PM
SUSE 10.0 extremely slow internet connection! what is wrong? tamere Suse/Novell 20 02-02-2006 07:30 AM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
Extremely slow kppp internet connection msisto Linux - Newbie 2 09-10-2003 03:57 PM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration