LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-04-2007, 01:26 AM   #1
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Rep: Reputation: 15
Internet connection died in openSuSE


Ok, here's my story... my internet has just simply stopped working in openSuSE. I was browsing the internet, and had yast downloading some things for me. I also had xchat and kopete running. It was at this point that the internet just died. At first, I thought little of it, as my internet dies a lot here. But after an hour I began to wonder, so I rebooted, but to no avail. I tried restarting the modem etc, and finally I booted to Windows and found that the internet would work in XP. Thinking that the internet was working again(whenever it dies, all I can do is wait for it to come back), I booted back to openSuSE and lo and behold, no internet. At this point I have tried everything I can think of, but I still cannot get my internet working. To be clear, it's not just browsing, it's everything, IRC, instant messaging, yast, the works. There is simply no internet connection available anymore. I have restarted a couple times, booting back and forth between XP and openSuSE, and Windows has internet, while openSuSE does not. I really have no idea how this could have happened, is there a way to check and see if the network stuff is running in openSuSE or something? I don't know much about network related things.
 
Old 01-04-2007, 01:35 AM   #2
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Well, pop open a console and type these commands. If you don't know what the output means, just post it and we'll be glad to interperet.

To test if you truly do have network connection:
Code:
ping www.google.com
To see what your computer has your networking hardware doing
Code:
su
<enter your root password>
ifconfig
 
Old 01-04-2007, 01:49 AM   #3
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Ok, I pinged google and it came up with "unknown host - www.google.come"

I did the other thing too, but I'm still trying to come up with a viable way to get it on here, besides writing it down by hand and then typing it back in after booting to Windows. I tried burning it to a DVD-RW, but of course Windows can't read it, so that's out. I'll get it up here in a few minutes even if I do have to handwrite it, though.
 
Old 01-04-2007, 01:56 AM   #4
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
if it couldn't resolve google into an IP address, then you aren't connected to a network, so the output of ifconfig will help us see why.
 
Old 01-04-2007, 02:04 AM   #5
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Code:
eth0      Link encap:Ethernet  HWaddr 00:17:31:3B:D2:1E
          inet addr:70.128.115.215  Bcast:70.128.115.223  Mask:255.255.255.240
          inet6 addr: fe80::217:31ff:fe3b:d21e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:840 (840.0 b)  TX bytes:1014 (1014.0 b)
          Interrupt:233 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:39 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2885 (2.8 Kb)  TX bytes:2885 (2.8 Kb)
 
Old 01-04-2007, 02:07 AM   #6
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Okay, so you've been given an IP address. Perhaps your network is set up to use DCHP and you somehow got stuck with a fixed address. Try

dhclient eth0

and see if that changes anything.
 
Old 01-04-2007, 02:15 AM   #7
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Yes! That output some stuff to console, and I checked, and I have an internet connection now. Thanks a lot!
 
Old 01-04-2007, 02:19 AM   #8
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Hold on now, that fixed it now, but it will be broken again next time you reboot. In OpenSuse you configure everything in YAST, no? So, you need to find network settings of some kind, and where it asks about connection type for eth0, it will currently say something like "fixed IP" and then an IP address. you need to change that option to "dynamic IP" via DCHP. (The wording will probably vary) Of course, if you need to get back online in linux for more help, that command will always work again, but if you configure in YAST, you won't have to type that every time you want to get online.
 
Old 01-04-2007, 02:39 AM   #9
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Ok, near as I can tell, what I need is the DNS and Hostname Network Service configuration window in the YaST Control Center. When I run this after running dhclient, it gives me a window saying this:

The resolver configuration file (/etc/resolv.conf) has been temporarily modified by /sbin/dhclient. You have two options:
Modify the current (changed) version of the file.
Press 'Accept' now and continue editing other (nonresolver) data. You could return to this dialog later when the above service has terminated.

Either option I accept, there's a checkbox called Change Hostname Via DHCP. It is both checked and greyed out. I tried rebooting and opening up this window before running dhclient, and this prevented the popup window, but the checkbox is still greyed out. Anyway, does that sound like the right thing?
 
Old 01-04-2007, 02:43 AM   #10
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Well, it sounds right. As long as you have internet access, I guess it is right. :-)
 
Old 01-04-2007, 02:46 AM   #11
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Well, I still have to do the dhclient thing every time I reboot. This is very strange, I had never even seen these config windows before this, I didn't change any options. How on earth did my system randomly get like this?
 
Old 01-04-2007, 02:56 AM   #12
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
I have no idea what might have caused the change. I hope some Suse user comes by this thread and can tell you what to change in YAST. At least now you have internet, but I hope we can make it more convenient for you.
 
Old 01-04-2007, 03:03 AM   #13
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks for the help, at least now I have internet. It's a bit inconvenient, but at least I don't have to reboot to get internet now, haha. Now I wait for someone with suse to come along
 
Old 01-04-2007, 03:05 AM   #14
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
perhaps try going to the suse subforum and asking:

How do I use Yast to configure my network to automatically fetch an IP with DHCP?

That's where all the suse users hang out.
 
Old 01-04-2007, 03:12 AM   #15
Dark_Oppressor
Member
 
Registered: Apr 2005
Location: Oklahoma, USA
Distribution: Linux Mint
Posts: 45

Original Poster
Rep: Reputation: 15
Ok cool, I did that, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet connection suddenly died, I can't even get to the router! The MJ Linux - Software 2 08-13-2006 08:33 PM
fedora core 4 --UPS died and so is my LAN connection mhykgyver Linux - Networking 1 06-16-2006 12:53 AM
MX record probelm connection died.(#4.4.2) AZIMBD03 Linux - Networking 4 12-09-2004 12:27 PM
Network connection suddenly died KingofBLASH Linux - Networking 1 01-02-2004 12:41 PM
connection died unexpected jamaso Linux - Newbie 2 11-11-2001 07:26 PM


All times are GMT -5. The time now is 04:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration