LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-02-2010, 03:23 PM   #1
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
Question Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button


I have a Dell XPS 1640 with an Intel Corp. PRO/Wireless 5300 AGN wifi card. When i press the radio on/off button, fedora goes to a screen with the fedora logo, starts blinking the caps lock and becomes completely non-responsive to keypresses or mouse. I have to shut it down after.

So, how do I make the radion on/off button work correctly?

Quote:
# lspci | grep Intel
04:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection

# iwconfig | grep wlan

wlan0 IEEE 802.11abgn Mode:Managed Access Point: Not-Associated
Tx-Power=15 dBm
Retry long limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff

# lsmod|grep wmi
dell_wmi 1561 0
wmi 5620 1 dell_wmi
 
Old 08-03-2010, 09:19 AM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Original Poster
Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
any ideas?
 
Old 08-04-2010, 11:04 AM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Original Poster
Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
Any pointers?
 
Old 08-05-2010, 10:12 AM   #4
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Original Poster
Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
Come on. 3 days and not a single idea?
 
Old 08-12-2010, 09:30 AM   #5
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Original Poster
Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
Angry

Well, if anyone runs into this thread, looking for help with this issue -- I'm sorry to report that there is none. No one has any help to give on the issue.

I do have a solution for you that worked for me.

Uninstall Fedora and install Ubuntu. For the XPS 1640 all the drivers are already there, unlike Fedora.
 
Old 08-30-2010, 10:33 AM   #6
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,391
Blog Entries: 1

Original Poster
Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
Update: Fedora 13 does the same crap.

Stick to Ubuntu,.. Fedora sucks. Oh, and support for fedora? Its laughable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BackTrack 4 wireless problem (Intel wifi link 5100 AGN) kevinx17910 Linux - Newbie 1 06-06-2010 09:02 PM
Intel Wifi Link 5100 AGN - Fix unrecognized KairosDrasis Linux - Hardware 7 05-23-2010 01:28 AM
My Intel(R) Wifi Link 5100 AGN - not detected ohmeng Linux - Newbie 8 05-21-2010 03:59 AM
intel wifi 5100 agn not detected!!! mankaragian Linux - General 10 05-04-2010 03:22 PM
Intel WiFi Link 5300 on Debian Etch lindylex Debian 0 10-03-2008 05:11 PM


All times are GMT -5. The time now is 03:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration