LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 11-29-2004, 09:22 PM   #1
johnfg
LQ Newbie
 
Registered: Mar 2004
Location: Hazelton, Idaho USA
Posts: 15

Rep: Reputation: 0
Intel ProWireless 2200BG


I posted within another post and I don't think anyone saw it! I am running Fedora Core 3 on an Asus Z9000. I cannot get the wireless card working correctly. I'm trying ipw2200, it seems to have installed fine, and the card is recognized. But here's what's happening when I try to bring it up:
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not supported.

Here's what I have in ifcfg-eth1

DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:0e:35:51:a6:3c
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=192.168.0.5
DOMAIN=
USERCTL=no
PEERDNS=no
GATEWAY=192.168.0.1
TYPE=Wireless
IPV6INIT=no
ESSID=Motorola
CHANNEL=1
MODE=Auto
RATE=Auto

Please help me to get wired!

Thanks! John
 
Old 11-29-2004, 09:49 PM   #2
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Rep: Reputation: 30
I had similar problems with ipw2100 and FC2 (I'm running FC3 now, but haven't had chance to try the ipw2100 drivers yet).

Anyway, first check to see if you have the module installed for your wireless card:

Code:
#lsmod |grep -i ipw2200
If you get no result, then you need to load your module by hand:

Code:
#modprobe ipw2200
If you didn't get any errors, then check again to see if the module is loaded. If all went well, then just use the network settings tool to bring up the settings for your wireless card.

To have the ipw2200 module load at boot up, edit your /etc/rc.d/rc.sysinit. Locate the lines in that file that look like this:

Code:
echo -n $"Initializing hardware... "

ide=""
scsi=""
network=""
audio=""
other=""
and add your wireless module like this:

Code:
echo -n $"Initializing hardware... "

ide=""
scsi=""
network="ipw2200"
audio=""
other=""
Hope this works for you.
 
Old 11-29-2004, 10:50 PM   #3
johnfg
LQ Newbie
 
Registered: Mar 2004
Location: Hazelton, Idaho USA
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks, but no banana!

I did everything you suggested: the module is there, loaded and loading after a reboot. But I'm still getting the same error message that I listed above.

Any other ideas?

And thanks very, very much for your help!

john
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 2200BG and Slackware 10.1 darkarcon2015 Slackware 8 07-15-2005 11:57 PM
Intel 2200bg littlebeagle Linux - Wireless Networking 1 05-12-2005 03:08 AM
Intel 2200BG wireless problems idahoakl Suse/Novell 4 03-12-2005 08:24 AM
Installing Intel 2200bg in Suse 9.2 billdwyer Linux - Wireless Networking 25 01-21-2005 11:32 PM
Intel 2200BG support in FreeBSD Lurker01 *BSD 5 10-25-2004 08:38 AM


All times are GMT -5. The time now is 11:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration