LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-23-2008, 05:57 AM   #1
alfmarius
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
Installing Debian etch with usb pen - "ethernet card not found"


OK, I feel I have tried everything, so now I'm desperate for some help.

After struggling many hours setting up/finding the correct etch image for booting from a usb pen to install etch, I made it work in the end!

So now I'm booting up debian (yeey!) and when about to configure the network I get the "ethernet card not found" in my face. Depressing. I've searched everywhere, but not found any help.

Details:

I downloaded:
ftp://ftp.debian.org/debian/dists/et...ia/boot.img.gz
and did a 'zcat boot.img.gz > /dev/sdb

booting from the usb, linux starts and i get the menu. I want to setup my ethernet card so i do a "Detect network hardware", and get the incredible "ethernet card not found". I tried to put another super-compatible NIC inside, but same message.

My two ethernet cards are (cut n paste from 'lspci')

Ethernet controller: Intel Corporation 82547EI Gigabit Ethernet Controller (LOM)
Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)

...so linux know about the cards but cant find them..hmm

modprobe <just about anything i try> gives "FATAL: Module x not found."

Please, pick me down from the wall and help me

Alf
 
Old 06-24-2008, 06:53 AM   #2
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
not sure, but did you forget to add the install cd itself? it seems to me you only have the image to boot, but not the installation image

did this myself before and kept my notes as below.

Code:
make a debian installation usb

To download the installer we do as follows

$ wget http://ftp.nl.debian.org/debian/dists/etch/main/installer-amd64/current/images/hd-media/boot.img.gz

and we will also need the same iso file as when making an installation cd

$ wget http://cdimage.debian.org/debian-cd/4.0_r2/amd64/iso-cd/debian-40r2-amd64-netinst.iso

The exact mountpoint of the usb can be found with

$ fdisk -l

Assuming your usb is mounted as /dev/sda we can extract the boot.img.gz to the usb stick.

$ zcat boot.img.gz > /dev/sda

Then mount the usb.

# mount /dev/sda /mnt

when this is done simply copy the .iso to the same usb disk

# cp debian-40r2-amd64-netinst.iso /mnt

and then unmount the usb stick

# umount /mnt
 
Old 06-24-2008, 09:35 AM   #3
alfmarius
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Randall Slack View Post
not sure, but did you forget to add the install cd itself? it seems to me you only have the image to boot, but not the installation image
Thats it

I got mine from here:
http://cdimage.debian.org/debian-cd/...86-netinst.iso
..put it on the usb stick and voila!

A comment to this is that it seems strange to me that one have to download a 160 MB image to get the network going (yes for sure other things are in that image, but still). Why don't "they" make an image superstripped that just get everything off the net during install..

Thanks for helping mate!

Alf
 
Old 06-24-2008, 09:51 AM   #4
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
well....

luckily "they" already did, i suppose the 6mb mini.iso
http://ftp.nl.debian.org/debian/dist...mages/netboot/
would have done the trick as well instead of the 160mb netinstall.

guess i could have pointed this out to you earlier but the possibility slipped my mind
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Installing Debian Etch From A Windows System With "Debian-Installer Loader" LXer Syndicated Linux News 0 09-28-2007 12:41 AM
can't get "usb to ethernet" card to work samel_tvom Linux - Hardware 12 01-16-2006 02:25 PM
can't get supported "usb to ethernet" card to work samel_tvom Linux - Networking 0 01-11-2006 10:44 AM
"Skin not found" problem from installing Mplayer in Debian/Sarge !!! Blue Jacket Linux - Software 2 10-05-2005 01:58 AM
Debian "etch" install problems - no NIC found SharkeyNor Debian 2 08-14-2005 04:12 AM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration